Sign in to follow this  
Followers 0
Regency

Ie debug mode says does not exist..

2 posts in this topic

Like, i have it open the parent ie window, then opens a embedded for a image, then i write something about it and it saves it and exits the gui, but i want it to call upon the old parent window to do as this script cays.. what am i doing wrong?

#include <GUIConstantsEx.au3>
#include <IE.au3>
#include <WindowsConstants.au3>
#AutoIt3Wrapper_Run_Debug_Mode=Y
Global $Url = ""
Global $A1 = ""
Global $P1 = ""
Global $tmnx = ''

$Tmnx = _iecreate($Url,0,1,1,0)
_IELoadWait($Tmnx)
$oImg = _IEImgGetCollection($Tmnx,0)
$sInfo = $oImg.src


_IEErrorHandlerRegister ()

$oIE = _IECreateEmbedded ()
GUICreate("Embedded Web control Test", 450, 300, _
        (@DesktopWidth - 640) / 2, (@DesktopHeight - 580) / 2, _
        $WS_OVERLAPPEDWINDOW + $WS_VISIBLE + $WS_CLIPSIBLINGS)
$Desired = GUICtrlCreateGroup("Enter Captcha Answer",8,225,425,49)
$username = GUICtrlCreateInput("", 16, 241, 114, 21)
$savename = GUICtrlCreateButton("Save", 168, 241, 75, 25, 0)
GUICtrlCreateGroup("", -99, -99, 1, 1)
$Relogin = GUICtrlCreateButton("Start", 300, 241, 75, 25, 0)
$GUIActiveX = GUICtrlCreateObj($oIE, 10, 10, 400, 200)
Global $User = GUICtrlCreateLabel("", 8, 352, 250, 17) ; This is 
GUISetState()       ;Show GUI

_IENavigate ($oIE,$oimg.src)
While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            ExitLoop
        Case $savename
            $name1 = GUICtrlRead($username)
            GUICtrlSetData($User, $name1)
        Case $Relogin
            Relog()
    EndSwitch
WEnd

Func Relog()
    _IELoadWait($Tmnx)
    $oUser = _IEGetObjByName($Tmnx, "Login1$UserName")
    _IEFormElementSetValue($oUser, $A1)
    $oPass = _IEGetObjByName($Tmnx, "Login1$Password")
    _IEFormElementSetValue($oPass, $p1)
    $oLogIn = _IEGetObjByName($Tmnx, "Login1$LoginLinkButton")
    $oCap = _IEGetObjByName($Tmnx, "recaptcha_response_field")
    _IEFormElementSetValue($oPass, $name1)
    _IEAction($oLogIn, "click")
    _IELoadWait($Tmnx)
EndFunc

Share this post


Link to post
Share on other sites



Is it because after you call the ie embededded you cant call the parent window?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0