Jump to content
Sign in to follow this  
Markus

_SQLite_Exec(-1, "DELETE FROM....") doesn't really delete?

Recommended Posts

Markus

I deleted all data from a *.db file created by the usual autoit sql functions with the _SQLite_Exec(-1, "DELETE FROM...") command.

the select query didn't find any data after that anymore. But if I look at the *.db file it still has the same size and if i open it in notepad the data is still there.

(Maybe familiar problem but couldn't find a thread here)


"It's easier to disintegrate an atom than a prejudice." (A.Einstein)---------------------------------------------------------------------------My C++ - tools:Tidy tool-->indents your c++ sourceCleanscript --> cleans autoit-code before compiling (co-author: peethebee)My tools:GUIBuilder-->build your window and get the source; german versionMy Games:OnlineGameCenter-->Online Chess and Connect4 with a rtf-chatSnake-->including a level editor to build your own levelsTetris-->the well known game, big funOther things:Tower of Hanoi-->perfect riddler with graphic output

Share this post


Link to post
Share on other sites
Vakari

I deleted all data from a *.db file created by the usual autoit sql functions with the _SQLite_Exec(-1, "DELETE FROM...") command.

the select query didn't find any data after that anymore. But if I look at the *.db file it still has the same size and if i open it in notepad the data is still there.

(Maybe familiar problem but couldn't find a thread here)

After the "Delete From", VACUUM

SQlite Query Language: VACUUM

Edited by Vakari

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×