Sign in to follow this  
Followers 0
nitr0

Vista UAC + run("test.exe") in admin mode

4 posts in this topic

Ive read a few topics here about UAC, and with the #requireadmin code the autoit compiled exe will ask for permission to run with admin rights. And this works great!

But...

If I want to run an external application that needs admin rights, for example Run("test.exe"), this doesn't seem to work...

Is it possible to make this work with AutoIt? Or is it a problem with test.exe wich lacks some code to invoke UAC?

I hope you understand what I mean..

Share this post


Link to post
Share on other sites



Do you mean the RunAs command??

Details in help file or the command.

I'm at work so I'm not able to look it up.


tolle indicium

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

you could use Shellexecute with verb "runas"

//Edit: same time...

Edited by ProgAndy

*GERMAN* [note: you are not allowed to remove author / modified info from my UDFs]My UDFs:[_SetImageBinaryToCtrl] [_TaskDialog] [AutoItObject] [Animated GIF (GDI+)] [ClipPut for Image] [FreeImage] [GDI32 UDFs] [GDIPlus Progressbar] [Hotkey-Selector] [Multiline Inputbox] [MySQL without ODBC] [RichEdit UDFs] [SpeechAPI Example] [WinHTTP]UDFs included in AutoIt: FTP_Ex (as FTPEx), _WinAPI_SetLayeredWindowAttributes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0