Jump to content
Sign in to follow this  
jennico

strange issue with AutoItX3_x64.dll

Recommended Posts

jennico

by accident i encountered a problem with AutoItX3_x64.dll in the following versions:

- 3.2.11.10

- 3.2.13.13

- 3.3.0.0

the "ExtractIconEx" call results that the file contains more than 60,000 icons, on extracting them, they are all empty.

$dll="AutoItX3_x64.dll";enter path here
$hCount = DllCall("shell32.dll", "int", "ExtractIconEx", "str", $dll, "int", -1, "hwnd", "", "hwnd", "", "uint", "")
msgbox(0,"",$hCount[0])

the older version 3.2.12.1 is okay (no icon).

i cannot estimate if this is due to bad dll design or maybe the dll call is not appropiate for 64bit dll. so please one of the Devs could check that out.

cheers j.


Spoiler

I actively support Wikileaks | Freedom for Julian Assange ! | Defend freedom of speech ! | Fight censorship ! | I will not silence.OixB7.jpgDon't forget this IP: 213.251.145.96

 

Share this post


Link to post
Share on other sites
jennico

meanwhile i found the same problem in "squish_x64.dll" (from paint.net). so i guess, "ExtractIconEx" has problems with _x64.dll's.

j.


Spoiler

I actively support Wikileaks | Freedom for Julian Assange ! | Defend freedom of speech ! | Fight censorship ! | I will not silence.OixB7.jpgDon't forget this IP: 213.251.145.96

 

Share this post


Link to post
Share on other sites
BrettF

Hi,

I have XP x64, and I am a bit confused about your problem. Why should AutoItX3_x64.dll contain icons?

Netherless,

My results for AutoItX3_x64.dll was 0, and same with the other .dll. I tried the same with the x86 versions too, and it returned the same?

What are we meant to be seeing as a problem?

Can you please post a script that replicates your problem, along with exact steps?

Cheers,

Brett

Share this post


Link to post
Share on other sites
trancexx

Maybe that's compiler issue.

Something is wrong with address of resource section and ExtractIconEx function is relying on that (appears so).

Some other functions used for similar purposes does not have problems with these modules. I can show you if you want.


♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×