Sign in to follow this  
Followers 0
SpotCheckBilly

Autoit 1-2-3

17 posts in this topic

Hi everyone,

I just discovered AutoIt 1-2-3 so I thought I would give it a shot. On the very first lesson, the one that shows the ScitEfor the first time, there is an error message regarding one of the lines in the script. All of the other lessons to load OK. It doesn't make sense that one would be expected to correct syntax errors on the very first lesson.

Has anyone else run into this problem? If I right-click on that lesson in the folder and click "Edit Script" the script editor opens but I still don't know how to correct the syntax.

I am an absolute, complete and total rookie when it comes to programming so please be gentle.

Thanks in advance for any help. -- SCB :)


[font="Tahoma"]"I was worried 'bout rich and skinny, 'til I wound up poor and fat."-- Delbert McClinton[/font]

Share this post


Link to post
Share on other sites



can u give me the link to autoit1-2-3.. i don't have it..

or just post the code, and i can tell u what the error is.. and how to correct it..


[font="Garamond"]Manjish Naik[/font]Engineer, Global Services - QPSHoneywell Automation India LimitedE-mail - Manjish.Naik@honeywell.com

Share this post


Link to post
Share on other sites

Are you talking about Lesson-1.au3?

Share this post


Link to post
Share on other sites

@Manjish

I think he is speaking about the exe wich has no source...

Cheers, FireFox.


 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites

@Manjish

I think he is speaking about the exe wich has no source...

Cheers, FireFox.

I doubt, coz he said he right clicked and opened it in scite.. u cannot do that with a compiled exe..:)


[font="Garamond"]Manjish Naik[/font]Engineer, Global Services - QPSHoneywell Automation India LimitedE-mail - Manjish.Naik@honeywell.com

Share this post


Link to post
Share on other sites

@Manjish

yep, sorry

Cheers, FireFox.


 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites

@spotcheckbilly

Please provide more information so we can assist you. Lesson name/source code.


...will never learn all there is to know about autoit, no worries...i came to the forums :)

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

Lesson #1 is not intended to "run". note the exit at the top

Exit

; This is the SciTE editor.
; used for:

; - Scripting your programs.
; - Syntax Checking for errors.
; - Tidy (clean-up) your programs.
; - Create executable programs.
; - and Much, Much More!


; Notice the semi-colon ";" on the left for comments.
For ; no semi-colon is used for commands. ; Notice the "for" is highlighted and known as a command. 


; other commands include,
If, And, Or, Then, Next, While, Wend. ; there are more commands to learn later.


; there is no, "Go-to", in AutoIt, you can use.
Call. ; to call a Function, Functions will be taught later. 

; Another way to comment is to use, "#cs" for comments start and, "#ce" for comments end.

#cs
here are my comments.
you can have as many comment lines as you would like.
#ce

Maybe some of you should familiarize yourself with Autoit 1-2-3

8)

Edited by Valuater

NEWHeader1.png

Share this post


Link to post
Share on other sites

First of all, thanks everyone who responded. A majority of the forums that I belong to (security, mostly) have a substantially longer reply time.

@Manjish -- thankfully Valuater includes a link to AutoIt 1-2-3 in his signature.

@Authenticity --Lesson-1.au3?. That is correct.

@Valuater -- OK, there are actually a couple of things going on. First, my AV software (NOD32) keeps quarantining AutoIt-1-2-3 -Demo26.exe. I restore it, it runs fine until the next time I boot up when it's back in quarantine again. Not fun.

I did notice the Exit at the top of the Lesson-1.au3 script, but that was at a later point in time. The sequence of events was as follows:

1.) I launched AutoIt-1-2-3.

2.) Under this step number 1 header, I had recently updated AutoIt so I did not download that. I did, however, download the beta version and the SciTE editor.

3.) Installed both. Then I moved on to Step number 2.

4.) I clicked the "Show me SciTE Editor" button.

5.) Received the following error message:

AutoIt Error

Line 19 (file, "C.:\Documents and Settings\*\Desktop\AutoIt\AutoIt 1-2-3\Lessons\Lesson-1.au3"):

If, And, Or, Then, Next, While, WEnd.

If, And, Or, Then, Next, While, WEnd.۸ ERROR

Error: Missing separator character after keyword.

6.) Clicked OK and waited for the voice narration to finish.

7.) The other two buttons worked as expected.

I then exited the tutorial program and launched the SciTE Editor. I opened the specified file from within the editor to see if perhaps I could figure out how to fix the error. When the editor first opened I got the following message in a separate frame at the bottom:

need to change au3.properties: BETA_AUTOIT=0

I figured that would require a registry edit and I just didn't feel like digging around in the registry to find it so I stepped out of that mess entirely. I ran through the help demos and took the first level test, passed it, played a couple of games of tic-tac-toe (yeah, I know) and moved onto the next level..

I considered uninstalling everything and starting from scratch but thought I should post first. I sure would hate for someone to just give up because of a possible script error.

Thanks again everyone. -- SCB


[font="Tahoma"]"I was worried 'bout rich and skinny, 'til I wound up poor and fat."-- Delbert McClinton[/font]

Share this post


Link to post
Share on other sites

I have a bit of an update. I uninstalled everything (except AutoIt 1-2-3), then downloaded and reinstalled in the sequence displayed in Step 1. This fixed the "BETA_AUTOIT=0" error but I still get an error when I click the "Get SciTE" button in Step 2. Since I can launch the Script Editor manually then open that lesson file, that's no big deal.

I do have a problem related to the text size in the main AutoIt 1-2-3 window. I am quite vision impaired due to complications from diabetes. I've had to resize all of the system font settings which means that many of the text lines in the AutoIt 1-2-3 get cut off or disappear completely. I managed to get through everything on level 1, but when reading the questions for the test on level 2, I only get a partial question. For instance, Question #1 reads as follows:

"Include file needed to create a" (appears to be another line beneath.).

All of the questions seem to be missing a line.

@Valuater -- I don't know how many more levels there are but I suspect I'll have the same problem with each of them. If it's possible and you have the time, perhaps you could e-mail me a copy of the text on each page (you can PM me for my e-mail address). I know that's probably a big request and the most certainly can understand if you don't have time to do it.

Anyway, it's a nice tutorial and I'm having fun playing with it. -- SCB


[font="Tahoma"]"I was worried 'bout rich and skinny, 'til I wound up poor and fat."-- Delbert McClinton[/font]

Share this post


Link to post
Share on other sites

About the font size (or maybe overall size) you can hold the CTRL and scroll up the mouse wheel to zoom and vice versa.

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

Sorry you are having problems Bill,

I played with the button to "Get Scite" and it seemed to work fine for me ( BTW, that's in step #1)

here is the questions for level II

1 through 10

$Label_6 = GUICtrlCreateLabel('Question #1. Include file needed to create a GUI...', 50, 95, 270, 20)

$Label_6A = GUICtrlCreateLabel('Question #2. Command to Create a new GUI...', 50, 120, 270, 20)

$Label_6B = GUICtrlCreateLabel('Question #3. Command to Display the GUI...', 50, 145, 270, 20)

$Label_6C = GUICtrlCreateLabel('Question #4. Control command to create an Input...', 50, 170, 270, 20)

$Label_6D = GUICtrlCreateLabel('Question #5. Control command to create a Label...', 50, 195, 270, 20)

$Label_6E = GUICtrlCreateLabel('Question #6. Control command to create a Button...', 50, 220, 270, 20)

$Label_6F = GUICtrlCreateLabel('Question #7. Control command to create a Check Box...', 50, 245, 270, 20)

$Label_6G = GUICtrlCreateLabel('Question #8. Control command to create a Picture...', 50, 270, 270, 20)

$Label_6H = GUICtrlCreateLabel('Question #9. Control command to create a Slider...', 50, 295, 270, 20)

$Label_6I = GUICtrlCreateLabel('Question #10. Control command to create an Edit Box...', 50, 320, 270, 20)

11 - 20

$Label_7 = GUICtrlCreateLabel('Question #11. Control command to Set the Data in a Control...', 50, 95, 300, 20)

$Label_7A = GUICtrlCreateLabel('Question #12. Control command to Read the Data in a Control...', 50, 120, 310, 20)

$Label_7B = GUICtrlCreateLabel('Question #13. Control command to Set the Limit of a Control...', 50, 145, 300, 20)

$Label_7C = GUICtrlCreateLabel('Question #14. Control command to Set the State of the Control...', 50, 170, 310, 20)

$Label_7D = GUICtrlCreateLabel('Question #15. Control command to Set the Color of the Data...', 50, 195, 300, 20)

$Label_7E = GUICtrlCreateLabel('Question #16. Control command to "Listen" for a Message...', 50, 220, 300, 20)

$Label_7F = GUICtrlCreateLabel('Question #17. Command to Exit a While/Wend Loop...', 50, 245, 270, 20)

$Label_7G = GUICtrlCreateLabel('Question #18. Command to Split A String...', 50, 270, 270, 20)

$Label_7H = GUICtrlCreateLabel('Question #19. You can Support AutoIt by making a...', 50, 295, 270, 20)

$Label_7I = GUICtrlCreateLabel("Question #20. Full Name of AutoIt's Owner/Developer...", 50, 320, 270, 20)

hope that helps... 3's comming

Valuater

8)

Edited by Valuater

NEWHeader1.png

Share this post


Link to post
Share on other sites

@Authenticity -- I don't have a mouse, I use an iGesture touchpad and while it is configurable for a scroll wheel, I don't have the dexterity in my fingers to make the scroll gesture. Not fun, for sure. :)

@Valuater -- Sorry. What I should have said was "Show Me SciTE - Editor" button. That's the one I get the error on.

Thank you so much for the requested text. It will make taking the test much easier. LOL It occurred to me (at about the same time I was copying the text in your above post) that I should try one of the other cool features of AutoIt, namely "AutoIt v3 Window Info" to see if I could retrieve the same text. I'm sure that you know the answer. Since that handy dandy of tool seems to be an integral part of writing scripts, maybe you could incorporate it into one of the tests, eh?

Anyway, at the risk of posting an untidy script, it truly is refreshing to belong to a group of people who share their expertise freely instead of doling it out in little incremental tidbits as they see fit.

Thanks again. -- SCB

PS A big shiny gold star to anyone who can tell me where (the nickname) SpotCheckBilly came from


[font="Tahoma"]"I was worried 'bout rich and skinny, 'til I wound up poor and fat."-- Delbert McClinton[/font]

Share this post


Link to post
Share on other sites

Spot-Check Billy...???

http://www.strangeloves.com/public/users/d...SpotCheck+Billy

I found the error, it is created when the "au3" file is set to "Run" in Scite rather than "Edit" in Scite. Now fixed, will upload soon.. not too soon...lol

Thanks!!!

Also, let me know if you can read the questions for the exams from the window info tool.

Valuater

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Nice effort on the SpotCheckBilly search. Actually, SpotCheckBilly is a recurring character in several songs by my all-time favorite band "Little Feat". I've never run across anyone else using it. In fact, most of the time, people have never even heard of "Little Feat" -- which is unfortunate because they're a pretty amazing group.

I'm glad that you discovered what was causing that error message. Fortunately for me, although I have absolutely no programming experience, I do have enough computer experience to know that there is always more than one way to open a file. I suspect that most people who embark on that tutorial would be in a similar position.

"Now fixed, will upload soon.. not too soon...lol"

Of course. We never want to rush headlong into things. HeeHee

Yes indeed, I was able to get the text for the exam questions from the Windows Info Tool. It worked like a charm. The font was far too small for me to read it from within the tool itself so I had to copy/paste it into Notepad where I have the font size cranked up to 24 pt. Notepad and I are pretty much constant companions. :)

George a.k.a. SpotCheckBilly


[font="Tahoma"]"I was worried 'bout rich and skinny, 'til I wound up poor and fat."-- Delbert McClinton[/font]

Share this post


Link to post
Share on other sites

Cool!!

Robert

Valuater

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0