Sign in to follow this  
Followers 0
liten

line -1: Error:Error In Expression

4 posts in this topic

#RequireAdmin
#Region;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_Res_Comment=Speed HK(Mayn Mem.)
#AutoIt3Wrapper_Res_Description=Speed HK(Mayn Mem.)
#AutoIt3Wrapper_Res_Fileversion=1.0.0.0.0
#EndRegion;**** Directives created by AutoIt3Wrapper_GUI ****
#include <Nomadmemory.au3>
#include <Array.au3>
#include <memory.au3>
#include <Inet.au3>
WinWaitActive("TwelveSky2")

Global $Paused
HotKeySet("{PAUSE}", "TogglePause")
HotKeySet("{ESC}", "Terminate")

;HP and Chi Base, editting these will change when the bot takes a pill
$ID = _MemoryOpen(ProcessExists("TwelveSky2.exe"))
$AttackSpeed =
$ClickToTele = 0x00B8451B
$IP = _GetIP()
$ADDRESS = "xx.xxx.xxx.xx"

Func IP_CHECK() 
WinActive("TwelveSky2")
while $IP > $ADDRESS
     Exit 0 
    WEnd
while $IP < $ADDRESS
     Exit 0
    WEnd
EndFunc;==>Check IP address

Func AttackSpeedFreeze()
    SetPrivilege("SeDebugPrivilege", 1)
    $ID = _MemoryOpen(ProcessExists("TwelveSky2.exe"))
    _MemoryWrite($AttackSpeed, $ID, 150)
    While 1    
     SpeedHackFreeze()
    Wend
 _MemoryClose($ID) 
 EndFunc
 Func ClickToTele()
    SetPrivilege("SeDebugPrivilege", 1)
    $ID = _MemoryOpen(ProcessExists("TwelveSky2.exe"))
    _MemoryWrite($ClickToTele, $ID, 90000)
    While 1    
     SpeedHackFreeze()
    Wend
 _MemoryClose($ID) 
 EndFunc
While 1 
    AttackSpeedFreeze() 
    IP_CHECK()
WEnd
Func TogglePause()
    $Paused = Not $Paused
    While $Paused
        Sleep(100)
        ToolTip('Litens Hacks"Paused"', 512, 15)
    WEnd
    ToolTip("")
EndFunc  ;==>TogglePause

Func Terminate()
    ToolTip('"Exiting"', 512, 15)
    Sleep(1000)
    ToolTip("")
    Exit 0
EndFunc  ;==>Terminate

Is my bot i am trying to make, that only works for the IP i set it to work for EX. if i set it to 11.111.11.111, and your computers is 11.111.11.112 then u cant use and the bot shuts down, it also frezes and changes a couple of Addresses, but as stated above i get line -1: Error:Error In Expression, Please Help.


My UDF:Freeze.au3-Freeze values like CE, ML, ETC[i][/i][u][/u]

Share this post


Link to post
Share on other sites



You got variable that have assign (=) operator without any value: $AttackSpeed =

P.S

Use Syntax check before you run/compile the script.


Using OS: Win 7 Professional, Using AutoIt Ver(s): 3.3.6.1 / 3.3.8.1

AutoIt_Rus_Community.png AutoIt Russian Community

My Work...

AutoIt_Icon_small.pngProjects: ATT - Application Translate Tool {new}| BlockIt - Block files & folders {new}| SIP - Selected Image Preview {new}| SISCABMAN - SciTE Abbreviations Manager {new}| AutoIt Path Switcher | AutoIt Menu for Opera! | YouTube Download Center! | Desktop Icons Restorator | Math Tasks | KeyBoard & Mouse Cleaner | CaptureIt - Capture Images Utility | CheckFileSize Program

AutoIt_Icon_small.pngUDFs: OnAutoItErrorRegister - Handle AutoIt critical errors {new}| AutoIt Syntax Highlight {new}| Opera Library! | Winamp Library | GetFolderToMenu | Custom_InputBox()! | _FileRun UDF | _CheckInput() UDF | _GUIInputSetOnlyNumbers() UDF | _FileGetValidName() UDF | _GUICtrlCreateRadioCBox UDF | _GuiCreateGrid() | _PathSplitByRegExp() | _GUICtrlListView_MoveItems - UDF | GUICtrlSetOnHover_UDF! | _ControlTab UDF! | _MouseSetOnEvent() UDF! | _ProcessListEx - UDF | GUICtrl_SetResizing - UDF! | Mod. for _IniString UDFs | _StringStripChars UDF | _ColorIsDarkShade UDF | _ColorConvertValue UDF | _GUICtrlTab_CoverBackground | CUI_App_UDF | _IncludeScripts UDF | _AutoIt3ExecuteCode | _DragList UDF | Mod. for _ListView_Progress | _ListView_SysLink | _GenerateRandomNumbers | _BlockInputEx | _IsPressedEx | OnAutoItExit Handler | _GUICtrlCreateTFLabel UDF | WinControlSetEvent UDF | Mod. for _DirGetSizeEx UDF
 
AutoIt_Icon_small.pngExamples: 
ScreenSaver Demo - Matrix included | Gui Drag Without pause the script | _WinAttach()! | Turn Off/On Monitor | ComboBox Handler Example | Mod. for "Thinking Box" | Cool "About" Box | TasksBar Imitation Demo

Like the Projects/UDFs/Examples? Please rate the topic (up-right corner of the post header: Rating AutoIt_Rating.gif)

* === My topics === *

==================================================
My_Userbar.gif
==================================================

AutoIt is simple, subtle, elegant. © AutoIt Team

Share this post


Link to post
Share on other sites

You got variable that have assign (=) operator without any value: $AttackSpeed =

P.S

Use Syntax check before you run/compile the script.

sorry for the simple mistake, next time i will RTFM hahaha

My UDF:Freeze.au3-Freeze values like CE, ML, ETC[i][/i][u][/u]

Share this post


Link to post
Share on other sites

Is my bot i am trying to make, that only works for the IP i set it to work for EX. if i set it to 11.111.11.111, and your computers is 11.111.11.112 then u cant use and the bot shuts down, it also frezes and changes a couple of Addresses, but as stated above i get line -1: Error:Error In Expression, Please Help.

Next time when you get line -1: Error from EXE then run uncompiled script from Scite4AutoIt3 to see exact error line number.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0