Sign in to follow this  
Followers 0
Noobcube

pixelsearch

6 posts in this topic

i wanna do PixelSearch( 713, 466, 713, 466, 0x55574D )

then i want if yes continue my script and if no wait 3 seconds and try again but i cant ever get search working

no matter what colour code i put it continues

i did pixel get colour on them exact co-ords and it said the colour 55574D

can anyone help?

Share this post


Link to post
Share on other sites



How did you get that pixel color?

Default PixelGetColor gives you a decimal integer, you have to convert it to a 6 digit hex integer, if you want to use it as a hex.

Here's a sample:

Local $PixelColor = PixelGetColor(10, 10)
ConsoleWrite("Default pixel color: " & $PixelColor & @CR)
ConsoleWrite("Hex based pixel color: " & Hex($PixelColor,6) & @CR)
Local $aTemp = PixelSearch(1, 1, 20, 20, $PixelColor)
ConsoleWrite("PixelSearch X coord: " & $aTemp[0] &@CR)
ConsoleWrite("PixelSearch Y coord: " & $aTemp[1] &@CR)

Share this post


Link to post
Share on other sites

i used the window info first, then the pixelsearch and it came up with 55574D and with the window info saying 0x55574D i guess put 0x there ^^

Share this post


Link to post
Share on other sites

If you use the Window Info tool then you can just double click on Mouse/Color, and it will copy the value to the clipboard.

I suggest the Freeze (Ctrl+Alt+F) mode, and use the "Finder Tool", it's much easier.

Share this post


Link to post
Share on other sites

i have the right colour, but the if part isnt working

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0