Sign in to follow this  
Followers 0
cypher175

INSERTING UNICODE SYMBOLS INTO AUTOIT SCITE..??

7 posts in this topic

Is there anyway to insert Unicode symbols into the AutoIt Scite editor..??

I need to set some variables as Unicode symbols in my code, but when i try to copy paste them in they show up as QuestionMarks ???

is there anyway to switch the encoding for my autoit project so the Unicode symbols wont get changed into ???'s

Share this post


Link to post
Share on other sites



You can switch the encoding in SciTE this way: File->Encoding->[Choose] >_


*GERMAN* [note: you are not allowed to remove author / modified info from my UDFs]My UDFs:[_SetImageBinaryToCtrl] [_TaskDialog] [AutoItObject] [Animated GIF (GDI+)] [ClipPut for Image] [FreeImage] [GDI32 UDFs] [GDIPlus Progressbar] [Hotkey-Selector] [Multiline Inputbox] [MySQL without ODBC] [RichEdit UDFs] [SpeechAPI Example] [WinHTTP]UDFs included in AutoIt: FTP_Ex (as FTPEx), _WinAPI_SetLayeredWindowAttributes

Share this post


Link to post
Share on other sites

Why are you typing the subject all in capital letter?

Just to let you know: I memory is working well so I am not going to tolerate anything from you.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

You can switch the encoding in SciTE this way: File->Encoding->[Choose] :(

ok so I switched the Encoding to File->Encoding->[uTF-8 with BOM] and the Unicode Symbols appeared.. >_<

But now when I make a coding mistake the SyntaxCheck Prod doesn't notice it at all..??

Whats up with that.. How come its not picking up the coding mistakes at all and keeps telling me there are - 0 error(s), 0 warning(s) when I intentionally put a coding error in my script just to test if it would pick it up or not..??

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

ok so I switched the Encoding to File->Encoding->[uTF-8 with BOM] and the Unicode Symbols appeared.. >_<

But now when I make a coding mistake the SyntaxCheck Prod doesn't notice it at all..??

Whats up with that.. How come its not picking up the coding mistakes at all and keeps telling me there are - 0 error(s), 0 warning(s) when I intentionally put a coding error in my script just to test if it would pick it up or not..??

Au3check doesn't support UNICODE files at this moment and there are no plans to do so yet. Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

So would I need to temporarily switch back to the "Code Page Property" Encoding then if i wanted to check for Syntax Errors..??

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Just try to use UTF-8 without BOM, so Au3Check wont regognize its UNICODE and does the check >_<

This should be possible since ASCII characters are encoded the same way in UTF-8 as in ANSI with Codepages.

(But AutoIt itself won't recognize the ecoding too, so you have to switch between UTF-8 with and wothout BOM.

Edited by ProgAndy

*GERMAN* [note: you are not allowed to remove author / modified info from my UDFs]My UDFs:[_SetImageBinaryToCtrl] [_TaskDialog] [AutoItObject] [Animated GIF (GDI+)] [ClipPut for Image] [FreeImage] [GDI32 UDFs] [GDIPlus Progressbar] [Hotkey-Selector] [Multiline Inputbox] [MySQL without ODBC] [RichEdit UDFs] [SpeechAPI Example] [WinHTTP]UDFs included in AutoIt: FTP_Ex (as FTPEx), _WinAPI_SetLayeredWindowAttributes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0