Jump to content

Search the Community

Showing results for tags 'ObjGet'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 11 results

  1. The below code will cause AutoIt to hard crash after 18+/- seconds with the error: -1073741819 Sometimes the method succeeds 2+/- seconds, most the time not. I just updated to AutoCAD2016 and I am getting a high failure rate with my scripts. Class ID of the target application is AfxMDIFrame110u I updated SciTE to see if that would help but it did not. ConsoleWrite("AutoIt Ver: " & @AutoItVersion & @CRLF) ConsoleWrite(@OSVersion& " " & @OSArch & @CRLF) ConsoleWrite("Build: " & @OSBuild & @CRLF) ConsoleWrite(@OSServicePack & @CRLF) ConsoleWrite(@OSType & @
  2. So I'm trying to do some as400 automation and hit a wall when trying to get a COM object. The code on line 8 is failing, the as400.ws file opens with PCSWS.exe so I tried using that as the file path too but that didn't work either. Any and all help is greatly appreciated! $file = "C:\Users\Rhidlor\Desktop\as400.ws" If Not FileExists($file) Then MsgBox(0, "Error", "Error finding file") Exit EndIf $object = ObjGet($file) If @error Then MsgBox(0, "Error", "Error getting object") Exit EndIf $object.SendKey
  3. Hy All, again I got a question. I try to convert wmic PATH Win32_videocontroller GET adapterram i tried to to it like in this example but my knoledge is not good enough Local $oWMI = ObjGet("winmgmts:root\CIMV2") Local $oDisks = $oWMI.ExecQuery("select * from WIN32_DiskDrive") So i tired Local $oWMI = ObjGet("winmgmts:root\CIMV2") Local $oGMRam= $oWMI.ExecQuery("Win32_videocontroller") $Memory=$oGMRam.adapterram but this does not work. I like to understand what i need to do?
  4. Lets say I open 12 Excel workbooks and use _Excel_BookList to get a list of this open workbooks. It can take the function up to 45 seconds to return the result. Each call to ObjGet takes longer then the previous one while incrementing the index: I searched the forum but only found some threads from 2008 discussing the processing of the ROT (Running Objects Table). Does someone have an idea how to enhance this function (some miraculous WinAPI calls ...)? #include <Excel.au3> Local $oExcel = _Excel_Open() Global $iTimer = TimerInit() Global $aWorkbooks = _Excel_BookLi
  5. Good Morning Everyone and Happy Friday! First - of course: Thanks to everyone in AutoIT - You help systems administrators and programmers everywhere get help to folks that need it with fluid automation I can personally say that you've helped literally thousands of people I've distribute exe's too. Amazing work, you've saved so many of us all time, redundancy and pain. You've quite honestly given many folks their time back... On with the questions then... Having real trouble getting this OutlookEX UDF to work... getting "Error creating a connection to Outlook. @error = 1, @extended = -2147221
  6. Hi All, I've coded the small script below, but it can't seem to get the instance of Windows Media player as it keeps going to @error, I've not used com objects before so any assistance would be appreciate. I already have WMP open and minimised. I retrieved "WMPlayerApp" from the AutoIT info tool, I've included a copy below. I'm using these sources: https://msdn.microsoft.com/en-us/library/dd564085.aspx https://msdn.microsoft.com/en-us/library/dd564018.aspx $oWMP = ObjGet("", "WMPlayerApp") If @error Then MsgBox(0, "Can't get WMP", "Cou
  7. HI I am wanting to know what my CPU temp is but don't know what object to use. I don't relay know how objget works so would not know where to start. I have seen people integrate things like windows speech to text into their scripts but don't know how they know what object to use! How do I find the right object? And how dose it work? Thanks Jacob
  8. For years, I have been running a script using ObjGet to open an Excel workbook but, after upgrading from Win7 to Win10, ObjGet is now returning with an error. The only way I can get it to work on Win10 is to actually open the workbook manually myself and then run the script.
  9. Before upgrading to AutoIt v.3.3.10.2, I had no problems using ObjGet, but now I get a "0x80020006 Unknown name" COM error. I'm running Windows 7 and the object to which I'm trying to attach is PowerTermPro.Document, which worked fine previously, but not so much now. 1. Does anyone know why this error would occur and how to fix it? 2. Also, are there any tools available to see which objects are available in the running object table (ROT) and possibly see their ProgID and/or CLSID?
  10. Let's say I have multiple PowerTerm Pro windows open. Global $oObj = ObjGet("", "PowerTermPro.Document") ; <-- Production command works ok for the first instance only Global $oObj = ObjGet("", "PowerTermPro.Document", 1) ; <-- Beta command gives COM Error: 0x80020006 Unknown name. Can anyone shed any light on this? How can I get access to multiple objects of the same class?
  11. Well I asked it before in an other topic but no one replies there so I thought I'll start it as a seperate topic. Edit: I now noticed some of them are methods and others properties, can I both use methods and get properties?
×
×
  • Create New...