Jump to content

Search the Community

Showing results for tags 'POST'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 18 results

  1. Hi mates, well this is my first contribution. a simple UDF to use Virustotal API v2.0 The response return is not parsed|splitted. requires >WinHttp UDF Functions List: Update: Now a Only Function using a flags for respective mode. VT() Use respective flag($Type) VT(ByRef $aAPI, $Type, $sResource, $sAPIkey,$Comments="") flags($Type) $fReport = retrieve a scan report on a given file $fScan = submit a file for Scanning $fRescan = Rescan files in VirusTotal's file store $uReport = retrieve a scan report on a given URL $uScan = submit a URL for Scanning $Comment = Make a commnet o
  2. Ciao, This example reproduces the problem I encounter when sending a post request to an echo server. Instead of being sent as text utf8, the data is transmitted base64 encoded. Example: - json String: '{"firstName":"Jonathan","lastName":"Freeman","loginCount":4,"active": "yes","text":"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Morbi vel volutpat nunc. Maecenas id tempus mi. Morbi ipsum enim, ultricies ac augue sit amet, ullamcorper finibus ex. Vestibulum vel posuere nibh, nec faucibus eros. Nam malesuada non lacus a suscipit. Nulla rhoncus tempus mi quis placerat. C
  3. A little help here please !? I'm trying to parse a file but the function is not working well! i think there is some thind doing wrong at FileRead() Obs: username,password and API link below is fictitious ConsoleWrite(">POST METHOD UPLOADING LOCAL IMAGE<" & @CRLF) _PostMethodTest() Func _PostMethodTest() Local Const $sAPIKey = '8f1e0a750088957' Local $sBoundary = "--------Boundary" Local $sHeaders = "Content-Type: multipart/form-data; boundary=" & $sBoundary & @CRLF Local $sData = '' Lo
  4. I'm trying to get data from http://poe.trade/ - disclaimer, although this site is about a game, my script will not in any way interact directly with the game in any way. The script is just to get data from the site. To explain how it works - you submit a POST request and a custom URL is returned, then you do a GET request on that URL and you get the final URL you want. First issue: Now, I've tried doing so by using https://apitester.com/ and the first phase works. Here's how it looks like at APITester: Request Headers POST /search HTTP/1.1 Host: poe.trade Accept:
  5. Hi All i am currently trying to add a function to my project that can send SMS, i have gone with Twilio for the sms service that use a REST API. I have never worked with an API before, and could use some help. I can get my function working with using cURL.exe and copy past command from the website with the following code. And thats great unfortunately i am have issue with character like æøå when sending a SMS appears like a box or ?. this does not happen if i do it from the website so it looks like a Unicode issue in curl.exe. I have done some searching on the forum and und
  6. Hello there, could anyone advanced in WinHTTP tell me what am I missing please? #include "WinHttp.au3" #include <Array.au3> $sPic = "C:\Users\Source\Pictures\Capturex1.PNG" $sPic2 = "C:\Users\Source\Pictures\Capturex2.PNG" $hOpen = _WinHttpOpen() $hConnect = _WinHttpConnect($hOpen, "https://m.facebook.com/") $sRead = _WinHttpSimpleFormFill($hConnect, "login.php", "login_form", "name:email", "login@mail.com", "name:pass", "pasword") $aRead = _WinHttpSimpleFormFill($hConnect, &qu
  7. Hi everyone, I have a script that call this function again & again normaly Func CallAPI($amount, $target, $condition, $API_key) $oHTTP.Open("POST","https://HOST?api_key="&$API_key) $oHTTP.SetRequestHeader('content-type','application/json') $oHTTP.Send('{"amount":'&$amount&',"target":'&$target&',"condition":"'&$condition&'"}') $Response = $oHTTP.ResponseText Return $Response EndFunc but sometime (may be after 105 request, 203 request, 1000 request, ... n request) this request error and make my script stop
  8. Have this following input parameter(Complex list of inputs) that need to be SEND as part of HTTP POST Request. Have been searching forums to find an AutoIT equivalent to enapsulate the following data, but unsuccessful. Below given Working Code is failing with 400-Bad Request for obvious reason of incomplete input - unable to send ip_list and other array type parameters Questions: 1. How to encapsulate the below given data for $oHttp.Send() 2. How to enapsulate special data types like null - aligned_device_tempate parameter White sapced values - () and
  9. Create Postage Stamp from any images. Transparency is preserved around serrated edges for permit to paste stamp. Downloads are available in the download section Hope you like it ! Edit : The glue is not supplied with the stamp!
  10. Version 1.0.4

    209 downloads

    Postage Stamp Builder
  11. Hello, I'm in the making of a script that needs to post XML data through HTTPS to our ServiceDesk Plus MSP service. I'm running into trouble because I have never made any scripts using HTTP with POST and I cannot see what I'm doing wrong here. Can someone help me or should I find help somewhere else? $URLSDP="" ;REMOVED - cannot publish this. this is the HTTPS url to our ServiceDesk $TechnicianKey="" ;REMOVED $ID="" ; Request ID $sPostData = "OPERATION_NAME=ADD_NOTE&INPUT_DATA=<Operation><Details><Notes><Note><isPublic>f
  12. Dear AutoIt Community, I have checked some HTTP examples in the forums. So, I created a basic script as the following: $login = ObjCreate("winhttp.winhttprequest.5.1") $sUsername = "ty" $sPassword = "AAbb11!!" Local $url = "http://192.168.182.160:9889/authenticate.action" $login_packet = "username=" & $sUsername & "&password=" & $sPassword & "&vcode=0000&dstInfo=300%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0%3A0&language=en_US&name=default" $login.open("POST", $url) $login.SetRequestHeader("Content-Type", "application/x-www-form-urlenc
  13. So I have a bit of code where I'm sending a (very large) xml string via a POST command to a site. Except, I think it's timing out. Not quite sure, perhaps it's not, and I just have it written wrong? All I get in SCITE is Error in this kind of orange text (not the usual black). My responsetext and status and statustext don't come back as anything, so I'm kind of at a loss as to how to troubleshoot past this. Anyone have an idea for me? (I had to hide the site and dbid in the quickbase URL as it's my company, so I can't post it for confidentiality reasons). $oHTTP = ObjCreate("winhttp.
  14. I'm having a hard time trying to set a value in a specific JavaScript textarea... And I think, this is the right time.. Is it possible to set a value in the "Join the discussion…" textarea and simulate the mouse click of the "Post as {USERNAME}" button of the web page that have added a Disqus forum? If they are possible then: How can I set a value in the "Join the discussion…" textarea? And how to simulate the mouse click of the "Post as {USERNAME}" button? Note: Before you can see the "Post as {USERNAME}" button, you must be sign in with Disqus first! This is the (NULL) previous test w
  15. I'm in the middle of converting somthing into autoit and I hit a snag.. dojo.rawXhrPost({ url: webServiceURL, handle: handler, headers: { "Content-Type": "text/xml; charset=utf-8", "cache-control": "no-cache" }, postData: this.BuildXMLString(), timeout: 0, sync: bSync }); Ahh, POST, my old Nemesis. I've tried (and failed!) several different things to do what this does using _WinHttp UDF but have had no luck. How do you send raw post data with Autoit? Is it possible?
  16. Hi All, Long time no post - the forum has changed a lot since I was last here! Hope you are all ok. Anyway, the reason I'm here is because I'm writing a program that needs to post a Tweet to a Twitter account. I am using the >Twitter UDF, which I have already adapted slightly so that once a user has logged in once the username and password is not need because the OAuth token and OAuth token secret is stored and used again, rather than regenerating a them each time the program is launched. However, since the UDF was last updated Twitter has updated their API and retired the use of XML so
  17. Hi Guys, I'm trying to do a HTTP POST which would change a setting on my server. (details here, enable recordings etc.) When I use the full URL via a browser it works fine, when I use the script below, it fails. #include <http.au3> $Host = "192.168.20.5" $Port = "5000" $File = "/ivr/PbxAPI.aspx" $PostData = "func=upd_ext&extnum=3888&pwd=123456!&record_calls=0" $Socket = _HTTPConnect($Host, $Port) _HTTPPost($Host, $File, $Socket, _HTTPEncodeString($PostData)) _HTTPClose($Socket) I assume I'm doing something wrong, I can't figure out what :-) Any suggestions are appr
  18. I was working on a solution for adamchapman on his topic here. I was able to make the option change quite easily, but downloading the file is a different story. AutoIt Code to change select option I reviewed the function tied to the change event. This same function is called when you click the download link. The only difference is the argument is false and true respectively. I removed the code that is executed when false as it is not relevant for the issue. It basically builds a string with the selected option value + true + symbol (Example: 5d|true|AA), then sets the value of the inpu
×
×
  • Create New...