Jump to content

Search the Community

Showing results for tags 'colour'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 5 results

  1. Hey, all. I've been looking for a way to change cursor colour but not the cursor itself. I've been looking for a couple hours now and can't find anything. I also don't even know where to start, if anyone has any tips or examples please comment them. Thanks
  2. Hi All, While creating a few excel spreadsheets using AutoIt, I came across something which to my limiting time to research the forums I don't anyone has mentioned. The color pallettes are reversed. Huge shock to me. I wanted to produce a red row but kept on getting blue. Seems like 0xFF0000 was red on the charts but when running the script, I got blue. I then played around with the colors, and after a few tries, I finally got Red. Reversed the FF0000 and the result is 0000FF. So for Excel compared to Html 0000FF (Red) - Excel 0000FF (Blue) - Html FFFF00 (Cyan) - Excel FFFF00(Yellow) - Html
  3. I have tried several way sto get this to work to no avail. Any help would be appreciated. #include <ListViewConstants.au3> #include <GuiListView.au3> #include "GuiListViewEx.au3" $idItem = GUICtrlCreateListViewItem($r & " | " & $c & $adoRs.Fields("TransactionAmount").value & " | " & $Timestamp & " | " & _StringProper($adoRs.Fields("Tillid").value) & @CRLF & @CRLF & "Card Number : " & $cardnum & " " , $idListView) ConsoleWrite( "IDITEM" & $idItem) If STRINGLEFT($adoRs.Fields("TransactionAmount").value,1)= "-" Then Consolewrite(" String is Negative" & @CRLF) ;Drops in Here as expected ;GUICtrlSetColor(-1, $COLOR_RED) ; Colour line if item is negative this didn' work $TxC= _GUICtrlListView_SetTextColor($hListView, $CLR_RED) ; I also tried $TxC= _GUICtrlListView_SetTextColor(-1, 0xFF0000) CONSOLEWRITE("TEXTCOLOUR RETURNED " & $TxC & @crlf) ; This is returning True ELSE Consolewrite(" String is NOT Negative" & @CRLF) EndIf
  4. Hi All, I've been experimenting with the colour options for the SciTE script editor included with AutoIT's full installation, and seem to be having a bit of trouble achieving the colours I'm after.... After reading the given documentation for ConsoleWrite (the function i'm trying to use), I can see that the default colours are chosen with the following parameters: ! = Red > = Blue - = Orange + = Green However, I'm receiving the following; As you can see, the output is still formatted with colours, Only they're not what I was expecting. I assume this is a setting in SciTE rather than the AutoIT language, Has anyone come across any settings within SciTE regarding console colouring? I've been through various properties and settings for SciTE. but can't seem to find anything that references console or colour. May sound like i'm grasping at straws a bit here, But I'm after formatting certain outputs with red text more than anything. Any help is greatly appreciated. Kind Regards Javi.
  5. Hi guys, Been a while since I was last using AutoIt properly and it's showing! I am creating a simple game launcher - before you all pounce, this is not a hack. I will use it to pass command line parameters to a game. Not to hack it. Anyway, I have loaded the background image and have a button displayed - however the text on both the checkbox and group will not change? Looking through the help file, I noted: That sort of contradicts itself? My brother tried to show me optional 'workarounds' however neither of them suited what I want to do. So here is the program. Works the same without the background image. #include <GDIPlus.au3> #include <WinAPI.au3> Global $hGUI, $hImage, $hGraphic, $hLabel Global $hRunGroup, $hRun, $hRunTesting ; Create GUI $hGUI = GuiCreate("Assaultcube Launcher", 400, 400) ;~ GUICtrlSetDefColor(0xFFFFFF, $hGUI) GUISetBkColor(0x000000, $hGUI) GUISetState() ; Create background image _GDIPlus_Startup() $hImage = _GDIPlus_ImageLoadFromFile("C:\Program Files\AssaultCube_v1.1.0.4\packages\misc\startscreen.png") $hGraphic = _GDIPlus_GraphicsCreateFromHWND($hGUI) _GDIPlus_GraphicsDrawImageRect($hGraphic, $hImage, 10, -20, 380, 380) ; Hide Loading... text GUICtrlCreateLabel("", 130, 180, 120, 30) GUICtrlSetBkColor(-1, 0x000000) ; Create controls $hRunGroup = GUICtrlCreateGroup("Run Assaultcube", 10, 250, 380, 50) $hRun = GUICtrlCreateButton("Run Assaultcube", 40, 300) $hRunTesting = GUICtrlCreateCheckbox("Testing", 100, 100) ; Set appropriate colours GUICtrlSetColor($hRunGroup, 0xFFFFFF) GUICtrlSetColor($hRun, 0x000000 ) GUICtrlSetColor($hRunTesting, 0xFFFFFF) While 1 switch GUIGetMsg() case -3 _Exit() EndSwitch WEnd Func _Exit() _GDIPlus_GraphicsDispose($hGraphic) _GDIPlus_ImageDispose($hImage) _GDIPlus_ShutDown() Exit EndFunc Can anyone help me to set the group and checkbox text colours please? Please note the background colours must stay the same.
×
×
  • Create New...