Sign in to follow this  
Followers 0
JohnOne

Lately in scite4autoit

16 posts in this topic

Of late (month or so) been having intermittent problems with au3check

! ***************************************************************************************************

! * Input file is UTF8 encoded with BOM, Au3Check does not support UNICODE and will be skipped. *

! ***************************************************************************************************

I dont mess around with scite setting and options as a rule, and so cant think what might be causing this.

Anyone any Ideas?

Heres my test script which causes the above

#include <GUIConstants.au3>

AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites



What do you see at File|Encoding in SciTE? Or have you edited your script or that UDF with something other than SciTE?

;)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

This is a warning from Autoit3Wrapper warning you about the fact that you have scriptfile that is encoded in a flavour of UNICODE either UTF or UCS which is not supported by au3check/obfuscator and Tidy.

The current beta version of Tidy support UTF with or without BOM.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

In file encoding, I see

Code Page Property

UCS2- big endian

UCS3- big endian

UTF8 with BO<

UTF8

It was set to Code Page Property

I tried them all, without change.

I only ever use scite for Autoit and the only thing is the include in the script, which I wouldnt dare to edit.

Tidy works fine, its au3check what seeme to be the problem, ctrl + t is OK, just ctrl + F5 or just F5.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Its making a liar out of me now.

I went to paste the udf contents into notepad, save and put them back in the udf, I realized there was only include ...Ex in it so made it read only again again and tried GUICondtantsEx without error, tried GUICondtants again and it was fine.

It only happens occasionally, so I guess its a computer problem.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

In file encoding, I see

Code Page Property

UCS2- big endian

UCS3- big endian

UTF8 with BO<

UTF8

It was set to Code Page Property

I tried them all, without change.

I only ever use scite for Autoit and the only thing is the include in the script, which I wouldnt dare to edit.

Tidy works fine, its au3check what seeme to be the problem, ctrl + t is OK, just ctrl + F5 or just F5.

Did you change your code page in Sciteuser or sciteglobal.properties to force the use of UTF8 with BOM?

code.page=0

The latest productionversion of Tidy will not work either on that file, only the current Beta.

Tidy AutoIt3 v2.1.0.5   Copyright (c) Jos van der Zande  August 16, 2010
!> Script is encoded in UTF8 which is not supported ..  stopping process.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I'm using Tidy version 2.2.0.4

Not got around to testing a later beta yet.

That is a Beta too... v2.1.0.5 was the latest production version.

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I know, but it was working fine when I tested it so just left it.

EDIT:

are they related Jos?

Au3Check and Tidy.

No... (maybe I do not understand as this is to me a bit of a "kicking in a open door" questions ;) Dutch saying meaning you are asking a question to which the answer is very obvious to me when you understand their purpose)

back to your issue: Did you look at the properties files to see if you messed with the code.page parameter?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Nope, I dont change anything in them if I can help it, on account of not knowing what they do.

I have

#code.page=932

That is a commented line and doesn't count.

So what do you have in the SciTEGlobal.properties for Code.page= ?

This is the original distributed section:

# Internationalisation
# Japanese input code page 932 and ShiftJIS character set 128
#code.page=932
#character.set=128
# Unicode
#code.page=65001
code.page=0
#character.set=204
# Required for Unicode to work on GTK+:
#LC_CTYPE=en_US.UTF-8
#output.code.page=65001

Also make sure you do not have anything for code.page= in au3,properties, sciteuser.properties or any scite.properties in any directory where scripts are stored.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Yes, sorry Jos, exactly that.

# Internationalisation

# Japanese input code page 932 and ShiftJIS character set 128

#code.page=932

#character.set=128

# Unicode

#code.page=65001

code.page=0

#character.set=204

# Required for Unicode to work on GTK+:

#LC_CTYPE=en_US.UTF-8

#output.code.page=65001


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Then the only other option that is left is that you use another editor that changes the file to a UTF8 with BOM because as far as I know SciTE will not do it unless you tell it via File/Encoding menu option....

Jos ;)


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

There is no way I'm changing editor, I can live with this.

And like I said, Its most likely something to do with my pc machine, I'm convinced of that, now you have gone through the possibilities.

Thanks you very much Jos, I appreciate you taking the time.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0