Sign in to follow this  
Followers 0
hogfan

Filegetversion still returning AutoIT version.......

19 posts in this topic

I have the following code in the my compiled script:

#Region AutoIt3Wrapper directives section            
#AutoIt3Wrapper_Res_Fileversion= "1.0.2"
#endregion

However, when running filegetversion function, autoit is still returning the AutoIT version, and not "1.0.2" as I have specified. Any help extremely appreciated.

-hogfan

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

Changed to:

#Region AutoIt3Wrapper directives section
#AutoIt3Wrapper_Res_Description= Description            
#AutoIt3Wrapper_Res_Fileversion= 1.0.2.0
#endregion

but the Fileversion comparison still returns the autoit version. I have searched on this as well but couldn't find any good documentation in the help file. Any help appreciated.

-hogfan

Edited by hogfan

Share this post


Link to post
Share on other sites

I have even tried your example (although I do not see it in the helpfile) and after compiling the version number on the Details tab in Windows Explorer only shows the AutoIT version. So your question isn't why FileGetVersion isn't working (because it is) but instead why the version isn't being changed on compile.

Share this post


Link to post
Share on other sites

I am just compiling with Aut2EXE. From what I have been seeing it looks like I actually need to install autoitwrapper, but I can't find a download for that.

Share this post


Link to post
Share on other sites

Ok, I got the latest version installed and re-compiled the script, but the file version is still showing the AutoIT version. I am at a loss.

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

Did you get information in the SciTE outputpane during your compile( f7) that the version is updated?

Are you looking for fileversion or product version?

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I'm actually compiling with Aut2Exe. I am looking for the fileversion #.

Share this post


Link to post
Share on other sites

Compile WITHOUT compressing with UPX then use Reshacker to change the file version resource value then use the appcompacter form portableapps.com to compress the file with UPX.


My UDFs are generally for me. If they aren't updated for a while, it means I'm not using them myself. As soon as I start using them again, they'll get updated.

MY PROJECTS


Active: IRC UDF, WindowEx UDF
Discontinued: GithubBubbleSort UDF

Share this post


Link to post
Share on other sites

Try downloading and installing this

http://www.autoitscript.com/site/autoit-script-editor/downloads/

as Jos suggested


010101000110100001101001011100110010000001101001011100110010000

001101101011110010010000001110011011010010110011100100001

My Android cat and mouse game
https://play.google.com/store/apps/details?id=com.KaosVisions.WhiskersNSqueek

We're gonna need another Timmy!

Share this post


Link to post
Share on other sites

As stated, this fileversion option is to be used with the full version of SciTE.

Open SciTE, open your script, compile using F7.

You will see your file version change.


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Whenever I try to build after compiling the script directly out of SCITE Editor, I get no output file even though it says it was created. That's why I was compiling with Aut2exe.

Share this post


Link to post
Share on other sites

Tried again, created a folder and gave everyone full control of it. Scite says the .exe was created successfully, but it didn't create the file. I have never had so many problems.

Share this post


Link to post
Share on other sites

Compile a script and post the complete output pane information from Scite and we'll see what might be going wrong.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Tried again, created a folder and gave everyone full control of it. Scite says the .exe was created successfully, but it didn't create the file. I have never had so many problems.

Yeap, can't be you so must be something with the stuff we gave you. :mellow:

Anyway, give us some real input on your what you are doing and we might be able to help.

Also tell us if you started SciTE in admin mode or not assuming you are using win7 or Vista.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Ok, I found the problem with the compile. It compiles fine with the correct version # if I disable "Use UPX" in the Compile settings. However I don't understand why the UPX is getting this permission denied error with UPX enabled.

+>15:50:40 Program Resource updating finished successfully.rc:0
>Running:(3.3.0.0):C:\Program Files\AutoIt3\aut2exe\upx.exe" --best --compress-icons=0 -qq "C:\Program Files\AutoIt3\Examples\GUI\Simple\MYAPP.exe"
upx: C:\Program Files\AutoIt3\Examples\GUI\Simple\MYAPP.exe: IOException: rename error: Permission denied
   1019840 ->    674752   66.16%    win32/pe     MYAPP.exe
->15:50:44 UPX Ended: rc:1
+>15:50:44 Created program:C:\Program Files\AutoIt3\Examples\GUI\Simple\MYAPP.exe
>Exit code: 0    Time: 12.676

Any ideas on this one?

-hogfan

Share this post


Link to post
Share on other sites

Build your scripts out of the Program Files folders and see if that makes any difference. Also, make sure that you don't have a Windows Explorer window open to the folder that the .exe is being created in.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0