Sign in to follow this  
Followers 0
Mamatha

Installation successful page in a wizard doesn't get activate after instalation takes place

5 posts in this topic

I am trying to automate (.exe file) the installation process of my product using autoit.

Everything works ok except the last before page.

When I hit next button on "ready to install" page, it goes to "installing" page (on this page it installs all the required files and it has no buttons / keys to sent to goto next page. This process takes about 3-4 minutes)

And then it automatically goes to "installation successful" page. On this page I have to hit "finish" button here to end up.

It stopped working at the "installing" page in the wizard.

Please find the code that I have been trying.

#requireadmin

Opt("WinTitleMatchMode", 2)

Opt("WinTextMatchMode", 2)

$Version = "1234"

$sScriptName = "Installation Automater"

$exe = "C:\Setup"&$Version&".exe"

$ProcessName = "Setup"&$Version&".exe"

$windowname = "Matrix Setup"

$delay = 1000

ShellExecuteWait($exe)

;It waits for the 'welcome' page of the wizard to popup and become active

WinWaitActive($windowname)

sleep(500)

Send("!n")

Sleep($delay)

;Sends a mouse click command to 'I Agree' radio box on the license agreement dialog

ControlClick($windowname, "I agree to the terms of this license agreement", 602, "", 1)

Sleep($delay)

Send("!n")

;It waits for the 'installation folder' page of the wizard to popup and become active

WinWaitActive($windowname)

Sleep($delay)

Send("!n")

;It waits for the 'shortcuts' page of the wizard to popup and become active

WinWaitActive($windowname)

Sleep($delay)

ControlClick($windowname, "Next >", 100, "", 1)

;It waits for the 'ready to install' page of the wizard to popup and become active

WinWaitActive($windowname)

Sleep($delay)

Send("!n")

;It waits for the "lnstalling' page of the wizard to popup and become active

WinWaitActive($windowname, "Installing Matrix")

Sleep(180000)

;It waits for the 'installation successful' page of the wizard to popup and become active

WinWaitActive($windowname, "Installation Successful")

Sleep($delay)

Send("!f")

Exit

Share this post


Link to post
Share on other sites



I don't see how it works at all because you start off with ShellExecuteWait(), pausing the script until the process finishes. That would prevent all the window handling after it.

:D


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

I changed ShellExecuteWait($exe) to Run($exe)

But the last bit still doesn't work

Share this post


Link to post
Share on other sites

Hi Mamatha, I am also trying to automate an installation... Did you have any luck with this?

Share this post


Link to post
Share on other sites

Hi, Mamatha. Rather than using WinWait and mouseclicks, have you looked into whether the product supports some mode of silent installation from the command line? This is often much easier than trying to script your way through the various windows. If you browse to the location of the executable from the command line and type in "exe name" /? does it return anything?


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • sree161
      By sree161
      Hi,
      i have a code which generates two numeric outputs.i have to save them in excel.
      Is there any way to export them to specific cells in excel???
    • TotalAuto
      By TotalAuto
      Howdy All
      I've gone around and around in circles wasting hours trying to fix this problem to no avail so I thought I would try posting for help given there are some real smart people in this forum.
      Background
      I have 5 separate .au3 scripts that all do different basic tasks. For example:
      1.au3 = opens Chrome browser to obtain information from a specific website then closes
      2.au3 = opens an Excel workbook to run a macro then saves and closes
      3.au3 = Open two seperate workbooks and transfers data from one to the other then saves and closes
      4.au3 = .......etc
      5.au3 = .......etc
      These 5 separate scripts, doing completely different tasks, need to each run once per day at 5 different designated times within a day and then close. For example:
      1.au3 = 10am
      2.au3 = 12pm
      3.au3 = 2pm
      4.au3 = 4pm
      5.au3 = 5pm
      Problem
      I can not get these different scripts to reliably run at their designated times. When I manually run these scripts individually by using 'Go F5' they work perfectly. If I convert these scripts to an .exe and manually run each one they work about 98% of time.
      How can I schedule these different .au3 files or associated .exe files to reliably run each day at different times?
      Attempts To Fix The Issue
      1. I have tried converting each .au3 script into their own .exe file and use Window's Task Scheduler to run these .exe files at their designated time but the success rate  of running each .exe in full, to completion, without error is very low at about 30%. Things that commonly go wrong include a browser not opening but movement still continues on the desk top. Other times things just do not happen at all.
      2. I have Windows 7 64 bit and have tried creating and running both (x86) and (x64) .exe files but again reliability problems exist;
      3. I have also tried moving each .exe file to the My Documents folder as I read someone that keeping your files on your desktop ties your files to individual Windows user profiles which can cause AutoIt operating errors. Not sure if this is correct but thought I would try it anyway. It did not fix my issue.
      4. I installed a program called AlwaysUp which supposedly always reliably runs in the background and will reliably execute your AutoIt script or .exe files. Still have significant reliability issues.
      Therefore, can someone please provide advice on how I can get my 5 different .au3 files to run at 5 designated times through the day, every day, without fail? Overtime I will be creating more and more different .au3 files to run certain tasks throughout the day and do not want to create one large AutoIt file that continually runs and attempts to do all the different tasks itself.
      Any help is very appreciated.
      Thanks
      Dan
       
       
    • hugomito
      By hugomito
      Hi all,
      I built an AutoIt application that interacts with several other applications/software. Now, it's turn to interfact with Visual Studio Team Services (VSTS).
      Does anyone has a blog, demo, script to share?
      Thanks!
    • Viki
      By Viki
      This is my first time here so please dont bombard me that what a silly question I am asking!!
      I have 500 rows (A1:A500) in a spreadsheet and I just want to copy one by one row and then paste into another application and then press enter, loop should repeat this until finishes all 500 rows.
      I have looked at clipget(), clip(put() but dont know how to select next row in next turn. I also looked at Array to store but again no luck. Can some guide me please..
    • DineshPawar
      By DineshPawar
      0down votefavorite   In my current project, Excel macro open AutoIt script using a function Call Shell("location of autoit script").
      For proper functioning of AutoIt script it's need to be close parent Excel workbook, so this closing Excel action is written in AutoIt script itself.
      But as soon as AutoIt script close parent Excel workbook then script get pause and it do nothing.
      How open the AutoIt script from Excel workbook and after that parent Workbook get close?