Sign in to follow this  
Followers 0
Ehe

_IELinkClickByIndex hangs in "Der Download von Dateien von dieser Site auf dem Computer wurde aus Sicherheitsgründen geblockt."

7 posts in this topic

Nach dem Aufruf von _IELinkClickByIndex ($oIE, 0)

kommt nicht der Dateidownload Bildschirm, (dieser kommt wenn ich den Link "manuell" im Explorer anklicke), sondern im Explorer kommt in der Explorer-Informationsleiste die Warnung "Der Download von Dateien von dieser Site auf den Computer wurde aus Sicherheitsgründen geblockt. Klicken Sie hier, um Optionen anzuzeigen..."

Gibt es einen Zusatzparameter(/sonstige Einstellung) der die Blockierung aufhebt?

Gibt es eine andere Funktion einen Link zu aktivieren, der die Zusatzabfrage umgeht?

Gruß,

Ehe

Share this post


Link to post
Share on other sites



Hallo Ehe,

erstmal ist dies das Englische Forum :-) Es gäbe auch eine deutsches (www.autoit.de).

Du sprichst davon, dass es einen Untschied gibt, ob du den Link manuell anklickst, oder es mit Autoit machst?

Wie sieht denn das HTML aus?

Gruß

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

Hello Mega,

Thank you for the reply.

here ia an extract of the HTML code:

<!-- line -->

<tr>

<td colspan="5"><img vspace="5" border="0" src="/nice/web/includes/images/dot_clear.gif"></td>

</tr>

<tr>

<td colspan="5" class="tdc1"><img height="1" src="/nice/web/includes/images/dot_clear.gif"></td>

</tr>

<tr>

<td colspan="5"><img vspace="5" border="0" src="/nice/web/includes/images/dot_clear.gif"></td>

</tr>

<tr>

<td class="normal12px" nowrap width="226">

<a href="/nice/SwHashlistDownload?SW_HASHLIST_ID=183336" class="hl3">

10.01.2012, 12:22:54

</a>

</td>

<td width="7">

<img height="1" width="7" src="/nice/web/includes/images/dot_clear.gif">

</td>

<td class="normal12px" nowrap width="353">

<a href="/nice/SwHashlistDownload?SW_HASHLIST_ID=183336" class="hl3">

Has_List.xml

</a>

</td>

<td width="7">

<img height="1" width="7" src="/nice/web/includes/images/dot_clear.gif">

</td>

<td class="normal12px" nowrap width="106">

&nbsp;

</td>

</tr>

---------------

Also using _IELinkGetCollection($oIE) and performing _IEAction($0Link, "click") on first link shows the same result.

Can I make the Explorer more tolerant?

Regards,

Ehe

Share this post


Link to post
Share on other sites

I didn't send your initial post through a translator, but I'm guessing that if you look at the second example for _IEAction in the helpfile, you'll find your answer.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Hello dale,

thanks for your reply. Sorry I will try to translate my original question:

------

After calling _IELinkClickByIndex ($oIE, 0)

The Datadownload screen does not appear, (This screen comes when I click the Link "manually" in Explorer), Instead comes in Infoline of Explorer the Warnung "Download of files from this Site has been blocked for safety reasons. Klick here to see the options..."

Is there an additional parameter(/settings variable) which bypasses the blocking?

Is there another function which starts the link and avoids the safety question?

------

I think my problem is related to the security settings of my Explorer.

Regards,

Ehe

Share this post


Link to post
Share on other sites

I think the solution is in the helpfile as Dale mentioned.

; *******************************************************
; Example 2 - Same as Example 1, except instead of using click, give the element focus
;              and then use ControlSend to send Enter.  Use this technique when the
;              browser-side scripting associated with a click action prevents control
;              from being automatically returned to your code.
; *******************************************************
#include <IE.au3>
$oIE = _IE_Example("form")
$oSubmit = _IEGetObjByName($oIE, "submitExample")
Local $hwnd = _IEPropertyGet($oIE, "hwnd")
_IEAction($oSubmit, "focus")
ControlSend($hwnd, "", "[CLASS:Internet Explorer_Server; INSTANCE:1]", "{Enter}")
; Wait for Alert window, then click on OK
WinWait("Windows Internet Explorer", "ExampleFormSubmitted")
ControlClick("Windows Internet Explorer", "ExampleFormSubmitted", "[CLASS:Button; TEXT:OK; Instance:1;]")
_IELoadWait($oIE)

Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

Thanks *,

I have now two solutions:

1. Manipulate the Explorer to be more tolerant

Extras>Internetoptionen>Sicherheit>Vertrauenwürdige Sites

enter the startpage and reduce the security to low

2. Use another function.

instead of using _IELinkClickByIndex ($oIE, 0)

use:

$oLinks = _IELinkGetCollection($oIE)

For $oLink In $oLinks

$dwnldlink=$oLink.href

ExitLoop

Next

_IENavigate ($oIE,$dwnldlink,0)

Regards,

Ehe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0