Sign in to follow this  
Followers 0
LordBoling

Script not working (Problems solved! Thanks.)

7 posts in this topic

#1 ·  Posted (edited)

Hello everyone! Hope you are having great days.

I unfortunately am in need of assistance.

I am in the process of creating a program that will allow me to search 2 systems that my company uses that store customer info.

At this time if a customer places an order it could be in our online only system, our in-store system, or both at the same time. So instead of searching one manually, then the other, I decided to code a script that would look in both at the same time until it find the order. It has a few issues though.

Issue #1 (Solved, Thank you BrewManNH!): I have two GUIs that I created, but apparently created wrong as the first one never closes until the script ends completely or if they press the red X, but is supposed to close when the user presses okay, but not end the script. This GUI is called in my code by a function called RefGui().

Issue #2 (Solved): This same GUI is supposed to return a reference id entered by the user in an input field and what type of reference number it is by selecting a radio button. However, when used like it was intended it only returns the data from the input field. If nothing is put in the input field then it will return both the data in the input field and which radio selection is made.

I have other issues but will probably deal with them once I have those figured out. If someone could take a look at my code and give me some ideas I would appreciate it.

#include "CSV.au3"
#include "Array.au3"
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#include <EditConstants.au3>
#include <StaticConstants.au3>
#include <ButtonConstants.au3>
Opt("WinWaitDelay",100)
Opt("WinDetectHiddenText",1)
Opt("MouseCoordMode",0)
Opt("SendCapslockMode",1)

$objErr = ObjEvent("AutoIt.Error","MyErrFunc")


;Open Connection to OsCommerce database
$oConn = ObjCreate("ADODB.Connection")
$oConn.Open(;Connection string to my first database)

;Open Connection to Mas90 database
$conn = ObjCreate("ADODB.Connection")
$DSN = ;Connection string for my second database
$conn.Open($DSN)

;Define var for reference type as global w/ initial value/Moved per BrewManNH's suggestion
Global $refType="Internet"
;Loop until user closes first GUI w/ close button
While 1
;~ ;Define var for reference type as global w/ initial value
;~ Global $refType="Internet"
;Ask for order number or invoice number: (This opens first gui)
$refNum=RefGui()
;Start text var to display message.
$OrderMsg=$refNum & @CRLF & $refType
;If user selected internet search OsCommerce. Otherwise this won't be necessarily.
If $refType="Internet" Then
;Query status and comments
$rs = $oConn.Execute("SELECT orders.orders_status,orders_status_history.comments FROM orders,orders_status_history WHERE orders.orders_id='"& $refNum &"' AND orders_status_history.orders_status_id=orders.orders_status AND orders_status_history.orders_id=orders.orders_id")
;Make sure a result was returned then get results
If IsObj($rs) And $rs.EOF=False Then
  $osStatus = $rs.GetRows()

  $rs = $oConn.Execute("SELECT orders_status_name FROM orders_status WHERE orders_status_id ='"& $osStatus[UBound($osStatus)-1][0] &"'")
  $temp=$rs.GetRows()
  $osStatus[UBound($osStatus)-1][0]=$temp[0][0]

  $OrderMsg+="OsCommerce:" & @CRLF
  $OrderMsg+=@TAB & "Status:" & $osStatus[UBound($osStatus)-1][0] & @CRLF
  $OrderMsg+=@TAB & "Comments:" & $osStatus[UBound($osStatus)-1][1] & @CRLF

Else
  $osStatus = 0
EndIf
EndIf
;If internet or sales were chosen then check if it has been put in Mas90 yet.
If $refType="Internet" Or $refType="Sales" Then
$rs = $conn.Execute("SELECT OrderType FROM SO_SalesOrderHeader WHERE (SalesOrderNo='"& $refNum &"')")
If IsObj($rs) And $rs.EOF=False Then
  $SOStatus = $rs.GetRows()

  $OrderMsg+="Sales Order:" & @CRLF
  $OrderMsg+=@TAB & "Status:" & $SOStatus[0][0] & @CRLF

  $rs = $conn.Execute("SELECT ItemCode,ItemCodeDesc,QuantityOrdered,QuantityBackordered FROM SO_SalesOrderDetail WHERE (SalesOrderNo='"& $refNum &"' AND ItemType='1')")
  If IsObj($rs) And $rs.EOF=False Then
   $SOItems = $rs.GetRows()
  
   $OrderMsg+=@TAB & "Items:" & @CRLF
  
   $i=0
   While $i<UBound($SOItems)-1
    $OrderMsg+=@TAB & @TAB & "(" & $SOItems[$i][0] & ") " & $SOItems[$i][1] & @CRLF
  
    $rs = $conn.Execute("SELECT TotalQuantityOnHand FROM CI_Item WHERE (ItemCode='"& $SOItems[$i][0] &"')")
    If IsObj($rs) And $rs.EOF=False Then
     $item = $rs.GetRows()
    
     $OrderMsg+=@TAB & @TAB & "Ordered/Available: " & $SOItems[$i][2] & "/" & $item[0][0] & @TAB & "Backordered: " & $SOItems[$i][3] & @CRLF
    EndIf
    $i+=1
   WEnd

  Else
   $SOItems = 0
  EndIf
Else
  $SOStatus = 0
EndIf

$rs = $conn.Execute("SELECT InvoiceNo, SalesOrderNo FROM SO_InvoiceHeader WHERE (SalesOrderNo='"& $refNum &"')")
If IsObj($rs) And $rs.EOF=False Then
  $InvStatus = $rs.GetRows()

  $rs = $conn.Execute("SELECT InvoiceNo,ItemCode,ItemCodeDesc,QuantityOrdered,QuantityBackordered FROM SO_InvoiceDetail WHERE (InvoiceNo='"& $InvStatus[0][0] &"' AND ItemType=1)")
  If IsObj($rs) And $rs.EOF=False Then
   $InvItems = $rs.GetRows()
  Else
   $InvItems = 0
  EndIf
Else
  $InvStatus = 0
EndIf

$rs = $conn.Execute("SELECT InvoiceNo, SalesOrderNo FROM AR_InvoiceHistoryHeader WHERE (SalesOrderNo='"& $refNum &"')")
If IsObj($rs) And $rs.EOF=False Then
  $InvHst = $rs.GetRows()
  $rs = $conn.Execute("SELECT InvoiceNo,ItemCode,ItemCodeDesc,QuantityOrdered,QuantityBackordered FROM AR_InvoiceHistoryDetail WHERE (InvoiceNo='"& $InvHst[0][0] &"' AND ItemType=1)")
  If IsObj($rs) And $rs.EOF=False Then
   $InvItems = $rs.GetRows()
  Else
   $InvItems = 0
  EndIf
Else
  $InvHst = 0
EndIf

ElseIf $refType="Invoice" Then
$rs = $conn.Execute("SELECT InvoiceNo, SalesOrderNo FROM AR_InvoiceHistoryHeader WHERE (InvoiceNo='"& $refNum &"')")
If IsObj($rs) And $rs.EOF=False Then
  $InvHst = $rs.GetRows()
  $rs = $conn.Execute("SELECT InvoiceNo,ItemCode,ItemCodeDesc,QuantityOrdered,QuantityBackordered FROM AR_InvoiceHistoryDetail WHERE (InvoiceNo='"& $refNum &"' AND ItemType=1)")
  If IsObj($rs) And $rs.EOF=False Then
   $InvItems = $rs.GetRows()
  Else
   $InvItems = 0
  EndIf
Else
  $InvHst = 0
EndIf
EndIf
Gui($OrderMsg)

WEnd

;This is the second GUI that displays the results
Func Gui($txt)
    Local $myedit, $msg
    $hGUI=GUICreate("Details:", 500, 300, Default, Default,$WS_OVERLAPPEDWINDOW) ; will create a dialog box that when displayed is centered
$GUISize=WinGetClientSize($hGUI)
$myedit = GUICtrlCreateEdit($txt,-1, -1, $GUISize[0], $GUISize[1],$ES_READONLY)
GUICtrlSetResizing ( $myedit, $GUI_DOCKBORDERS )
    GUISetState()
DllCall("user32.dll","int","HideCaret","int",0)

Send("{END}")
    ; Run the GUI until the dialog is closed
    While 1
        $msg = GUIGetMsg()
        If $msg = $GUI_EVENT_CLOSE Then ExitLoop
    WEnd
    GUIDelete($hGUI)
EndFunc

;This is the first GUI. It asks for the information required to look up the order
Func RefGui()
$RefGui = GUICreate("Reference#", 261, 156, -1, -1)
GUISetFont(10, 400, 0, "Verdana")
GUICtrlCreateLabel("Enter Reference:", 15, 12, 116, 20)
$RefNum = GUICtrlCreateInput("REFERENCE #", 136, 8, 110, 24, BitOR($GUI_SS_DEFAULT_INPUT,$ES_UPPERCASE))
$OK = GUICtrlCreateButton("OK", 176, 120, 75, 25, BitOR($BS_DEFPUSHBUTTON,$BS_NOTIFY))
GUICtrlCreateGroup("Select Ref Type:", 16, 40, 145, 105, BitOR($GUI_SS_DEFAULT_GROUP,$WS_CLIPSIBLINGS))
$Internet = GUICtrlCreateRadio("Internet Order", 24, 64, 113, 17)
GUICtrlSetState(-1, $GUI_CHECKED)
$Sales = GUICtrlCreateRadio("Sales Order", 24, 88, 113, 17)
$Invoice = GUICtrlCreateRadio("Invoice", 24, 112, 113, 17)
GUICtrlCreateGroup("", -99, -99, 1, 1)
GUISetState(@SW_SHOW)
While 1
  $nMsg = GUIGetMsg()
  If $nMsg = $GUI_EVENT_CLOSE Then Exit

  If $nMsg = $OK Then
   ExitLoop
  EndIf
WEnd
If GUICtrlRead($Internet) = 1 Then
  $refType="Internet"
ElseIf GUICtrlRead($Sales) = 1 Then
  $refType="Sales"
ElseIf GUICtrlRead($Invoice) = 1 Then
  $refType="Invoice"
EndIf

$temp=GUICtrlRead($RefNum)
GUIDelete($RefGui)
Return $temp
EndFunc

Func MyErrFunc()
$hexnum=hex($objErr.number,8)
Msgbox(0,"","We intercepted a COM Error!!"    & @CRLF               & @CRLF & _
             "err.description is: " & $objErr.description   & @CRLF & _
             "err.windescription is: " & $objErr.windescription & @CRLF & _
             "err.lastdllerror is: "   & $objErr.lastdllerror   & @CRLF & _
             "err.scriptline is: "   & $objErr.scriptline   & @CRLF & _
             "err.number is: "     & $hexnum               & @CRLF & _
             "err.source is: "     & $objErr.source     & @CRLF & _
             "err.helpfile is: "       & $objErr.helpfile     & @CRLF & _
             "err.helpcontext is: " & $objErr.helpcontext _
            )
exit
EndFunc

Here is just the code for the first GUI so you don't have to look through all that:

Func RefGui()
$RefGui = GUICreate("Reference#", 261, 156, -1, -1)
GUISetFont(10, 400, 0, "Verdana")
GUICtrlCreateLabel("Enter Reference:", 15, 12, 116, 20)
$RefNum = GUICtrlCreateInput("REFERENCE #", 136, 8, 110, 24, BitOR($GUI_SS_DEFAULT_INPUT,$ES_UPPERCASE))
$OK = GUICtrlCreateButton("OK", 176, 120, 75, 25, BitOR($BS_DEFPUSHBUTTON,$BS_NOTIFY))
GUICtrlCreateGroup("Select Ref Type:", 16, 40, 145, 105, BitOR($GUI_SS_DEFAULT_GROUP,$WS_CLIPSIBLINGS))
$Internet = GUICtrlCreateRadio("Internet Order", 24, 64, 113, 17)
GUICtrlSetState(-1, $GUI_CHECKED)
$Sales = GUICtrlCreateRadio("Sales Order", 24, 88, 113, 17)
$Invoice = GUICtrlCreateRadio("Invoice", 24, 112, 113, 17)
GUICtrlCreateGroup("", -99, -99, 1, 1)
GUISetState(@SW_SHOW)
While 1
  $nMsg = GUIGetMsg()
  If $nMsg = $GUI_EVENT_CLOSE Then Exit

  If $nMsg = $OK Then
   ExitLoop
  EndIf
WEnd
If GUICtrlRead($Internet) = 1 Then
  $refType="Internet"
ElseIf GUICtrlRead($Sales) = 1 Then
  $refType="Sales"
ElseIf GUICtrlRead($Invoice) = 1 Then
  $refType="Invoice"
EndIf

$temp=GUICtrlRead($RefNum)
GUIDelete($RefGui)
Return $temp
EndFunc
Edited by LordBoling

Share this post


Link to post
Share on other sites



First, your GUIDelete is after the Return statement so it's never going to get acted on, you'll need to move it to before the Return statement. BUT, and this is extremely important, first read the contents of the $refnum input box and assign it to a variable, and then use the variable in the Return statement. If you don't do this, there's no control to read from anymore, so the contents will be lost when you delete the GUI.

Second, you should probably move the declaration of the variables outside of the While loop, it can slow the script down, just move the Global $reftype line to before the While 1 line.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

BrewManNH, Awesome!! Thank you, that solved the first issue perfectly, the RefGui now closes like it is supposed to. I knew I had to check the value before deleting the GUI but had forgotten that the Return keyword exits the function.

Unfortunately I still have the second issue. I predefined $refType as "Internet", but after RefGui() is called, it becomes blank. Anyone got any ideas on what is causing this? I did move the initial declaration outside of the loop as BrewManNH suggested but that did not affect what it is set to after the gui is called.

Updated code can be seen in the first post.

Share this post


Link to post
Share on other sites

If you need to reeturn more values from functions use ByRef parameters like this (tested,working):

#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#include <EditConstants.au3>
#include <StaticConstants.au3>
#include <ButtonConstants.au3>

Global $RefNum, $RefType

RefGui($RefNum, $RefType)
MsgBox (0, 'RefGui result', $RefNum & ' - ' & $RefType)

Func RefGui(ByRef $num, ByRef $type)
    $RefGui = GUICreate("Reference#", 261, 156, -1, -1)
    GUISetFont(10, 400, 0, "Verdana")
    GUICtrlCreateLabel("Enter Reference:", 15, 12, 116, 20)
    $RefNum_id = GUICtrlCreateInput("REFERENCE #", 136, 8, 110, 24, BitOR($GUI_SS_DEFAULT_INPUT,$ES_UPPERCASE))
    $OK = GUICtrlCreateButton("OK", 176, 120, 75, 25, BitOR($BS_DEFPUSHBUTTON,$BS_NOTIFY))
    GUICtrlCreateGroup("Select Ref Type:", 16, 40, 145, 105, BitOR($GUI_SS_DEFAULT_GROUP,$WS_CLIPSIBLINGS))
    $Internet = GUICtrlCreateRadio("Internet Order", 24, 64, 113, 17)
    GUICtrlSetState(-1, $GUI_CHECKED)
    $Sales = GUICtrlCreateRadio("Sales Order", 24, 88, 113, 17)
    $Invoice = GUICtrlCreateRadio("Invoice", 24, 112, 113, 17)
    GUICtrlCreateGroup("", -99, -99, 1, 1)
    GUISetState(@SW_SHOW)
    While 1
      $nMsg = GUIGetMsg()
      If $nMsg = $GUI_EVENT_CLOSE Then Exit

      If $nMsg = $OK Then
       ExitLoop
      EndIf
    WEnd

    If GUICtrlRead($Internet) = 1 Then
      $Type="Internet"
    ElseIf GUICtrlRead($Sales) = 1 Then
      $Type="Sales"
    ElseIf GUICtrlRead($Invoice) = 1 Then
      $Type="Invoice"
    EndIf

    $num=GUICtrlRead($RefNum_id)
    GUIDelete($RefGui)
EndFunc

Also check if you don't have the same variable names more than once (local x global)

I see $RefNum is such case

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Also it's better (more safe) to use

If IsChecked($Internet) Then
      $Type="Internet"
    ElseIf IsChecked($Sales) Then
      $Type="Sales"
    ElseIf IsChecked($Invoice) Then
      $Type="Invoice"
    EndIf

Func IsChecked($control)
    Return BitAnd(GUICtrlRead($control),$GUI_CHECKED) = $GUI_CHECKED
EndFunc
Edited by Zedna

Share this post


Link to post
Share on other sites

What makes you think that $reftype is getting blanked after the function returns? I tested parts of your script and it worked for me, but I can't test all of it because the script won't run as written.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Sorry guys. My bad. It was not returning blank. I was appending it to other variables using += instead of &=. This caused some issues of course. Once I fixed that everything seems to be working great.

Thank you for all the help guys.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • Miliardsto
      By Miliardsto
      Hello.
      Drag option works only on parent window but as we can see on the parent gui is showed up child gui (on the right side with the color).
      Desired action is when we want to drag whole program we can also drag child gui and child gui will drag with parent gui.
      How to do this?
       
      #include <GUIConstantsEx.au3> #include <WindowsConstants.au3> #include <Array.au3> GUIRegisterMsg($WM_NCHITTEST, "_NCHITTEST") $hGUI = GUICreate("Test", 500, 500, -1, -1) $cButton_0 = GUICtrlCreateButton("Child 0", 10, 10, 80, 30) $cButton_1 = GUICtrlCreateButton("Child 1", 10, 50, 80, 30) $cButton_2 = GUICtrlCreateButton("Child 2", 10, 90, 80, 30) GUISetState(@SW_SHOW, $hGUI) ; guis Global $hChild_[3] Global $countGUI = UBound($hChild_) - 1 ;MsgBox("","",$countGUI) ; licznik dla GUI Global $gui = 0 $hChild_[0] = GUICreate("Child 0", 350, 300, 150, 0, $WS_POPUP, $WS_EX_MDICHILD, $hGUI) GUISetBkColor(0xFF0000) GUISetState(@SW_SHOW, $hChild_[0]) $hChild_[1] = GUICreate("Child 1", 350, 300, 150, 0, $WS_POPUP, $WS_EX_MDICHILD, $hGUI) GUISetBkColor(0x00FF00) GUISetState(@SW_HIDE, $hChild_[1]) $hChild_[2] = GUICreate("Child 2", 350, 300, 150, 0, $WS_POPUP, $WS_EX_MDICHILD, $hGUI) GUISetBkColor(0x0000FF) GUISetState(@SW_HIDE, $hChild_[2]) While 1 Switch GUIGetMsg() Case $GUI_EVENT_CLOSE Exit Case $cButton_0 _All_Hide() GUISetState(@SW_SHOW, $hChild_[0]) $gui = 0 Case $cButton_1 _All_Hide() GUISetState(@SW_SHOW, $hChild_[1]) $gui = 1 Case $cButton_2 _All_Hide() GUISetState(@SW_SHOW, $hChild_[2]) $gui = 2 EndSwitch WEnd Func _All_Hide() GUISetState(@SW_HIDE, $hChild_[0]) GUISetState(@SW_HIDE, $hChild_[1]) GUISetState(@SW_HIDE, $hChild_[2]) EndFunc Func _NCHITTEST($hWnd, $uMsg, $wParam, $lParam) If $hWnd = $hGUI Then Local $aPos = WinGetPos($hWnd) If Abs(BitAND(BitShift($lParam, 16),0xFFFF)- $aPos[1]) < 500 Then Return $HTCAPTION EndIf Return $GUI_RUNDEFMSG EndFunc  
    • IAMK
      By IAMK
      Hello,
       
      I have a script which uses a GUI with two buttons. It gets shown and hidden., and pressing the buttons (including their hotkeys) highlights the button, making you able to press enter the next time.
      However, I don't want that.
       
      I've tried using WinActivate() to make enter do things on another program, but the enter is still tied to the AutoIT GUI (which still has the button highlighted).
       
      Here's the important part of my code:
      $MY_GUI = GUICreate("Check.exe", 400, 300, ((@DesktopWidth / 2) - 200), -500) WinSetOnTop($MY_GUI, "", 1) ;Keeps the window on the top. $Button1 = GUICtrlCreateButton("Pass (Ctrl+P)", 40, 250, 120, 40, $WS_GROUP) GUICtrlSetFont(-1, 12, 400, 0, "MS Sans Serif") $Button2 = GUICtrlCreateButton("Fail (Ctrl+F)", 240, 250, 120, 40, $WS_GROUP) GUICtrlSetFont(-1, 12, 400, 0, "MS Sans Serif") $GUIText = GUICtrlCreateLabel("", 20, 10, 360, 230) GUICtrlSetFont(-1, 13, 400, 0, "MS Sans Serif") GUICtrlSetData($GUIText, Execute($stepMessage[$step])) $showGUI = "True" GUISetState(@SW_SHOW) While($showGUI = "True") $buttonPressed = GUIGetMsg() Switch $buttonPressed Case $Button1 ;Pass $pass = "True" $buttonPressed = 0 $showGUI = "False" GUISetState(@SW_HIDE) Case $Button2 ;Fail $buttonPressed = 0 $showGUI = "False" GUISetState(@SW_HIDE) While($message = "") $message = InputBox("Check.exe", "Please enter the reason the step failed." & @CRLF, "", "", 300, 200, ((@DesktopWidth / 2) - 150), -400) WEnd Return $message EndSwitch WEnd Local $pass = "False" ;Whether "Pass" or "Fail" was pressed. Local $failLog = xxxfunc($pass) ;Returns a message to log if the step failed. ##THIS CALLS THE CODE SNIPPET ABOVE## FileWrite($file, _Now() & ": Step " & $step & getStatus($pass) & "and took " & Ceiling(TimerDiff($timer) / 1000) & " seconds." & @CRLF) If($failLog <> "") Then FileWrite($file, "Logged comment: " & $failLog & @CRLF) EndIf WinActivate("[TITLE:ProgramName]") ;Hotkeys: HotKeySet("^{p}", "pressPass") HotKeySet("^{f}", "pressFail") Func pressPass() $buttonPressed = $Button1 EndFunc Func pressFail() $buttonPressed = $Button2 EndFunc  
      The GUI's button/hotkey pressing works correctly.
      The same WinActivate code works in another script of mine.
      Together, WinActivate is not take "Active" away from the GUI's last-pressed button. How do I fix this?
       
      Thank you in advance.
    • fatpig
      By fatpig
      Dear AutoIT Community.
      I am currently working on a program that will display lots of images in a scroll down GUI.
      I create the GUI based on the number of images, which works fine.
      But all images I place using GuiCtrlCreatePic above a threshold of around 32000 pixels (cant say exactly) are placed at negative locations and finally will reach 0 again
      and will then populate on top of the images placed there before.
      For $i = 1 To $Images[0] ; Get picture dimensions $hImage = _GDIPlus_ImageLoadFromFile($ImgRep & $Images[$i]) $iX = _GDIPlus_ImageGetWidth($hImage) $iY = _GDIPlus_ImageGetHeight($hImage) _GDIPlus_ImageDispose($hImage) ; Resize & place images in GUI $Pic[$i] = GUICtrlCreatePic($ImgRep & $Images[$i], $Spacer, Round($yPos, 0), $MaxImgWidth, $MaxImgWidth * ($iY / $iX)) $yPos = $yPos + $MaxImgWidth * ($iY / $iX) + $Spacer $log = $log & "|" & $yPos $currentlut = $Images[1] Next I have found a limit at 32767 pixels for some GUI elements when googling around.
      Can someone tell me how to circumvent that?
      thanks!
      cheers
      Felix
    • Shirdish_chakravarthi
      By Shirdish_chakravarthi
      Hello Guys this is my gui and i need the numeric value typed in the highlighted  inputbox. if this value is greater than 1 i need to perform some operations
      \
       
      Here is the summary about that field which i got from wininfo tool

      i tried writing the code as shown below.. but the msgbox is popping up empty value..when the same code is pasted under some button action i am able to access the value present in the field..but when placed alone as written in the attached script i am unable to fetch it... 

      here i am using the valu present in the field

      can you guys tell me what's wrong??? or how can i get that value?
       
      My_GUI.au3

    • Neonovaz
      By Neonovaz
      Hello
       
      Is there anyway to store word documents in Autoit GUI? For example I have a instruction sheet that I want to bundle up with the exe.

      So a user simply clicks the icon and the stored document will launch  (Something like how you can add objects like excel sheets in word documents )

      (I Know we can launch word files from script directory)