Sign in to follow this  
Followers 0
EmptySpace

Solved. JITDebugger.Getting this window when trying to launch script

16 posts in this topic

#1 ·  Posted (edited)

More and more times I get this window , I have to hit no like 5 times but sometimes all autoit wont respond at all. So anyone knows why I get this after launching script? If I try to debug it just stucks/do nothing...

lPosted Image

Ahhh im so tired of this! Cant get rid of it... ;)

--------------------------------------------------solved---------------------------------------------------------------------

I spent ~4hours browsing my windows and searching that debugger, it stops my pc! I just disabled(diable didnt worked, idk i did something) it as i didnt found out how to uninstal it.

So if anyone is having same problem:

Go to regedit

HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindows NTCurrentVersionAeDebugDebugger

from

"C:\Windows\System32\vsjitdebugger.exe" -p %ld -e %ld change to 0.

-----------------------------------------------edit---------------------------------------------------------

Previous method worked only 3times. I got mad when it poped out again! I searched for vsjitdebugger in system and deleted all files! It disappeared now! Finally...

Edited by Edgaras

Share this post


Link to post
Share on other sites



Are you making a joint application? Anytime my AutoIT crashes (its rare) my JIT debugger never opens!

Share this post


Link to post
Share on other sites

Mostly it pop ups when I embed browser into gui and when im trying to launch it then debuger shows... I have to click "no" like 10 times then it disappears and script works fine...

Share this post


Link to post
Share on other sites

Didnt understood what you just wrote but this affect appears when I make web browser + ip changer + some buttons which navigates to sites...

Share this post


Link to post
Share on other sites

I deleted whole my project codes since I get this... Its GUI where is ie embeded and some simple buttons. It works fine it launches but when i navigate somewhere i get that window after i close it everything is ok but when i navigate to same web again it appears again. Even with google.com lol

Share this post


Link to post
Share on other sites

Nah, no need to solve it now. Just was wondering why I get this... Maybe something wrong with my computer? Becouse it works fine for others (friends etc.)

Share this post


Link to post
Share on other sites

No no no its small enought code. You dont know how gui looks with embeded browser? lol

Share this post


Link to post
Share on other sites

#14 ·  Posted (edited)

Just found out that something wrong with this debugger. Even when browsing the net it sometimes appears saying that iexplorer.exe or other browser have an unhandled exception. Im trying to uninstall it somehow but cant find it.

Edited by Edgaras

Share this post


Link to post
Share on other sites

The debugger shouldn't be enabled by default. I'd expect that either you have the /debug switch in your boot.ini or possibly enabled by another setting... like this:

http://www.kensfi.com/how-to-disable-just-in-time-debugging/

Share this post


Link to post
Share on other sites

Lol, I tried everything. But it didnt worked... I got rid of it only deleting some files...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0