Sign in to follow this  
Followers 0
ileandros

FireWall for blocking certain IP.

11 posts in this topic

#1 ·  Posted (edited)

Hello,

Its my first time doing this and i need a hand here from someone who has already messed up with firewall.

When i connect to a programm(random one) my IP adress keeps changing. Actually i got 2 IP adress(Foreign Adress), one that is changing some digits everytime i connect and one other that is always the same.

I am trying to block all Foreign addresses besides a specific one.

So here we go:

My Proto is TCP

My two Local Addresses are: (192.168.1.6:49991 , 192.168.1.6:50084)

My two Foreign Addresses are: (80.239.208.193:1119 , 80.239.XXX.XXX:1119) the second one here keeps changing everytime i reconnect.

What i want to do is to set a firewall that is going to block all Foreign Addresses and let me join only on a specific one which is gonna be this: 80.239.XXX.74:1119

But i don't understand what the last 5 digits after the Local Address and the last 4 digits after the Foreign Address are...?? Are they local ports? Remote ports?

How can i block them in the Firewall advanced settings? How can i make my computer run only on the selected address???

Here is a photo of netstat in cmd

Edit: Here is photo of my FireWall advanced setting. I dont really know how to set it so please take a loot

post-68849-0-58863000-1347318819_thumb.p

post-68849-0-09023800-1347319016_thumb.p

Edited by ileandros

I feel nothing.It feels great.

Share this post


Link to post
Share on other sites



80.239.XXX.74:1119 =

80.239.XXX.74 is the entire IP address, it's always a quad (111.222.333.444).

1119 is the port to connect to at the IP.

But I don't understand really. You want to block all outgoing connections from all programs and only allow connections to 80.239.XXX.74?


[center]Spiderskank Spiderskank[/center]GetOpt Parse command line options UDF | AU3Text Program internationalization UDF | Identicon visual hash UDF

Share this post


Link to post
Share on other sites

Not really. Only for the programm im running. So i edited it and changed the Local port to 1119 but still my IP is not the set one(80.239.XXX.74:1119)... Its random 80.239.XXX.XXX:1119


I feel nothing.It feels great.

Share this post


Link to post
Share on other sites

Ok, got it. But this 80.239.XXX.74:1119 are those three X's also random?

Doubleclick the program entry in the Advanced Settings window. Go to the Scope tab. There you can enter a subnet mask or an entire range of IP's for the remote connections allowed.


[center]Spiderskank Spiderskank[/center]GetOpt Parse command line options UDF | AU3Text Program internationalization UDF | Identicon visual hash UDF

Share this post


Link to post
Share on other sites

This is how im doing it but still my ip address is different everytime. Connecting server is not the same. In the scope setting i changed both the Local Ip address and the Remote Ip addres but still nothing...

80.239.XXX.74:1119 yes they are also random. Not big range though arround 200 - 215.


I feel nothing.It feels great.

Share this post


Link to post
Share on other sites

Then I wouldn't know. Try a Windows forum.


[center]Spiderskank Spiderskank[/center]GetOpt Parse command line options UDF | AU3Text Program internationalization UDF | Identicon visual hash UDF

Share this post


Link to post
Share on other sites

Yeah ur right. But i made a project with autoit massing with firewall thats why i asked here.

Anyway this is how it is. Any other ideas people???


I feel nothing.It feels great.

Share this post


Link to post
Share on other sites

Cmon people its a programming forum... Anyone knows a powerfull tools for firewall???

Bump


I feel nothing.It feels great.

Share this post


Link to post
Share on other sites

1) Allow inbound/outbound: 80.239.208.0 - 80.239.211.255 (Check to see if they are using static ports or dynamic. If dynamic you need to allow port any)

2) Block inbound/outbound: any/all

Order of rules are essential.

Question: What is the necessity to connect to Blizzard servers only? Dedicated gaming rig?

Share this post


Link to post
Share on other sites

Its the first time im doing this so please explain me how to do it more simply. Never messed up with firewall again so i dont quiet understand the ports. How don i allow? And which ports. Local or remote? Do i use range? I found my prog in inbound but not in outbound settings. I have no idea how to block it.

Answer is that i have a client seeding to public and i leech from Blizzard. I talk with some people and gave me some IP addresses which my leech would be easier so my programm would work better. Leeching and seeding causes a lot of lagg and delay to my programm and blizzard has a lot of servers. Some of them are pretty good....


I feel nothing.It feels great.

Share this post


Link to post
Share on other sites

If you do not know what port the server is allowing inbound connections to then you would need to allow any port on outbound traffic for you app.

Look at the second picture you uploaded. See where it says private for your application? You need a rule under Public for your app.

If all the rules in the picture are for your app you need to remove most of them that allow any local and any remote.

Your local IP will not change unless you are using a DHCP client or you have multiple network adapters. In other words, you have one private (local; NAT) IP.

If you have questions, please be specific and not request a whole lesson in ACLs (access control lists) because not all behave the same.

I am willing to help you learn further but you need to clarify what you are doing with Blizzards servers. When you say seed/leech all I can think of is bt. And if that is the case I still don't know what you are doing pointing your app to their servers. Since when does Blizzard host bt nodes?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0