Jump to content
Sign in to follow this  
RedneckTech

Compiling does not work

Recommended Posts

RedneckTech

Just wrote a new script. Just a stupid ping checker. Went to compile it and UPX was unable to "compress the stub". Tried it with another script I wrote in the past and now I got a different error. Tried on several different old scripts and none will compile, all for random errors. Tried updating to the new autoit. did not work. Installed the "Full" SCIte and still same problem... any information on this?

Tried via right click -> compile, Compile (x86), and Compile (x64) options

Share this post


Link to post
Share on other sites
RedneckTech

Sorry for double. Also the created .exe (in all cases) can not be moved, renamed, executed, deleted until I reboot. I can edit the script, but unless I rename it i cannot recompile it or i get the error "Error: error opening the destination file"

Share this post


Link to post
Share on other sites
BrewManNH

Sounds like something is accessing your script during the process. Is it in a Dropbox or similar location? AV locking it perhaps?


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
RedneckTech

tried that. Turned off MSSE, google drive turned off

G-Drive shouldnt be affecting though as its not in that folder

Share this post


Link to post
Share on other sites
iamtheky

"Error: error opening the destination file"

I get that on Win7 on occasion if I have the destination folder open, and a script of the same name in that folder. So while the symptoms match post #2, it does not occur with the regularity that post #1 would seem.


,-. .--. ________ .-. .-. ,---. ,-. .-. .-. .-.
|(| / /\ \ |\ /| |__ __||| | | || .-' | |/ / \ \_/ )/
(_) / /__\ \ |(\ / | )| | | `-' | | `-. | | / __ \ (_)
| | | __ | (_)\/ | (_) | | .-. | | .-' | | \ |__| ) (
| | | | |)| | \ / | | | | | |)| | `--. | |) \ | |
`-' |_| (_) | |\/| | `-' /( (_)/( __.' |((_)-' /(_|
'-' '-' (__) (__) (_) (__)

Share this post


Link to post
Share on other sites
RedneckTech

Just for craps, where is upx.exe stored by default? cant find it at all

Share this post


Link to post
Share on other sites
RedneckTech

@boththose.also on win7. hmm.... tried going through SCIte before and didnt work, but when i closed the window like you mentioned then tried through SCIte it worked.... this is strange.....

Share this post


Link to post
Share on other sites
SmOke_N

- Rogue app that has a file lock on your script.

- Maybe already have exe running from a test and never closed it before trying to re-compile.

- Sometimes I've found on Win7 that if I have the folder I'm compiling from Open/Visible it causes compile issues.

I'd bet on #1 or #2 of the above.

Restart your PC, open SciTe only ... to ultimately confirm ;) (unless you have the exe in the system startup of course) .


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites
JohnOne

I have similar issues, where I can not delete/rename a folder from which I have had open, and ran code from scite. Even if scite is closed, no exe's running and all files have been deleted, something still has hold of the folder until reboot or restart shell.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites
RedneckTech

Once i close the active explorer windows containing the source script closed it runs fine. cannot have source scripts on the desktop. No problems there i just cant be lazy anymore

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×