Jump to content
Sign in to follow this  

Fetching a button which is inside a window using AUTOIT

Recommended Posts



I am trying to click on a button which is embedded inside a window, i have tried WinMenuSelect option in AutoIT but it doesnt help, has anyone faced such a situation ? would anyone be able to help me get out of this? My app is a windows app built on VC++ and the scenario i am trying to automate is for eg you have one main window (whose properties can be fetched via Au3WindowInfo tool), this window has x,y,z buttons in it and when i try using Au3WindowInfo tool i dont see any of the properties for these x, y,z. So is there a way where i could ask AutoIT tool to click on button x which is inside the main window?

I have tried searching the forums if this topic already exisit but couldnt find any :(

All help appreciated.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.