Jump to content
Sign in to follow this  
ijourneaux

Canon EOS Utility

Recommended Posts

ijourneaux

I am trying to take control of a Canon camera via the EOS utility. I have been able to snap pictures by clicking on the takePicture button but I can seem to figure out how to control the AutoFocus toggle and the fStop 

The AF/MF toggle comes up as a WindowsForms10.Button.app.0.3553390 with a name of adMfSwitch1

The FStop show up as WindowsForms10.Button.app.0.3553390 with a name of olcAv

I can use the instance as that seems to change depending from one execution to the next,

Ian

Share this post


Link to post
Share on other sites
ijourneaux
AutoItSetOption('WinTitleMatchMode', 2)
Local $hWnd = WinWait(" EOS REBEL T5i", "", 10)
winactivate($hWnd)
consolewrite($hwnd &@crlf)
ControlClick($hWnd, "", "[Name:takePictureButton]")         ' This takes a picture
ControlClick($hWnd, "", "[Name:afMfSwitch1]")                  ' This toggles the auto manual focus button
' Unfortunately I need to know what the state of the button is so I know whether to toggle it or not
' I tried querying the control itself
consolewrite("Text: " & ControlGetText($hWnd, "", "[Name:afMfSwitch1]") & @crlf)
' and a text display there the control status is displayed
consolewrite("Text: " & ControlGetText($hWnd, "", "[Name:olcAFMode]") & @crlf)
 
Neither worked

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×