Jump to content
Sign in to follow this  
Seminko

Unable to click in an application

Recommended Posts

Seminko

Hey fellas,

I have this application and somehow Mouseclick will not click it. At all.

When the application is the active window, Mouseclick will do nothing. Not even move the mouse.

When the application is NOT the active window, Mouseclick will actually move the mouse over the app but not click anything.

WindowInfo say the app is Class: QWidget.

Any ideas?

Thanks

Share this post


Link to post
Share on other sites
MikahS

any chance we could have a look at the script you've written? :)


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

any chance we could have a look at the script you've written? :)

 

There is really no need to as it is only Mouseclick

Sleep(3500)
MouseClick("left", 111, 518, 3, 3)

Share this post


Link to post
Share on other sites
MikahS

You have 5 parameters in MouseClick when it can only take 4

EDIT:nevermind I'm dumb sometimes

Edited by MikahS

Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

No it doesn't. MouseClick(button, x, y, number of clicks, speed)

No problem ;)

Edited by Seminko

Share this post


Link to post
Share on other sites
BrewManNH

What's the application? Sounds like an application specific problem because MouseClick by itself isn't the problem.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
MikahS

I think BrewManNH could be right, just tested it and my MouseClick() call moves both whether its active or not.


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

What's the application? Sounds like an application specific problem because MouseClick by itself isn't the problem.

It is an application that logs specific actions I want to track. I asked the developer and he said the app is not protected in any way.

EDIT: when I start the application I get the warning to confirm whether to allow to make changes on the hard drive. If that is something to consider.

Edited by Seminko

Share this post


Link to post
Share on other sites
MikahS

Here is my code that I tested to make sure it wasn't something in the MouseClick function..

Local $msgbox

Run("Notepad.exe")

$msgbox = MsgBox(4, "", "Active or not active; Yes is active, No is not-active")
If $msgbox = 6 Then
    WinActivate("Notepad")
    MouseClick("left", 15, 15, 1, 999)
Else
    MouseClick("left", 15, 15, 1, 999)
EndIf

Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

Thanks Prodigy but I know for a fact it is not an issue with the function.

It is an issue with the app. I am asking whether some of you have already experienced something similar.

Share this post


Link to post
Share on other sites
MikahS

Definitely :) just for clarifying anyone else that wants to help ;)


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
JLogan3o13

Without the name of the app (if it is commercial), or screenshots/full Window Info Tool Information on the app it is a little difficult to help you troubleshoot.


√-1 2^3 ∑ π, and it was delicious!

How to get your question answered on this forum!

Share this post


Link to post
Share on other sites
MikahS

ooo the full Window Info Tool information JLogan said would help out a ton :)


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

Well I don't think it will help but here:

>>>> Window <<<<
Title:  LogMyActions 28.0823
Class:  QWidget
Position:   477, 306
Size:   726, 490
Style:  0x96CF0000
ExStyle:    0x00000100
Handle: 0x000D03C6

>>>> Control <<<<
Class:  
Instance:   
ClassnameNN:    
Name:   
Advanced (Class):   
ID: 
Text:   
Position:   
Size:   
ControlClick Coords:    
Style:  
ExStyle:    
Handle: 

>>>> Mouse <<<<
Position:   903, 438
Cursor ID:  0
Color:  0xFFFFFF

>>>> StatusBar <<<<

>>>> ToolsBar <<<<

>>>> Visible Text <<<<


>>>> Hidden Text <<<<

Share this post


Link to post
Share on other sites
MikahS

You forgot the screenshots :) as you already stated, now that we see that their isn't any info really in the info tool.


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

Again, don't know why, but here:

HKDRWwv.jpg

Share this post


Link to post
Share on other sites
MikahS

Pretty sure if an MVP asks for the information to help, there is a purpose :)


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites
Seminko

Oh, don't get me wrong. I don't doubt you guys. I sincerely don't know why :)

Share this post


Link to post
Share on other sites
MikahS

Your application is obviously stopping the MouseClick function from running, we are trying to find out why :)


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×