Sign in to follow this  
Followers 0
GoldenMike

Can't Click on Button in IE

6 posts in this topic

Hi everyone,

I've been using IE automation for about three years now and have created about 100 different automation scripts for my business mainly using IE automation.  A website that I use has just updated and is giving me problems clicking on a button. I've never really encountered this before, but this is what is happening.

There are two frames, both of which I can navigate into.

I create a link to the button (have done this many way, either by _IEGetObjbyName, IEGetObjbyID, or even doing a _IETagNameGetCollection, and sorting this by Class name to get the object i want)

All three ways give me a link to the object, which can be verified through a console write outer html read out.

The button is a radio, and Autoit will let me

$oButton.checked = True - to check the button

But the site will not let me do

$oButton.click

$oButton.onclick

$oButton.fireevent("onClick")

$oButton.fireevent("onMouseOver")

And the webpage won't respond, or update accordingly.

Here is the HTML for the radio button:

<input name="SearchType" id="searchTypeNumber" type="radio" CHECKED="checked" value="searchTypeNumber">

Not sure if this is any help but this is the form HTML

<form name="Form" id="Form" action="/status/search" method="post" novalidate="novalidate">

I have used this website in other areas that have changed as well, and successfully navigated through other forms.

Any thoughts or help on this is appreciated

Thanks,

Mike

Share this post


Link to post
Share on other sites



You didn't mention _IEFormElementRadioSelect. Have you tried that?

Share this post


Link to post
Share on other sites

j0kky - this worked.  Thank you so much.

Any idea why this worked, and nothing else?

Exit and DanP2 - I can't show code, it is a protected healthcare site.

Share this post


Link to post
Share on other sites

_IEAction($oButton, "click") work, because click() - is the method.

And you tried to get the property $oButton.click

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0