Sign in to follow this  
Followers 0
RickB75

Autoit 3.3.12 Error: separator character before keyword

9 posts in this topic

I'm using Jos' _InetSmtpMailcom function and I'm getting an error. 

"C:UsersecommgrDocumentswebsiteScriptsucs.au3"(222,15) : error: missing separator character before keyword.
    $objEmail.To
~~~~~~~~~~~~~~^
 
I have the most recent version of Autoit and I just downloaded the most recent version of SciTE . Is there a fix for this using the Autoit version that I'm using? I did see a post from JPM:
 
saying that he updated the Au3Check.exe file but I can't find it. I went to this page but the download link is broken
 
 
I did see a post Jos made here: 
 
saying to update to the Beta version. Is that the only fix for this???
 
 

Share this post


Link to post
Share on other sites



let me try that. Thanks for your input John :)

Share this post


Link to post
Share on other sites

Just now tried Tidy and it didn't work. Same error. I've read that this is just an issue with the Au3check.exe. Is there a way to turn it off for that particular script?

Share this post


Link to post
Share on other sites

I think thats it John. Quick question? Can I Place that in different sections of the script like this?

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

#AutoIt3Wrapper_Run_AU3Check=n

Mail function 

Blah, blah blah

#AutoIt3Wrapper_Run_AU3Check=y

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

More script here

Share this post


Link to post
Share on other sites

To get rid of that message, you should update your version of Au3Check to the latest version found here.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Thats the file I was looking Brewman. :thumbsup:   I searched the forums and the downloads section for the Scite Beta version but I couldn't find it. Both of you guys have made my night. Thank you, Thank you, Thank You. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0