Sign in to follow this  
Followers 0
firestrife23

Syntax Error make my head hurt...

8 posts in this topic

I'm sure you'll see this as noobish mistake but I've been trying to get this to work... 

The following line worked great:

DirCopy('"' & $sSourceFolder & '"', '"' & $sDestFolder & '"')

However next line is similar to above but launch as secondary process so my script can wait until the process no longer exist. The problem is... it's giving me syntax error, and I suspected it may have to do with ' or "

Local $pid = Run(@AutoItExe & ' /AutoIt3ExecuteLine DirCopy( '"' & $sSourceFolder & '"', '"' & $sDestFolder & '"' )')

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Try shellexecute instead of run and post the results.

Edit - I thought DirCopy was an external command. https://www.autoitscript.com/autoit3/docs/functions/DirCopy.htm I dont thing that setting a variable to DirCopy will return a PID. Try XCOPY with ShellExecute.

Edited by computergroove

Get Scite to add a popup when you use a 3rd party UDF -> http://www.autoitscript.com/autoit3/scite/docs/SciTE4AutoIt3/user-calltip-manager.html

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Great suggestion, I'm trying keep this script as native as possible but if xcopy is included with every version of windows then I might just use that instead. I'll report back soon with result.

Edit: Here's snippet of function i'm working on... I just realized if I use XCOPY then I cannot use progress bar.... 

Func _CopyFolder($sSourceFolder,$sDestFolder, $foldername)
   DirRemove($sDestFolder,1)
   Local $iSourceSize = DirGetSize($sSourceFolder), $iDestSize
   Local $pid = Run(@AutoItExe & ' /AutoIt3ExecuteLine DirCopy( '"' & $sSourceFolder & '"','"' & $sDestFolder & '"' )') ; <== This line is having issue.
   Do
     Sleep(350)
     $iDestSize = dirgetsize($sDestFolder)
     Local $ipct = int(($iDestSize/$iSourceSize)*100)
     GUICtrlSetData($sPStatus, $ipct & '% - Copying ' & $foldername & "...")
     GUICtrlSetData($sProgressBar, $ipct)
     Sleep(20)
   Until Not ProcessExists($pid)
EndFunc

If I substitute Line 4 with this code

Local $pid = Run(@AutoItExe & ' /AutoIt3ExecuteLine "DirCopy(''' & $sSourceFolder & ''', ''' & $sDestFolder & ''')"')

It'll work but if the folder's name contain ' character then it'll break...

Edited by firestrife23

Share this post


Link to post
Share on other sites

bump...

Share this post


Link to post
Share on other sites

2 things you can try, first don't use ' in a folder/file name. Or second use double quotes instead of single quotes, you'd have to change the surrounding quotes on the command line, but shouldn't be that hard to do.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

try this:

Local $pid = Run(@AutoItExe & ' /AutoIt3ExecuteLine DirCopy("' & $sSourceFolder & '"', '"' & $sDestFolder & '")')

"The mediocre teacher tells. The Good teacher explains. The superior teacher demonstrates. The great teacher inspires." -William Arthur Ward

Share this post


Link to post
Share on other sites

jguinch,

your solution is working, and thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0