Jump to content
Sign in to follow this  
Rainbowhat

Unable to Click on Handler

Recommended Posts

Rainbowhat

Hi All,

I had really read through a lot of samples and still cant get it to work on my handle .

1) I'm able to detect the colour using some sample code but even Send Space wont execute the space command inside the handler

2) May I know if I can mainly get coordinate inside the Handle or I just have to always use my screen resolution coordinate

3) How do I do a proper CLICK, It just wont click no matter what I do. It wont click the handler, it can detect the pixel but the click and space wont execute.

Apologies but I did do search around but just cant get any of those sample code to work.
 

WinActivate("Player")
Local $hWnd = WinGetHandle ("Player")
Send("{SPACE}")
Send("{SPACE}")
Send("{SPACE}")

$coord = PixelSearch(866, 0, 1280, 720, 0x427FED)
If Not @error Then
    MouseClick("left", $coord[0], $coord[1], 1, 0)
EndIf

Opt("MouseCoordMode", 1) ; Default, screen relative
Opt("PixelCoordMode", 1) ; Default, screen relative

Edited by Rainbowhat

Share this post


Link to post
Share on other sites
Blue_Drache

Bluestacks ... is a gaming application.  Nice try.  Go read the rules.

Edited by Blue_Drache

Lofting the cyberwinds on teknoleather wings, I am...The Blue Drache

Share this post


Link to post
Share on other sites
Rainbowhat

Cant simply just categories everything as game. Seriously? I'm not even interested in games please. I have better use for autoit other than some damn games. Have a living to make here bro, just trying out different type of technology to increase productivity

Edited by Rainbowhat

Share this post


Link to post
Share on other sites
Rainbowhat

I guess I have to find my way around?

And from what I've read on here, it actively resists automation.

Share this post


Link to post
Share on other sites
Rainbowhat

Try Andy emulator

That's something new ! Thanks for the share but what's the different would my code do. Actually I lost of old code which is why i'm trying to reproduce but just cant get it as good as I did previously. I remember having this issue of not being able to click back then too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×