Sign in to follow this  
Followers 0
Darkbanner

/AutoIt3ExecuteScript no longer working with compiled scripts?

3 posts in this topic

#1 ·  Posted (edited)

Hey guys, I tried to use /AutoIt3ExecuteScript on my compiled script today, as described in the AutoIt documentation (see below). 

I basically tried to execute an 2nd script with it: 

my1stscript.exe /AutoIt3ExecuteScript my2ndscript.au3

This executed the code of my1stscript.exe and not the code from my2ndscript.au3

 

Did I miss something or is this a bug? 

 

 

 

Run a script using another compiled script:

Compiled.exe [/ErrorStdOut] /AutoIt3ExecuteScript file [params ...]

                Execute another AutoIt script file from a compiled AutoIt3 executable. 

Compiled.exe [/ErrorStdOut] /AutoIt3ExecuteLine "command line"

                Execute one line of code as with AutoIt3.exe above. 

This means that there is no need to have a copy of AutoIt3.exe in addition to the compiled file - the interpreter stub of the compiled file will replace it.  So as long as there is at least one compiled script available, other AutoIt scripts can be run without the need to have AutoIt3.exe on the machine., either pre-installed or added via FileInstall.

https://www.autoitscript.com/autoit3/docs/intro/running.htm

Edited by Darkbanner

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

There is some #pragma directive you have to set to true, which is false by default, not sure which.

EDIT:

#pragma compile(AutoItExecuteAllowed, true)

Edited by JohnOne
1 person likes this

AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0