Herb191

Au3Recorder adding bad text/code when it runs

6 posts in this topic

I have not used Au3Recorder in a long time but I got bored yesterday and thought I would play with it a bit. I noticed right away that it was adding the following text to the top of the code every time I ran it:

+>         SciTEDir => C:Program Files (x86)AutoIt3SciTE   UserDir => C:UsersHerbAppDataLocalAutoIt v3SciTEAutoIt3Wrapper   SCITE_USERHOME => C:UsersHerbAppDataLocalAutoIt v3SciTE  

It’s not a big deal because I can just comment it out or delete it but I was wondering if anyone else was having this problem or if it was just me? I did a fresh install to see if that would fix the problem but it still does the same thing.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

I get the same thing, SciTEDir, UserDir, SCITE_USERHOME as well.

Not sure this is considered a problem, more or less just information for the user. :)

EDIT: At this point I'm not sure, as when trying to run it and compile it it gives me errors. Seems my knowledge on this subject is miniscule.  :geek:

Edited by MikahS

Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

I searched the forum for a solution but did not think to search the AutoIt issue tracker. This bug has been found and fixed. Here is the link to the solution.

Share this post


Link to post
Share on other sites

Thanks for the link, Herb191. :)


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

Thanks for the link, Herb191. :)

No problem. Thank you for helping me look for the solution.

Share this post


Link to post
Share on other sites

You're more than welcome.  ^_^


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • kcvinu
      By kcvinu
      Hi all,
      I am using AutoIt version 3.3.14.1. When i click on the menu item "AU3Recorder" in Tools menu nothing happens. So i checked in SciTE folder in installation directory. I can't find AU3Recorder in anywhere. What is the problem ?
    • Japanimation
      By Japanimation
      Hey guys, firstly - I'm new to all of this. I have a rather mundane task that I want repeated on my computer whenever I'm not home; However, I am no good at using AutoIt or any form of coding. But I was told that I could use a program here that would record my actions and form them into an AutoIt script. What I want done isn't a big task, just a simple click, wait, click, wait, click, wait, that would repeat itself for some time. But my issue is.. I cannot find Au3Recorder or ScriptWriter in my AutoIt directories. I actually browsed the forums a little bit and followed some of the suggestions (checking different folders, downloading the .zip instead, but I still can't find it.) Any help is greatly appreciated.

      Edit: After some more exploration, I have actually found Au3Recorder in the .Zip of the latest Autoit, in the Extras directory that was not included in the regular .exe installation. Thanks anyways, though! Sorry for the spam.