Jump to content
Sign in to follow this  
Skysnake

[RESOLVED] Firebird SQL create database ... create table problem

Recommended Posts

This thread splits off from this part of the conversation:

I do not think that this related to the actual ADO.UDF, which does connect successfully to the default RDB$DATABASE.  Question is on the actual DDL to use to (a) create database and (b) create table.  

I cannot create database with ADO.UDF, that may require ADOX and is receiving attention.

 

I have tested SQL queries on PostgreSQL and SQLite which worked, but on the Firebird it just does nothing.

Permissions perhaps? Although I use the same connection string...

; My AutoIt 

sConnectionString = DSN=Firebird;DATABASE=C:\AutoIt\ado_db\firebird\showDB_ado.fdb;SERVER=localhost;PORT=3050;UID=sysdba;PWD=masterkey;

Local  $new_fdb="CREATE TABLE drinks (    ID INTEGER PRIMARY KEY,NAME VARCHAR(100) NOT NULL    ) ; "

    Local $qResult = _ADO_Execute($sConnectionString, $new_fdb)
      ConsoleWrite("$qResult " & $qResult & " * "& $new_fdb & " * Line: "& @ScriptLineNumber &@CRLF)
      
;==============
;Scite output

$qResult -1 * CREATE TABLE drinks (    ID INTEGER PRIMARY KEY,NAME VARCHAR(100) NOT NULL    ) ;  * Line: 64
$qResult -1 Line: 76

I have tried "REcreate table..." as some sources indicate that it is the way to go. No success.

Edited by Skysnake

Skysnake

Why is the snake in the sky?

Share this post


Link to post
Share on other sites

 I was under the mistaken impression that the IBProvider was included in the standard Firebird installation.  In addition, Firebird is free, and the standard free installation can create dbs using iSQL, but the IBProvider is not free, but comes with a trial version.

If the choice is to pay for IBProvider to create Firebird db's or create for free manually, I will stick to iSQL.

ttp://www.ibprovider.com/eng/download.html

It appears that ADO itself can not create Firebird databases.


Skysnake

Why is the snake in the sky?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Nas
      Hello Guys,
       
      I am running the Ado example script, if I run this line, it runs without errors :
      Local $sConnectionString = 'DRIVER={' & $sDriver & '};SERVER=' & $sServer & ';DATABASE=' & $sDatabase & ';UID=' & $sUser & ';PWD=' & $sPassword & ';' But when I try the windows auth one , it failed everytime :
      Func _Example_MSSQL_WindowsAuthorization() Local $sDatabase = 'AdventureWorks2016' Local $sServer = 'SQLSRV' _Example_5_MSSQL_WinAuth($sServer, $sDatabase, "Select * from Person.Address") EndFunc here is the error :
       
      ADO.au3 v.2.1.16 BETA (1204) : ==> COM Error intercepted !
      $oADO_Error.description is:     Provider cannot be found. It may not be properly installed.
      $oADO_Error.windescription:     Exception occurred.
      $oADO_Error.number is:     80020009
      $oADO_Error.lastdllerror is:     0
      $oADO_Error.scriptline is:     1204
      $oADO_Error.source is:     ADODB.Connection
      $oADO_Error.helpfile is:     C:\Windows\HELP\ADO270.CHM
      $oADO_Error.helpcontext is:     1240655
      By the way, I have 64x windows server 2016 with SQL Server , I already installed the odbc my sql connector, any thought on this will be greatly appreciate it.
×
×
  • Create New...