Jump to content

ie type in textbox doesnt keep text

Recommended Posts


Basically I need to type a text in 2 text boxes and press Save button to proceed further.

After pressing Save button the text disappears from those text boxes.

Local $oIE = _IEAttach("page")

$firstName = "Andy"
$lastName = "Gour"

 $oDiv = _IEGetObjById($oIE, "2c54f866-bf1b-4999-b587-7971d7d8648c")

 $oFirstName = _IEGetObjById($oDiv, "b91587da-5723-4b0f-8c5d-2c42f80e99ab")
 $oLastName = _IEGetObjById($oDiv, "f1bee0d0-651a-49aa-887b-4bab3745072f")

 ;fill up
_IEAction($oFirstName, "focus")
_IEFormElementSetValue($oFirstName, $firstName)
_IEAction($oLastName, "focus")
_IEFormElementSetValue($oLastName, $lastName)

The code works perfectly and text is in text boxes, but as soon as I press save button for this page the text disappears and status check for those text-boxes shows they are empty.

If I use Selenium webdriver - no problem, Sikuli - no problem as well, only with AutoIt.



Edited by sqa
added some description

Share this post

Link to post
Share on other sites

Sounds like the page is refreshing when clicking save/submitting, whats the code you use to save/submit?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.