BobboP

IECreateEmbedded issue

7 posts in this topic

#1 ·  Posted

Hi Guys.

A while ago, we created a basic browser using IECreateEmbedded to host a specific website.  We have done this so we can use custom buttons and functions linking to other installed application software.  The website itself was recently revamped and now the layout is wrongly presented in the custom browser.

I have checked the helpfile and found that the example script in the helpfile (which hosts the AutoIT website), seems to have the same issue displaying the AutoIT website, even if you increase the size of the browser window.  The top menubar is not displayed properly for starters.  I guess that the IE browser that AutoIT uses is now out of date and not compatible with some of the latest website designs.

Would be grateful to learn of any fixes that others have created or found.

Thanks in advance.

Share this post


Link to post
Share on other sites



#2 ·  Posted

Use Firefox or Chrome UDF if you want to display the site properly with HTML5 and CSS3 websites.

Please update to the latest IE and contact Microsoft to fix your site display for accuracy.
I think it would be faster to edit website code to be compatible with IE, which is faster than catching IE support for your code :)
AutoIT does not relate to IE support!


Regards,
 

Share this post


Link to post
Share on other sites

#3 ·  Posted

Hi VIP

Many thanks for the fast response and advice.  I am quite inexperienced but am trying to learn and appreciate your kind help.  I will look into the udf's you mentioned and presume they can be downloaded from somewhere if not already part of the AutoIT download.

I don't fully understand your reply though and would be grateful if you could elaborate for a relative newbie?  Does the version of IE i run at the time of compiling the script determine the embedded solution?  My installed version of IE is latest v11 (Win7), so If I am correct in my previous question then if (as is likely) it were compiled with an older IE installed, that could explain things.  Perhaps all I need to do is recompile the script whilst I have the latest IE installed?

Certainly, when I view the site in my normal IE browser, the site displays correctly.

on my Win10 workstation, it has edge of course.  Any compatibility there?

best regards

Share this post


Link to post
Share on other sites

#4 ·  Posted


small minds discuss people average minds discuss events great minds discuss ideas.... and use AutoIt....

Share this post


Link to post
Share on other sites

#5 ·  Posted

Hi Chimp

Clicked on the first link, and can see it all looks very promising.  Along with your explanation, this certainly gives me a much better understanding.

Will include in my script and test.  

Kindest thanks for your help.

Share this post


Link to post
Share on other sites

#6 ·  Posted

Eg for IE11 installed (no UDF version):
 

#include <IE.au3>
#include <Process.au3>
Local $regValue = "0x2AF8"
; IE11 edge mode: 11001 (0x2AF9)
; IE11: 11000 (0x2AF8)
; IE10: 10001 (0x2711)
; IE10: 10000 (0x02710)
; IE 9: 9999 (0x270F)
; IE 9: 9000 (0x2328)
; IE 8: 8888 (0x22B8)
; IE 8: 8000 (0x1F40)
; IE 7: 7000 (0x1B58)

RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION", _ProcessGetName(@AutoItPID), "REG_DWORD", $regValue)
RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION", _ProcessGetName(@AutoItPID), "REG_DWORD", $regValue)
;~ RegWrite("HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION", @ScriptName, "REG_DWORD", $regValue)
;~ RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION",@ScriptName, "REG_DWORD", $regValue)

Global $mainwin = GUICreate("IE test", 968, 688)
Global $OBJECT = ObjCreate("Shell.Explorer.2")
Global $OBJECT_CTRL = GUICtrlCreateObj($OBJECT, 0, 0, 968, 688)

GUISetState()
_IENavigate($OBJECT, "http://www.whatsmyuseragent.com/")
;~ _IENavigate($object, "http://www.pinterest.com/")

While 1
    Sleep(10)
    If GUIGetMsg() = -3 Then ExitLoop
WEnd

 

1 person likes this

Regards,
 

Share this post


Link to post
Share on other sites

#7 ·  Posted

Thanks VIP & Chimp for your help

I manually edited the HKLM reg with valuedata 11001 to prove off the point.  Worked perfectly of course.

Will build something based on your suggestions into my next script release.

Thanks again for the education.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now