Jump to content

Recommended Posts

Hi. I can open the editor with out problems but I can not compile because it is placed on another partition diferent from C.

Can you provide an update of this bug?

Capture.JPG

Capture2.JPG

Edited by ademon
pic2

Share this post


Link to post
Share on other sites

... and why do I need to provide an update or do you consider this to be a bug?
Just adhere to the appropriate directory tree and things should work fine.

Jos

(PS: No need to PM me to get attention, I'll get to it when I get to it. ;) )

Share this post


Link to post
Share on other sites
11 minutes ago, Jos said:


Just adhere to the appropriate directory tree and things should work fine.

 

Thanks for answer me. I do not understand, do you mean the directory tree where I have placed the editor?

Capture3.JPG

Edited by ademon
tree

Share this post


Link to post
Share on other sites

The way SciTE is configured in au3.properties is that it requires AutoIt3.exe in the parent directory.. so ...\autoit\scite\...
If you want that differently you need  to adapt the au3.properties to reflect that.

... else use the installer and all will work. ;)

Jos

Share this post


Link to post
Share on other sites

I have edited the file but it does not work. I can not use the installer in this machine because I have no admin rights ...

Well thank you for your attention

Capture4.JPG

Share this post


Link to post
Share on other sites

I have solved it!

To edit, compile, etc I am using the "X:\Descargas\AutoIt\autoit-v3\install\SciTe\SciTE.exe" and NOT the X:\Descargas\AutoIt\SciTE4AutoIt3_Portable\SciTE.exe

Edited by ademon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jitb
      I have an eof problem in SciTE. I keep gitting this knitsu at the end of the open sesion.
      Please see below. The file should end at line 1220 but has invisable lines. What am I doing wrong?
    • By v120
      Original posted by CoePSX
       
       
       
       
      Drawing_Script.au3
    • By AutoitMike
      Scite 3.4.4
      Win 10
      I click "Help" or press F1, there is no response
      If I use the file explorer and double click Autoit.chm or Autoit3.chm help opens.
      There is no dialog to check or uncheck "Always ask before opening this file" when clicking on these files.
       
      If you are curious as to why I dont have the latest version, I am creating a back up laptop that has a VERY extensive automation application that I have written over the past 15 years.
       
      An extremely potent, powerful, needed function has been deleted in the upgrade of Autoit in recent years that I can not do without. If my main laptop dies, which it almost did, I am in a very bad position. So I bought the exact same laptop and I am "cofiguring" it to work exactly the same as my main laptop. However, this one has been "Upgraded" to Win 10 which I hope is not the problem. 
      Thanks for any help
    • By Beege
      If you have every taken the time to set up a nice dark theme for your scite editor, you probably noticed shortly after a small yet really annoying flaw. For what ever reason, scite is not set up to let you change the caret fore color and caret line color per language. This really sucks if say you want to edit a properties file or any of the many other languages that Scite currently is setup to support. Pretty much all the other languages are set as light theme so unless you change the theme for those file types, you end up with something like below where the line color and caret are still using the dark theme colors. Line 3 in the pic:
       

       
      To get around this I came up with the following that seems to work pretty well.  
       
      Add the following properties to SciteUser.properties file (Options -> Open User Options File). Update colors to your own needs. You can addionally add any other propertys that dont have a lexer language option in the same fashion.
      # The default values (light themes) will be used for any lexer other than au3 caret.default.fore=#000000 caret.default.line.back=#FFFED8 selection.default.fore=#006000 selection.default.back=#F0A0A8 caret.au3.fore=#FFFFFF caret.au3.line.back=#111111 selection.au3.fore=#C2FFAE selection.au3.back=#f9f9f9  
      Add the following function to PersonalTools.Lua file. As jos pointed out, the OnStartup covers the filetab switches as well as the startup so only need the one function:
      function PersonalTools:OnStartup() -- the "and" + "or" keywords are ternary operators here local sLex = self:IsLexer(SCLEX_AU3) and 'au3' or 'default' props['caret.line.back'] = props['caret.' .. sLex .. '.line.back'] props['caret.fore'] = props['caret.' .. sLex .. '.fore'] props['selection.fore'] = props['selection.' .. sLex .. '.fore'] props['selection.back'] = props['selection.' .. sLex .. '.back'] end
      Last restart SciTE and that should be it. Let me know if you have any issues. Thanks
       
    • By ozymandius257
      Is there a way to remove the numbers from the tabs in Scite?
      When you have multiple autoit programs open, the tabs are numbered, so you'll get something like 1 ProgramA.au3    2 Program2.au3   3 Program3.au3
      I am working on programs with numbers as the first character, so I get  1 3-DoThis.au3     2 4-DoAnother.au3   3 5-DoTheRest.au3  (not the real program names, obviously :))
      It would be nice if I could get rid of the tab number, and just have the program name on each tab.
       
       
×
×
  • Create New...