Jump to content

Sqlite 32bit not working

Go to solution Solved by Jos,

Recommended Posts

I'm using the following:
newly installed Beta
SQlite version 3380000 aka 3.38.0
I put sqlite3.dll and sqlite3_x64.dll in C:\Windows\System32 since many scripts depend on them.

I extended the output of _SQLite_Startup()

ConsoleWrite("@AutoItX64 " & @AutoItX64 & @CRLF)
ConsoleWrite("$sDll_Filename " & $sDll_Filename & @CRLF)
ConsoleWrite("_SQLite_LibVersion=" & _SQLite_LibVersion() & @CRLF)

Also using the script from https://www.autoitscript.com/autoit3/docs/libfunctions/_SQLite_Startup.htm for testing.


>Running:(\Program Files (x86)\AutoIt3\autoit3.exe "R:\Download\aasdf.au3"    
@AutoItX64 0
$sDll_Filename sqlite3.dll

>Running:(\Program Files (x86)\AutoIt3\autoit3_x64.exe "R:\Download\aasdf.au3"    
@AutoItX64 1
$sDll_Filename sqlite3_x64.dll

>Running:(\Program Files (x86)\AutoIt3\Beta\autoit3.exe "R:\Download\aasdf.au3"    
@AutoItX64 0
$sDll_Filename sqlite3.dll

>Running:(\Program Files (x86)\AutoIt3\Beta\autoit3_x64.exe "R:\Download\aasdf.au3"    
@AutoItX64 1
$sDll_Filename sqlite3_x64.dll

Why doesn't it work in 32bit, despite me having the 32bit sqlite.dll? Autoit urges running scripts in 32bit mode and Scite starts scripts just in 32bit mode without the flag?
With #AutoIt3Wrapper_UseX64=Y it just works, both normal Autoit and beta!

sqlite3.dll sqlite3_x64.dll

Link to comment
Share on other sites

  • Developers
7 minutes ago, diepfeile said:

Thanks it seems to be working now. Is that applicable to all 32bit dlls?

Yeap ...   there is enough info to find on this topic on the Internet. ;) 

7 minutes ago, diepfeile said:

How do I get Scite to start in 64bit by default without needing to flag every file with #AutoIt3Wrapper_UseX64=Y?

You can set the default in 2 ways which is used by AutoIt3Wrapper:

  1. During installation of AutoIt3 you have to option to default to x64 
  2. Set the default in AutoIt3Wrapper.ini:

Jos :) 

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
Live for the present,
Dream of the future,
Learn from the past.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...