Sign in to follow this  
Followers 0
dcop

Input Box Text Highlighted By Default?

3 posts in this topic

Why does the first input box have the text highlighted when the GUI intitially opens? I don't want any text highlighted unless manually done....Dennis

#include <GUIConstants.au3>
; == GUI generated with Koda ==
Opt("GUIOnEventMode", 1) ; Change to OnEvent mode
$Form1 = GUICreate("DLM's Real Time Stock Quoter", 403, 183, 336, 147)
;~ GUISetOnEvent($GUI_EVENT_CLOSE, "CLOSEClicked")
GUISetBkColor(0xC0DCC0)
GUICtrlCreateLabel("", 90, 16, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
GUICtrlCreateLabel("", 90, 56, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
GUICtrlCreateLabel("", 90, 96, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
GUICtrlCreateLabel("Refresh Rate: 1000 = 1 Second", 215, 140, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
$Input1 = GUICtrlCreateInput("ORCL", 8, 16, 57, 17, -1, $WS_EX_CLIENTEDGE)
$Input2 = GUICtrlCreateInput("FISV", 8, 56, 57, 17, -1, $WS_EX_CLIENTEDGE)
$Input3 = GUICtrlCreateInput("DLX", 8, 96, 57, 17, -1, $WS_EX_CLIENTEDGE)
$Input4 = GUICtrlCreateInput("3000", 160, 136, 49, 21, -1, $WS_EX_CLIENTEDGE)
GUISetState(@SW_SHOW)
While 1
Sleep(1000)
WEnd
Exit

Share this post


Link to post
Share on other sites



#include <GUIConstants.au3>
; == GUI generated with Koda ==
Opt("GUIOnEventMode", 1) ; Change to OnEvent mode
$Form1 = GUICreate("DLM's Real Time Stock Quoter", 403, 183, 336, 147)

GUISetOnEvent($GUI_EVENT_CLOSE, "CLOSEClicked")
GUISetBkColor(0xC0DCC0)
GUICtrlCreateLabel("", 90, 16, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
GUICtrlCreateLabel("", 90, 56, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
GUICtrlCreateLabel("", 90, 96, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
GUICtrlCreateLabel("Refresh Rate: 1000 = 1 Second", 215, 140, 300, 17)
GUICtrlSetBkColor(-1, 0xC0DCC0)
$Input1 = GUICtrlCreateInput("ORCL", 8, 16, 57, 17, -1, $WS_EX_CLIENTEDGE)
$Input2 = GUICtrlCreateInput("FISV", 8, 56, 57, 17, -1, $WS_EX_CLIENTEDGE)
$Input3 = GUICtrlCreateInput("DLX", 8, 96, 57, 17, -1, $WS_EX_CLIENTEDGE)
$Input4 = GUICtrlCreateInput("3000", 160, 136, 49, 21, -1, $WS_EX_CLIENTEDGE)
GUICtrlCreateButton("dummy button", 10, 120, 90, 20)
;~ GUICtrlSetState(-1,$GUI_DEFBUTTON)
GUICtrlSetState(-1, $GUI_FOCUS)
GUICtrlSetState(-1, $GUI_HIDE)
GUISetState(@SW_SHOW)
While 1
    Sleep(1000)
WEnd
Exit

Func CLOSEClicked()
    Exit
EndFunc   ;==>CLOSEClicked


SciTE for AutoItDirections for Submitting Standard UDFs

 

Don't argue with an idiot; people watching may not be able to tell the difference.

 

Share this post


Link to post
Share on other sites

Man, I was never even was close! Thank you so much gafrost, Works just like I wanted!!

GUICtrlCreateButton("dummy button", 10, 120, 90, 20)

;~ GUICtrlSetState(-1,$GUI_DEFBUTTON)

GUICtrlSetState(-1, $GUI_FOCUS)

GUICtrlSetState(-1, $GUI_HIDE)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0