Sign in to follow this  
Followers 0
Vivvic

Script not functioning correctly

5 posts in this topic

Here is my script, it makes no errors but it dosn't click (at all) it uses a UDF that can be found here

http://www.autoitscript.com/forum/index.ph...=mouseclickplus

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;;;;;;;;;;;;;;;;              Emit               ;;;;;;;;;;;;;;;;;;;;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
#include <c:/program files/autoit3/beta/include/IE.au3>
#include <c:/program files/autoit3/beta/include/Mouseclickplus.au3>
#include <c:/program files/autoit3/beta/include/GUIConstants.au3>
Opt("MouseCoordMode", 0)  
;+++++++++++++++++++++++++++++++++++++++++++++
HotKeySet("{PAUSE}", "_Pause")
HotKeySet("{ESC}", "_Exit")
HotKeySet("{END}", "_ExitLoop")
;+++++++++++++++++++++++++++++++++++++++++++++
$gui = GUICreate("Gaia Online Slots Bot - by Emit", 674, 655, 0, 0);375, 170, -1, -1
;+++++++++++++++++++++++++++++++++++++++++++++
$Embed = ObjCreate ("Shell.Explorer.2")
$gui = $Embed
;+++++++++++++++++++++++++++++++++++++++++++++
$feedbackmenu = GUICtrlCreateMenu("Feedback")
$seperator = GUICtrlCreateMenuitem("", $feedbackmenu)
$emiT = GUICtrlCreateMenuitem("Emit", $feedbackmenu)
$seperator1 = GUICtrlCreateMenuitem("", $feedbackmenu)
;+++++++++++++++++++++++++++++++++++++++++++++
$Gaia_Slot = "http://gaiaonline.com/games/launch.php?g=slots"
$Gaia_Slot_bot = GUICtrlCreateButton("Gaia Slots Bot", 519, 600, 150, 30)
$Hotkeys = GUICtrlCreateLabel("Toggle pause - PAUSE" & @CRLF & "Quit bot - END" & @CRLF & "Exit - ESC", 5, 592)
;+++++++++++++++++++++++++++++++++++++++++++++
GUICtrlCreateObj ($Embed, 5, 5, 664, 584)
_IENavigate ($Embed, $Gaia_Slot)
$Embed.document.body.scroll = "no"
Global $Paused
;+++++++++++++++++++++++++++++++++++++++++++++
GUISetState()
While 1
    $msg = GUIGetMsg()
    Select
;+++++++++++++++++++++++++++++++++++++++++++++
        Case $msg = $emiT
            MsgBox(0, "Feedback", "Feel free to" & @CRLF & "email feedback to" & @CRLF & "Emit@30gigs.com")
;+++++++++++++++++++++++++++++++++++++++++++++
        Case $msg = $Gaia_Slot_bot
            $Loop = 1
            Do
                _MouseClickPlus ( "Gaia Online Slots Bot - by Emit", "left", 337, 511, 1);Replaced "Gaia Online Slots Bot - by Emit" with $Embed, stil fails to work.
                Sleep(100)
                _MouseClickPlus ( "Gaia Online Slots Bot - by Emit", "left", 337, 511, 1);Replaced "Gaia Online Slots Bot - by Emit" with $Embed, stil fails to work.
                Sleep(100)
                _MouseClickPlus ( "Gaia Online Slots Bot - by Emit", "left", 337, 511, 1);Replaced "Gaia Online Slots Bot - by Emit" with $Embed, stil fails to work.
                Sleep(100)
                _MouseClickPlus ( "Gaia Online Slots Bot - by Emit", "left", 600, 511, 1);Replaced "Gaia Online Slots Bot - by Emit" with $Embed, stil fails to work.
                Sleep(8000)
            Until $Loop = 0
;+++++++++++++++++++++++++++++++++++++++++++++
    EndSelect
WEnd
;+++++++++++++++++++++++++++++++++++++++++++++
Func _ExitLoop()
    Global $Loop = 0
EndFunc   ;==>_ExitLoop
;+++++++++++++++++++++++++++++++++++++++++++++
Func _Pause()
    $Paused = Not $Paused
    While $Paused
        Sleep(100)
    WEnd
EndFunc   ;==>_Pause
;+++++++++++++++++++++++++++++++++++++++++++++
Func _Exit()
    Exit 0
EndFunc   ;==>_Exit
;+++++++++++++++++++++++++++++++++++++++++++++

[quote name='DaleHohm']You have a strange habit of posting error messages that don't match your code.[/quote][quote name='SmOke_N']Forget the learning... straight to the scripting :lol: (laugh.gif)[/quote]

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

*bump*

Anyone? Thread has already moved to third page without one post.

EDIT: Just occured to me you may not have a Gaia Online account to test with heres one

Username:autoitforum

Password:autoit

Edited by Vivvic

[quote name='DaleHohm']You have a strange habit of posting error messages that don't match your code.[/quote][quote name='SmOke_N']Forget the learning... straight to the scripting :lol: (laugh.gif)[/quote]

Share this post


Link to post
Share on other sites

*bump* thought I would try one last time to get an answer to this problem, for a while at least, help appreciated.


[quote name='DaleHohm']You have a strange habit of posting error messages that don't match your code.[/quote][quote name='SmOke_N']Forget the learning... straight to the scripting :lol: (laugh.gif)[/quote]

Share this post


Link to post
Share on other sites

Hi,

I cannot test it at work. But did you try just to open a browser go to the site login (all manual) and just send one cammand via mouseClickPlus to the site to check whether it works at all?

So long,

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

Yes, just did that, also did not work, thinking Im not using the UDF correctly?


[quote name='DaleHohm']You have a strange habit of posting error messages that don't match your code.[/quote][quote name='SmOke_N']Forget the learning... straight to the scripting :lol: (laugh.gif)[/quote]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0