Sign in to follow this  
Followers 0
Pangu

installation automatic with reboot

59 posts in this topic

#1 ·  Posted (edited)

Hello :)

I'm sorry because i don't speak english very well :">

i write a scripts for an installation automatic, i would like reboot my pc and run a scripts after reboot. I understood that it was necessary to use the register but i don't understand :P

could you explain me :nuke:

For an explanation in English, go to my last post

Edited by Pangu

"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

; Write autologin Entries if you have to log in manually -- donn't forget to delete these when finished !!!
RegWrite("HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon", "AutoAdminLogon", "REG_SZ", "1")
RegWrite("HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon", "DefaultUserName", "REG_SZ", "Administrator")
RegWrite("HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon", "DefaultPassword", "REG_SZ", "PutYourPassHere" )
RegWrite("HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon", "DefaultDomainName", "REG_SZ", @ComputerName )
; Run the program
RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run", "AutoInstall" , "PutYourExeHere" )
; Reboot
Shutdown (6)

Edited by dabus

Share this post


Link to post
Share on other sites

thank you :)

what is this "AutoInstall" because i have an error message :P in this line :

RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run", "AutoInstall" , "PutYourExeHere" )

"error : error parsing function call" :nuke:


"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

sorry :P i'm stupid i forgot a special caractere :nuke:


"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

it does'nt function :P

this my scripts, you see error :nuke:

i have'nt login and password, i connect directly

;Installation de Zone alarm

run("Zone Alarm.exe")

WinWaitActive("Installation de ZoneAlarm")
Send("!S")

WinWaitActive("Enregistrement de ZoneAlarm")
Send("{TAB 2}" & "{SPACE}" & "{TAB}" & "{SPACE}" & "!S")

WinWaitActive("Installation de ZoneAlarm")
Send("{TAB 3}" & "{SPACE}" & "!S") 

WinWaitActive("Enregistrement de ZoneAlarm")
Send("!S")

WinWaitActive("Installation de ZoneAlarm")
Send("{ENTER}")

WinWaitActive("Assistant de licence")
MouseClick("left",577,255)
Send("{TAB}" & "{ENTER}")

WinWaitActive("Assistant de licence")
Send("{TAB 2}" & "{ENTER}")

WinWaitActive("Assistant de configuration")
Send("{TAB 2}" & "{ENTER}" & "{TAB 2}" & "{ENTER}")

;Write autoling Entries if you have to log in manually
RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon","REG_SZ","1")
RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine","REG_SZ", @ComputerName )
;run the program
RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","AutoInstall","Zone Alarm.au3")
;Reboot
Shutdown(6)

WinWaitActive("ZoneAlarm - Mise en route") <--- here, zone alarm open windows alone
Send("{ENTER}")

WinWaitActive("ZoneAlarm")
MouseClick("left",701,63)
MouseClick("left",770,10)

WinWaitActive("Conseils sur ZoneAlarm")
Send("{SPACE}" & "{TAB}" & "{ENTER}"

Exit

"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

it does'nt function :P

this my scripts, you see error :nuke:

i have'nt login and password, i connect directly

;Installation de Zone alarm

run("Zone Alarm.exe")

WinWaitActive("Installation de ZoneAlarm")
Send("!S")

WinWaitActive("Enregistrement de ZoneAlarm")
Send("{TAB 2}" & "{SPACE}" & "{TAB}" & "{SPACE}" & "!S")

WinWaitActive("Installation de ZoneAlarm")
Send("{TAB 3}" & "{SPACE}" & "!S") 

WinWaitActive("Enregistrement de ZoneAlarm")
Send("!S")

WinWaitActive("Installation de ZoneAlarm")
Send("{ENTER}")

WinWaitActive("Assistant de licence")
MouseClick("left",577,255)
Send("{TAB}" & "{ENTER}")

WinWaitActive("Assistant de licence")
Send("{TAB 2}" & "{ENTER}")

WinWaitActive("Assistant de configuration")
Send("{TAB 2}" & "{ENTER}" & "{TAB 2}" & "{ENTER}")

;Write autoling Entries if you have to log in manually
RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon","REG_SZ","1")
RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine","REG_SZ", @ComputerName )
;run the program
RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","AutoInstall","Zone Alarm.au3")
;Reboot
Shutdown(6)

WinWaitActive("ZoneAlarm - Mise en route") <--- here, zone alarm open windows alone
Send("{ENTER}")

WinWaitActive("ZoneAlarm")
MouseClick("left",701,63)
MouseClick("left",770,10)

WinWaitActive("Conseils sur ZoneAlarm")
Send("{SPACE}" & "{TAB}" & "{ENTER}"

Exit
RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","AutoInstall","REG_SZ","Zone Alarm.exe") ; Il manquait le REG_SZ et il faut exécuter le fichier compiler en .EXE.

De plus, lors de l'envoi des commandes de type Send, passe les commandes en minuscules car pas mal de logiciels ne vont pas bien réagir lors de l'envoi de majuscules

Bye

Eric

Edited by ECHAIGNE

Share this post


Link to post
Share on other sites

RegWrite('HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run','YourAPP', 'REG_SZ', 'C:\PATH\TO\YOUR\APP.exe')


[quote name='AceLoc']I gots new sunglasses there cool.[/quote]

Share this post


Link to post
Share on other sites

thank you, i succeeded reboot and run scripts but script starts again at the beginning and not at the end :P

you have an idea :nuke:


"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

thank you, i succeeded reboot and run scripts but script starts again at the beginning and not at the end :P

you have an idea :nuke:

;Installation de Zone alarm

; Si la clé n'est pas renseignée, il s'agit du 1er lancement

If Not RegRead("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run", "AutoInstall") Then

Run("Zone Alarm.exe")

WinWaitActive("Installation de ZoneAlarm")

Send("!s")

WinWaitActive("Enregistrement de ZoneAlarm")

Send("{TAB 2}" & "{SPACE}" & "{TAB}" & "{SPACE}" & "!s")

WinWaitActive("Installation de ZoneAlarm")

Send("{TAB 3}" & "{SPACE}" & "!s")

WinWaitActive("Enregistrement de ZoneAlarm")

Send("!s")

WinWaitActive("Installation de ZoneAlarm")

Send("{ENTER}")

WinWaitActive("Assistant de licence")

MouseClick("left", 577, 255)

Send("{TAB}" & "{ENTER}")

WinWaitActive("Assistant de licence")

Send("{TAB 2}" & "{ENTER}")

WinWaitActive("Assistant de configuration")

Send("{TAB 2}" & "{ENTER}" & "{TAB 2}" & "{ENTER}")

;Write autoling Entries if you have to log in manually

RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon", "AutoAdminlogon", "REG_SZ", "1")

RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon", "DefaultDomaine", "REG_SZ", @ComputerName)

;run the program

RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run", "AutoInstall", "REG_SZ", @ScriptFullPath)

;Reboot

Shutdown(6)

Else

; Après reboot

WinWaitActive("ZoneAlarm - Mise en route") < - - - here, zone alarm open windows alone

Send("{ENTER}")

WinWaitActive("ZoneAlarm")

MouseClick("left", 701, 63)

MouseClick("left", 770, 10)

WinWaitActive("Conseils sur ZoneAlarm")

Send("{SPACE}" & "{TAB}" & "{ENTER}"

; Suppression de la clé de lancement

RegDelete("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","AutoInstall")

; Suppression de l'autolog

RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon", "AutoAdminlogon")

EndIf

Exit

Share this post


Link to post
Share on other sites

i don't understood, script always starts again at the beginning and not at the end

you see an errors because i use "if....then""else...endif" :) :

;Installation de Zone alarm

;Condition : si la clé n'est pas renseigné, il s'agit du début de l'installation
If Not RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm")Then

        Run("zone alarm.exe")

        WinWaitActive("Installation de ZoneAlarm")
        Send("!s")

        WinWaitActive("Enregistrement de ZoneAlarm")
        Send("{tab 2}" & "{space}" & "{tab}" & "{space}" & "!s")

        WinWaitActive("Installation de ZoneAlarm")
        Send("{tab 3}" & "{space}" & "!s") 

        WinWaitActive("Enregistrement de ZoneAlarm")
        Send("!s")

        WinWaitActive("Installation de ZoneAlarm")
        Send("{enter}")

        WinWaitActive("Assistant de licence")
        MouseClick("left",577,255)
        Send("{tab}" & "{enter}")

        WinWaitActive("Assistant de licence")
        Send("{tab 2}" & "{enter}")

        WinWaitActive("Assistant de configuration")
        Send("{tab 2}" & "{enter}" & "{tab 2}" & "{enter}")

        ;Intégration des clés de lancement
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon","REG_SZ","1")
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine","REG_SZ", @ComputerName )
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm","REG_SZ","C:\Documents and Settings\Admin\Bureau\zone alarm.exe")

        ;Reboot
        Shutdown(6)

Else

;Apres reboot
WinWaitActive("ZoneAlarm - Mise en route")
Send("{enter}")

WinWaitActive("ZoneAlarm")
MouseClick("left",701,63)
MouseClick("left",770,10)

WinWaitActive("Conseils sur ZoneAlarm")
Send("{space}" & "{tab}" & "{enter}"

;Suppression des clés de lancement
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm")

EndIf

Exit

"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

i don't understood, script always starts again at the beginning and not at the end

you see an errors because i use "if....then""else...endif" :) :

;Installation de Zone alarm

;Condition : si la clé n'est pas renseigné, il s'agit du début de l'installation
If Not RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm")Then

        Run("zone alarm.exe")

        WinWaitActive("Installation de ZoneAlarm")
        Send("!s")

        WinWaitActive("Enregistrement de ZoneAlarm")
        Send("{tab 2}" & "{space}" & "{tab}" & "{space}" & "!s")

        WinWaitActive("Installation de ZoneAlarm")
        Send("{tab 3}" & "{space}" & "!s") 

        WinWaitActive("Enregistrement de ZoneAlarm")
        Send("!s")

        WinWaitActive("Installation de ZoneAlarm")
        Send("{enter}")

        WinWaitActive("Assistant de licence")
        MouseClick("left",577,255)
        Send("{tab}" & "{enter}")

        WinWaitActive("Assistant de licence")
        Send("{tab 2}" & "{enter}")

        WinWaitActive("Assistant de configuration")
        Send("{tab 2}" & "{enter}" & "{tab 2}" & "{enter}")

        ;Intégration des clés de lancement
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon","REG_SZ","1")
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine","REG_SZ", @ComputerName )
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm","REG_SZ","C:\Documents and Settings\Admin\Bureau\zone alarm.exe")

        ;Reboot
        Shutdown(6)

Else

;Apres reboot
WinWaitActive("ZoneAlarm - Mise en route")
Send("{enter}")

WinWaitActive("ZoneAlarm")
MouseClick("left",701,63)
MouseClick("left",770,10)

WinWaitActive("Conseils sur ZoneAlarm")
Send("{space}" & "{tab}" & "{enter}"

;Suppression des clés de lancement
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm")

EndIf

Exit
J'ai retesté la condition sur mon poste et elle fonctionne. Je ne comprends pas ce qui se passe

(par contre, évite de placer des chemin en dur dans le code car cela limite les endroits ou sera le script ==> remplace "C:\Documents and Settings\Admin\Bureau\zone alarm.exe" par @ScriptFullPath)

Share this post


Link to post
Share on other sites

ok merci pour le chemin :D

j'ai une question, j'ai en fait un fichier Zone Alarm.au3 et zone alarm.exe, je compile le tout avec Compile Script to .exe de autoit et ca me donne un fichier Zone Alarm Setup.exe et je pensais que ca combinait le script et le log mais apparement non car il faut quand meme l'exe du log :P c'est normal ?

sinon je me trompe peut etre de nom dans la base de registre en mettant zone alarm :)


"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

ok merci pour le chemin :D

j'ai une question, j'ai en fait un fichier Zone Alarm.au3 et zone alarm.exe, je compile le tout avec Compile Script to .exe de autoit et ca me donne un fichier Zone Alarm Setup.exe et je pensais que ca combinait le script et le log mais apparement non car il faut quand meme l'exe du log :P c'est normal ?

sinon je me trompe peut etre de nom dans la base de registre en mettant zone alarm :)

Ou là, un truc a du m'échapper. Tu parles de quel log ?

Mis à part le log, dans la pratique, il te faut :

- L'exécutable qui va lancer l'installation de ZoneAlarm (source .au3 compilé) que nous appellerons InstZoneAlarm.au3 qui donnera, une fois compilé, InsZoneAlarm.exe

- Le programme d'installation de ZoneAlarm (celui que tu lancerais si tu installais à la main) que nous appellerons ZoneAlarm.exe

Il ne faut pas que les 2 programme porte le même nom

Si tu veux un seul EXE final (afin qu'il soit portable sur X postex, par exemple), il faut que que tu intégre le source de ZoneAlam.exe dans l'éxécutable final par la commande, dans le script InstZoneAlarm.au3 :

FileInstall(".\ZoneAlarm.exe", @TempDir & "\ZoneAlarm.exe", 0)

et tu lancera cet exécutable par la commande Run(@TempDir & "\ZoneAlarm.exe") (au niveau de la ligne après le if not regread)

Dans la clé RUN de la base de registre, en utilisant la variable @ScriptFullPath, il te placera le lancement de InstZoneAlarm.exe et tous devrait bien se passer.

Share this post


Link to post
Share on other sites

ok donc c'est bon, je pensais que ca le faisait directement d'intégrer l'exe de log.

sinon je teste le script sur vmware (pc virtuel) est ce que ca peut etre la raison que ca fonctionne pas :P

j'ai remplacé le chemin d'acces à l'exe par @ScriptFullPath et du coup maintenant j'ai un message d'erreur :

Posted Image

mais le script ne tient pas compte de la condition quand il se relance car il recommence l'install :) , j'ai pourtant bien fait comme t'as dit :D


"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

#15 ·  Posted (edited)

j'ai une question que je pense que ca vient des modif pour le registre :

on a donc le script compilé : InsZoneAlarm.exe

et l'executable de zone alarm : ZoneAlarm.exe

alors dans les clés de registre on mets ZoneAlarm.exe ou InsZoneAlarm.exe :)

If Not RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","ZoneAlarm")Then

;Intégration des clés de lancement
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon","REG_SZ","1")
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine","REG_SZ", @ComputerName )
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm","REG_SZ","C:\Documents and Settings\Admin\Bureau\ZoneAlarm.exe")


;Suppression des clés de lancement
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","ZoneAlarm")
Edited by Pangu

"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

j'ai une question que je pense que ca vient des modif pour le registre :

on a donc le script compilé : InsZoneAlarm.exe

et l'executable de zone alarm : ZoneAlarm.exe

alors dans les clés de registre on mets ZoneAlarm.exe ou InsZoneAlarm.exe :)

If Not RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","ZoneAlarm")Then

;Intégration des clés de lancement
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon","REG_SZ","1")
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine","REG_SZ", @ComputerName )
        RegWrite("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","zone alarm","REG_SZ","C:\Documents and Settings\Admin\Bureau\ZoneAlarm.exe")
;Suppression des clés de lancement
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminlogon")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","DefaultDomaine")
RegDelete("HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run","ZoneAlarm")
Surtout pas. La clé RUN doit exécuter le script compilé càd InstZoneAlarm.exe, qui correspond à la variable @ScriptFullPath. Le fichier ZoneAlarm.exe doit être lancé par le RUN(... situé à la ligne après le If Not Regread...

Share this post


Link to post
Share on other sites

ok donc c'est bon, je pensais que ca le faisait directement d'intégrer l'exe de log.

sinon je teste le script sur vmware (pc virtuel) est ce que ca peut etre la raison que ca fonctionne pas :P

j'ai remplacé le chemin d'acces à l'exe par @ScriptFullPath et du coup maintenant j'ai un message d'erreur :

Posted Image

mais le script ne tient pas compte de la condition quand il se relance car il recommence l'install :) , j'ai pourtant bien fait comme t'as dit :D

Bizarre, on dirait qu'il lance l'installation de ZoneAlarm au lieu du script compilé. Ils n'ont pas le même nom ?

Sinon, pas de PB pour exécuter sous WmWare

Share this post


Link to post
Share on other sites

sorry but we are french, it's more simple :party:

c'était bien le probleme, j'avais mis le nom du log et pas du script de plus j'avais mis des espaces et le registre aimepas les espaces :D

par contre là j'ai un truc zarb, mon script est bon, les commandes correspondent bien à ce qu'il faut faire mais quand la fenetre de zone alarm s'ouvre la souris clic bien sur le bouton voulu mais zone alarm n'en tient pas compte et du coup il ne passe pas à la fenetre suivante :P , j'ai essayé en mettant plusieurs clic, en faisant "enter", en clic d'abord sur la fenetre pour etre sur qu'elle soit bien active puis en cliquant sur le bouton mais rien ne marche pourtant quand je le fais moi meme ca fonctionne, j'ai cherché une commande avec la souris pour forcer la validation mais j'ai rien trouvé :) , t'aurait pas une idée :D


"Donne un poisson à un homme, il mangera un jour. Apprends lui à pècher, il mangera toujours."-Proverbe chinois-

Share this post


Link to post
Share on other sites

#20 ·  Posted (edited)

sorry but we are french, it's more simple :party:

c'était bien le probleme, j'avais mis le nom du log et pas du script de plus j'avais mis des espaces et le registre aimepas les espaces :D

par contre là j'ai un truc zarb, mon script est bon, les commandes correspondent bien à ce qu'il faut faire mais quand la fenetre de zone alarm s'ouvre la souris clic bien sur le bouton voulu mais zone alarm n'en tient pas compte et du coup il ne passe pas à la fenetre suivante :P , j'ai essayé en mettant plusieurs clic, en faisant "enter", en clic d'abord sur la fenetre pour etre sur qu'elle soit bien active puis en cliquant sur le bouton mais rien ne marche pourtant quand je le fais moi meme ca fonctionne, j'ai cherché une commande avec la souris pour forcer la validation mais j'ai rien trouvé :) , t'aurait pas une idée :D

Then talk to eachother in a Personal Message, it's "that" simple.

P.S.

The guy that told ya'll this was an english speaking forum, is also French.

Edited by SmOke_N

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0