Sign in to follow this  
Followers 0
Ármányos Kő

Can look into OBJECT value, but why not changing?

3 posts in this topic

Hi,

I have to change fonts in an Illustrator object.

With the code below I can see nicely each caharacters's TextFont. Name or TextFont.Family

But when I try to give new value to it, it fails with this error message>

The requested action with this object has failed.:

.Name = "ArialMT"

.Name = "ArialMT"^ ERROR

Why?

I thought this will be easy stuff by looking at Help examples. I have collected the TextFont. Name values of all fonts on my computer and ArialMT is one of them.

What I am doing wrong?

Thanks for any help, this makes me struggling for days now...

Func TextFontlist()
    $oIll = ObjGet("","Illustrator.Application") 
    $fonts = $oIll.Documents(1).Stories.Count
    For $i = 1 to $fonts
        $chars = $oIll.Documents(1).Stories($i).Characters.Count
        For $z = 1 To $chars
            $info = $oIll.Documents(1).Stories($i).Characters($z).CharacterAttributes.Textfont.Name
            $stuff = $oIll.Documents(1).Stories($i).Characters($z).Contents
            Tooltip($oIll.Documents(1).Stories.Count&@LF&$info&@LF&@LF&$stuff&@LF&"      i, z>"&$i&"   "&$z)
            Sleep(250)
            If $info = "Helvetica" Then
                With $oIll.Documents(1).Stories($i).Characters($z).CharacterAttributes.Textfont
                    .Name = "ArialMT"
                EndWith
            Endif
        Next
    Next
    ToolTip("")
EndFunc

Share this post


Link to post
Share on other sites



A quick search found an Adobe Illustrator Scripting Guide here: http://partners.adobe.com/public/developer...iptingGuide.pdf

This guide states on page 455 that the TextFont property is Read-Only.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Thanks!

This is so amezingly stupid of me!

(Also, Adobe changed the guide significantly for the CS2 version which I have. They just do not list the R/O column anymore!)

Ok, I will have a look.

Now comes again some hard reading on the actual problem.

Be back

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0