Sign in to follow this  
Followers 0
Psibernetic

images strored in .exe

7 posts in this topic

I noticed programs such as installers have images in the program, but do no require those image files to be with the .exe ....is there anyway I can do this in autoit?


[sup]Psibernetic[/sup]My Creations:X-HideSecuracy

Share this post


Link to post
Share on other sites



hmm thaz actually probally a good method...fileinstall the files to the @TempDir.... its not perfect, but it provides the illusion...thank you Bert


[sup]Psibernetic[/sup]My Creations:X-HideSecuracy

Share this post


Link to post
Share on other sites

I know you found your solution but I wanted to add that I have done the method above of file install into a temp dir and deleting it later and it works very well, much better then I thought it would initially. Depending on your situation a good place to install it is into the users application directory since the user will almost always(if not always) have rights to that part of the drive.

Other then that there was a post I read from Zedna about adding resources to a complied script; its complicated and I admit I don't understand half of it so it may not be applicable to you.

http://www.autoitscript.com/forum/index.ph...mp;#entry169711


While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites

Or, perhaps add a IE object and navigate it to the site, this will require to "crop out" the picture by playing around with the X, Y, Left, Right parameters. All you need to do is host a picture on a site, than you need to add:

$oIE = ObjCreate("Shell.Explorer.2")
$Active = GUICtrlCreateObj($oIE, $width,$height,$left,$right)
$oIE.navigate ("your picture URL")

Kurt


Awaiting Diablo III..

Share this post


Link to post
Share on other sites

thnx guys, Someone... I will have to check that out when I get home from school...and Kurt, good idea..only limitation is if user doesn't have internet access, I experienced this issue yesterday with an application...it was useless because some file failed


[sup]Psibernetic[/sup]My Creations:X-HideSecuracy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0