Sign in to follow this  
Followers 0
glitchz

Aimbot

13 posts in this topic

#1 ·  Posted (edited)

This is my second aimbot for the classic shooting gallary game. I made this using image search but I can't seem to get it to work.

Ps its much more simpler then the pixelsearch and should be more accurate if I can get it to work.

ANY HELP IS WELCOME :) :

here you go

#cs ----------------------------------------------------------------------------

 AutoIt Version: 3.3.1.1 (beta)
 Author:         glitchz

 Script Function:
    Template AutoIt script.

#ce ----------------------------------------------------------------------------

; Script Start - Add your code below here

;First u must include this udf file.
#include <ImageSearch.au3> 

WinWaitActive("Shooting Gallery - Points2Shop - Earn Points for Free Rewards - Mozilla Firefox")

Global $Aimbot = 0

Opt("MouseCoordMode", 0)
Opt("PixelCoordMode", 0)
Opt("MouseClickDelay", 0)
Opt("MouseClickDownDelay", 0)

Hotkeyset ("{INS}", "AimShootAimbot")

$x1 = 0
$y1 = 0

Func AimShootAimbot()
$Aimbot = 1 
While 1 
$Aimbot = 1 = _ImageSearch("aim2.bmp", 1, $x1, $y1, 0)

If $Aimbot = 1 = _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 2 Then
    MouseMove($x1,$y1,3)
    MouseClick($x1,$y1,3)
    $Aimbot = 1
    If $Aimbot = 1 then
       $coord = PixelSearch(789, 601, 794, 615, $searchcolor15,25);15)
            If IsArray($coord) = 1 Then
                MouseClick('left', $coord[0], $coord[1], 1, 0)
                sleep(100)
            EndIf
        EndIf   
Tooltip("AimBot is Auto-Shooting", 0, 0)
Sleep(10000)
Wend
Endfunc

heres the pic

Posted Image

Edited by glitchz

Share this post


Link to post
Share on other sites



bump

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

bump

Watch the quick bumping, or your topics will get locked quick... :)

You provided absolutely nothing to work with. What is the error you are receiving, if not an error, what is the issue? etc...etc...etc...etc...

People often put as much effort into replying, as the poster does at asking... :)

Edit: For one, you are aware that you have a 10 second sleep in there, right?

Edited by BinaryBrother

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Watch the quick bumping, or your topics will get locked quick... :)

You provided absolutely nothing to work with. What is the error you are receiving, if not an error, what is the issue? etc...etc...etc...etc...

People often put as much effort into replying, as the poster does at asking... :)

Edit: For one, you are aware that you have a 10 second sleep in there, right?

Yes im aware of that, it is to create a tooltip in the top of the sreen to show the auto aim is functioning.

And sorry about bumping/not providing enough information, been trying to figure out this thing since yesterday and i'm really frustrated.

edit: also here was my previous post http://www.autoitscript.com/forum/index.php?showtopic=97923

my errors are that it simply cannot find the image that i'm looking for at all. With the code I povide I assume it should search for the image which is a target for a game.

Edited by glitchz

Share this post


Link to post
Share on other sites

bump

Share this post


Link to post
Share on other sites

If $Aimbot = 1 = _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 2 Then

What is that?

Also, why did you create another topic? And 24 hours is the usual time to wait before bumping.

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Sorry I was trying to create the verable aimbot to search for my image then click the center but I really new to imagesearch so its kind of confusing.

Posted Image

I cleaned up the script a little but still won't work

#include <ImageSearch.au3> 

WinWaitActive("Shooting Gallery - Points2Shop - Earn Points for Free Rewards - Mozilla Firefox")

Global $Aimbot = 0
Global $searchcolor = 0xFF7F7F

Opt("MouseCoordMode", 0)
Opt("PixelCoordMode", 0)
Opt("MouseClickDelay", 0)
Opt("MouseClickDownDelay", 0)

Hotkeyset ("{INS}", "AimShootAimbot")

$x1 = 0
$y1 = 0

Func AimShootAimbot()
$Aimbot = 1 
If $Aimbot = 1 = _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 2 Then
    MouseMove($x1,$y1,3)
    MouseClick($x1,$y1,3)
    $Aimbot = 1
    If $Aimbot = 1 then
       $coord = PixelSearch(789, 601, 794, 615, $searchcolor,25);15)
            If IsArray($coord) = 1 Then
                MouseClick('left', $coord[0], $coord[1], 1, 0)
                sleep(100)
            EndIf
        EndIf   
Tooltip("AimBot is Auto-Shooting", 0, 0)
Sleep(10000)
EndIf
EndFunc

Also here is my autohotkey script which doesn't work either

CoordMode Pixel

F1::
Loop
{
    ImageSearch, FoundX, FoundY, 245, 174, 646, 311, *200 C:\aim2.bmp
    if ErrorLevel = 0
   send {Click}
    Sleep, 100
        continue
    if Else
   
   Space::Suspend
}
Edited by glitchz

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

If $Aimbot = 1 = _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 2 Then

How is that going to evaluate true? Also, could you post the code for _imagesearch?

Edited by qazwsx

Share this post


Link to post
Share on other sites

How is that going to evaluate true? Also, could you post the code for _imagesearch?

Well looking at the demo and the functions I downloaded related to this topic http://www.autoitscript.com/forum/index.php?showtopic=65748

I assumed that if image search finds the bmp image it will find a certain pixel in it then click it.

Im really new like I said so go easy on me :)

Share this post


Link to post
Share on other sites

http://www.youtube.com/watch?v=_u6TVMqT3yA

free Aimbot there

Share this post


Link to post
Share on other sites

; Return Value(s): On Success - Returns 1

; On Failure - Returns 0

Change the if statement to:

If _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 1 Then

Also, comment your code. What is the purpose of the variable $aimbot?

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

http://www.youtube.com/watch?v=_u6TVMqT3yA

free Aimbot there

That aimbot is very buggy and gets detected fast and won't even hit 4's.

Change the if statement to:

If _ImageSearch("C:\aim2.bmp", 1, $x1, $y1, 0) = 1 Then

Also, comment your code. What is the purpose of the variable $aimbot?

Thx for the reply here is what I have so far.

Still doesn't even attempt to look for the picture or even click a red pixel

#cs ----------------------------------------------------------------------------

 AutoIt Version: 3.3.1.1 (beta)
 Author:         glitchz

 Script Function:
    Template AutoIt script.

#ce ----------------------------------------------------------------------------

; Script Start - Add your code below here

#include <ImageSearch.au3> 

WinWaitActive("Shooting Gallery - Points2Shop - Earn Points for Free Rewards - Mozilla Firefox")

Global $Aimbot = 0;Search for image.
Global $seachcolor = 0xF00000; color of the pixel in the image.

Opt("MouseCoordMode", 0)
Opt("PixelCoordMode", 0)
Opt("MouseClickDelay", 0)
Opt("MouseClickDownDelay", 0)

Hotkeyset ("{INS}", "AimShootAimbot")

$x1 = 0
$y1 = 0

Func AimShootAimbot()
$Aimbot = 0
If _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 1 Then
    MouseMove($x1,$y1,3)
    MouseClick($x1,$y1,3);If image is found left click.
    $Aimbot = 0
    If $Aimbot = 0 then
       $coord = PixelSearch(789, 601, 794, 615, $searchcolor,25))
            If IsArray($coord) = 1 Then
                MouseClick('left', $coord[0], $coord[1], 1, 0);If image color is found click.
                sleep(100)
            EndIf
        EndIf   
Tooltip("AimBot is Auto-Shooting", 0, 0);Activate tooltip once aimbot is running.
Sleep(10000)
EndIf
Endfunc
Edited by glitchz

Share this post


Link to post
Share on other sites

That aimbot is very buggy and gets detected fast and won't even hit 4's.

Thx for the reply here is what I have so far.

Still doesn't even attempt to look for the picture or even click a red pixel

#cs ----------------------------------------------------------------------------

 AutoIt Version: 3.3.1.1 (beta)
 Author:         glitchz

 Script Function:
    Template AutoIt script.

#ce ----------------------------------------------------------------------------

; Script Start - Add your code below here

#include <ImageSearch.au3> 

WinWaitActive("Shooting Gallery - Points2Shop - Earn Points for Free Rewards - Mozilla Firefox")

Global $Aimbot = 0;Search for image.
Global $seachcolor = 0xF00000; color of the pixel in the image.

Opt("MouseCoordMode", 0)
Opt("PixelCoordMode", 0)
Opt("MouseClickDelay", 0)
Opt("MouseClickDownDelay", 0)

Hotkeyset ("{INS}", "AimShootAimbot")

$x1 = 0
$y1 = 0

Func AimShootAimbot()
$Aimbot = 0
If _ImageSearch("aim2.bmp", 1, $x1, $y1, 0) = 1 Then
    MouseMove($x1,$y1,3)
    MouseClick($x1,$y1,3);If image is found left click.
    $Aimbot = 0
    If $Aimbot = 0 then
       $coord = PixelSearch(789, 601, 794, 615, $searchcolor,25))
            If IsArray($coord) = 1 Then
                MouseClick('left', $coord[0], $coord[1], 1, 0);If image color is found click.
                sleep(100)
            EndIf
        EndIf   
Tooltip("AimBot is Auto-Shooting", 0, 0);Activate tooltip once aimbot is running.
Sleep(10000)
EndIf
Endfunc

what is the sleep for?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0