Jump to content

Search the Community

Showing results for tags 'compiled'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements and Site News
    • Administration
  • AutoIt v3
    • AutoIt Help and Support
    • AutoIt Technical Discussion
    • AutoIt Example Scripts
  • Scripting and Development
    • Developer General Discussion
    • Language Specific Discussion
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Categories

  • AutoIt Team
    • Beta
    • MVP
  • AutoIt
    • Automation
    • Databases and web connections
    • Data compression
    • Encryption and hash
    • Games
    • GUI Additions
    • Hardware
    • Information gathering
    • Internet protocol suite
    • Maths
    • Media
    • PDF
    • Security
    • Social Media and other Website API
    • Windows
  • Scripting and Development
  • IT Administration
    • Operating System Deployment
    • Windows Client
    • Windows Server
    • Office

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


WWW


Interests

Found 12 results

  1. Hi. If I embedd a compiled autoit script into my new script, is there a possibility to pass some data from the compiled embedded exe to my script? I know it's possible with an ini or txt-file. But is there something without creating a file? I plan to return an array or an unformatted string of datas with delimiters inside. Any ideas? Regards, Conrad
  2. Hi All, It has been bugging me for a while now. Can you view the AutoIt code from within a compiled exe. Like how you can with most .Net exe's by using a certain program. If this is possible, how then can I secure my program (if this method exists).
  3. So, I have this odd issue happening with UIAWrappers. When I run simplespy.au3 through SciTE, it finds the object I'm trying to work with, no problem. But, when I compile simplespy.exe, it can't find it. Another script that utilizes UIAWrappers is experiencing the same phenomenon. EDIT: Compiling as 32-bit or 64-bit does not affect this behavior. The trouble starts at the very first object I try to get via _UIA_getObjectByFindAll, so I included the $properties2Match array and the object properties that were returned by _UIA_getPropertyValue for that first object both when running from S
  4. Hello all I found this function in the Internet It is to play audio files from the compiled script I did not understand just one thing on this function func play($name, $wait = 0) local Const $SND_RESOURCE = 0x00040004 local Const $SND_ASYNC = 1 ; Play the file - the script will pause as it sounds if $wait = 0 then DllCall("winmm.dll", "int", "PlaySound", "str", $name, "hwnd", 0, "int", BitOR($SND_RESOURCE, $SND_ASYNC)) else DllCall("winmm.dll", "int", "PlaySound", "str", $nam
  5. Hi All, I'm using UseTraySetIcon("shell32.dll", xx) to set my tray icon to a specific icon while running, is there a way I can specify this icon when I compile my script into an exe so my exe icon is the same? Thanks!
  6. I am having issues with Windows SmartScreen blocking my compiled scripts. They run fine on my computer, but when I move them over to a different one, either by USB or a file hosting site, they get blocked by Windows SmartScreen. I have tested it on a number of computers, and it happens on all of them. I have also done this with scripts that do and don't require Admin, and it always happens. Is that related to this? I was thinking it might be, but I am not so sure since the only antivirus I have is Windows Defender. I wouldn't mind this happening since I realize you can click More info and th
  7. Hi, would there a way to disable enable the CUI after the exe was compiled If a certain Action is being used?
  8. Hi guys, please bare with me for a moment here... My goal: To be able to take the error line number returned by the EXE file and locate the actual line in the source. I believe most of the AutoIt users are coming to this issue at some point. I realize the final source, before the compilation is done, is the combined source of all the include files and the main script etc. So I figured if I have a way to get this combined source, that would give me a solution to this problem. And I spent the last couple of days (more than 10 hours a day) searching in the forum and asking some questions in dif
  9. Hi, I'm facing a Weird issue from yesterday on a particular machine. Tried a lot of things, but did not get any solution. I created a script that runs a notepad. It works well when the script is not compiled (ie, when I press F5 from scite editor). But when I compile it and run the exe, it throws an error saying "Windows cannot find notepad.exe. windows cannot access the path specified. you may not have permissions to the folder". Both scite editor and the exe are run in the same credentials (Admin) Does anybody have any idea on this? Rgds Roshith
  10. Hi every body! I have a strange problem that i can't solve: I made a GUI with a ToolBar, and i want to display custom icons in it. It's OK if i don't compile the script and i try to add the icons into my ImageList directly from disque, but when i compile and embeed my icons in the Exe file, then my icons wont appear at all! I made a simplified sample GUI to show you my problem, but here, it's another problem: the first added icon won't appear, and the others (2) appear, and the standard compiled script's icons appear normally! I really have a big headach in this! Here is joined
  11. AutoIT Version: 3.3.8.0 OS: Windows 7 x64 I've written the following script: main() Func main() Local $IPAddress = "192.168.1.1" Local $recv = "" ;~ Inicialização TCPStartup() $Socket = TCPConnect($IPAddress, 23) ;~ Usuário AguardaString($Socket, "username:") EnviaComando($Socket, "user") ;~ Senha AguardaString($Socket, "password:") EnviaComando($Socket, "password") ;~ Comando de reinicialização AguardaString($Socket, "TBS>>") EnviaComando($Socket, "reboot") ;~ Finalização TCPCloseSocket($Socket) TCPShutdown() EndFunc ;==>main Func AguardaString(Const $Socket, Const $st
  12. ;; suggested filename: "SplitLineMerge.au3" ;; Just run(build) it on it self to test it. (SciTe4AutoIt3) ;; Generally tested. (possible rare exceptions ignored.) ;; ... Not intended to be used on none Obfuscated au3 files. ;; include these 3 lines in your source code. (with <foobar> parts adjusted to your situation.) #AutoIt3Wrapper_Run_Obfuscator=y #Obfuscator_Parameters=/so #AutoIt3Wrapper_Run_After=<Filespec_To_AutoIt3.exe, (not accepting quotes:?)> /AutoIt3ExecuteScript "<Path_To>\SplitLineMerge.au3" "%in%" DebugOut('>Running: Obfuscated_SplitLineMerge, CMD: ' &
×
×
  • Create New...