Jump to content
Sign in to follow this  
gingerbloke

How to Transfer OutLook 2003 data from XP to Vista Machines?

Recommended Posts

gingerbloke

I have been looking on the Forum for ways to Transfer Outlook Emails, Account Settings & Contacts from one computer to another automatically when the Outlook Folders are saved to USB.

Loads of people explain how to backup the settings but I can't find anything to restore them back.Posted Image

If it helps I am moving the Email info from an XP machine to a vista machine and Outlook is 2003 edition.

I was thinking of mimicking the keystrokes in Outlook to 'manually import' the data if there is no other way.Posted Image

Any help would be appreciated

Gingerbloke

Share this post


Link to post
Share on other sites
Xenobiologist

That is no Autoit question. Just export the files and then import them.


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites
gingerbloke

That is no Autoit question. Just export the files and then import them.

That would be fair enough if I had the original system but it crashed. I only have the outlook backup folder containing all the files (inc .pst) and a registry backup.

I am hoping to write a program that will allow people to restore their email info automatically in such a situation as I find myself in.

I would have to be the first to admit, I use Outlook but do not understand how it works. By developing an Outlook restore program (with the forums help) maybe others will be able to use it if they find themselves in a similar situation to me..

Looking at peoples backup programs they have/are developing, they would be in a similar situation to me if their systems crashed, so I do feel it would be useful to others and once created, I will post it for people to use on the forum.

Gingerbloke

"PROGRAMMING IS THE ABILITY TO BE ABLE TO AUTOMATE PROCESSES THAT WOULD OTHERWISE BE TIME CONSUMING OR TEDIOUS"

AUTHOR: I don't know I just made it up! Posted Image

Share this post


Link to post
Share on other sites
Confuzzled

Just restore from your backup. You do a verified backup of your system regularly, don't you?

Files and Settings Wizard/Windows Easy Transfer should be the solution to your problem, if you had an intact system in the first place.

Have you searched for your PST file location on the new machine and copied the old one to the same folder and then just used the Outlook Data File Management to access it?

Vatican bank motto: Jesus saves, so should you...

Share this post


Link to post
Share on other sites
gingerbloke

Have you searched for your PST file location on the new machine and copied the old one to the same folder and then just used the Outlook Data File Management to access it?

Thanks for that,

Posted Image Do you know when you look to much and miss the obvious? I totally overlooked the "Outlook Data File Management"

I will now work on automating reading these file locations and copying the .PST files to them with AutoIt.

Ive, worked out restoring the Account settings (minus password for some reason?) from the Registry so nearly there..

Thanks again Confuzzled

Share this post


Link to post
Share on other sites
gingerbloke

HELP PLEASE!!!Posted Image

Im pulling my hair out and im already bald.....

The below script opens outlook (2003) and uses the 'Data File Management' Menu to try and read the location on the Drive of the 'Personal Files' folder.

Ive got it to identify the 'Personal Files' location but it will not read the text from the Filename String in the Edit Box so I am not able to get the file path.

From 'AutoIt Windows Info' I get the following identified for the Window:

Basic Window Info-

Title: Personal Folders

Class: #32770

Basic Control Info-

Class: Edit

Instance: 1

Control-

ClassnameNN: Edit1

ID: 2003

The data is shown as a file path but I keep getting blank (all the rems are the different things ive be trying)

dim $progressflag
dim $ipos
dim $iposa
dim  $loop
$progressflag = 0
;Start out look if not running
If not ProcessExists("OUTLOOK.EXE") Then
Run("C:\Program Files\Microsoft Office\OFFICE11\OUTLOOK.EXE")
sleep (5000)
EndIf
If WinExists("Outlook Today - Microsoft Outlook") Then 
WinActivate("Outlook Today - Microsoft Outlook", "")
$progressflag = 1
endif 
If WinExists("Calendar - Microsoft Outlook") Then 
WinActivate("Calendar - Microsoft Outlook", "")
$progressflag = 1
endif
If WinExists("Contacts - Microsoft Outlook") Then 
WinActivate("Contacts - Microsoft Outlook", "")
$progressflag = 1
endif
If WinExists("Tasks - Microsoft Outlook") Then 
WinActivate("Tasks - Microsoft Outlook", "")
$progressflag = 1
endif

if $progressflag = 1 then
while $progressflag <> 10
  If WinActive("Enter Network Password") Then
   Send("{ENTER}")
  ; sleep (1000) 
  EndIf
  If WinActive("Outlook Send/Receive Progress") Then
   Send("!s")
   Send("!c")
  ; sleep (1000)
  EndIf
  If WinActive("Outlook Today - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf
  If WinActive("Calendar - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf
  If WinActive("Contacts - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf
  If WinActive("Tasks - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf

  If WinActive("Outlook Data Files") Then
   ControlClick("", "", 701) ;go to list view
   Send("{UP}") ;work way up to top of list view
   Send("{UP}")
   Send("{UP}")
   Send("{UP}")
   Send("{UP}")   
   ;Check each entry in list view for our Personal File
   For $loop = 1 to 5
    $iPos = ""
   ; sleep (2000)
    Send("!s"); now go to settings lidt box item
    If WinActive("Personal Folders") Then
    ;ControlCommand("","","ListBox1", "FindString", 'string')
    $iPos = ControlGetText("Personal Folders", "", "RichEdit20WPT1")
    ToolTip($iPos, 0, 0)
   ;  sleep (2000) 
    if $iPos <> "Personal Folders" then 
      $iPosa = ""
    endif

    if $iPos = "Personal Folders" then 
    ;**************************************************************************************
    ;************************THE BELOW I THINK IS THE PROBLEM******************************
    ;**************************************************************************************
      If WinActive("Personal Folders") Then
   [b]    $iPosa = ControlGetText("Personal Folders", "", "Edit1")[/b]
    ToolTip($iPosa, 0, 0)   ;********* NOT GETTING $iPosa String.. It is blank *********                            
    MsgBox(4096, $loop, $iPosa)
    sleep (5000)
      endif
    endif  
    EndIf 
    Send("{ESCAPE}")
    Send("{DOWN}") ;work way up to top of list view
   next
  endif
;  If WinActive("Microsoft Office Outlook") Then
;   $iPosa = ControlGetText("Microsoft Office Outlook", "", "Edit1")
  ; sleep (1000)
;  EndIf 
  
; sleep (5000)
wend 
endif

Thanks for any help/advice anyone can give

gingerbloke

Share this post


Link to post
Share on other sites
failedtocompile

HELP PLEASE!!!Posted Image

Im pulling my hair out and im already bald.....

The below script opens outlook (2003) and uses the 'Data File Management' Menu to try and read the location on the Drive of the 'Personal Files' folder.

Ive got it to identify the 'Personal Files' location but it will not read the text from the Filename String in the Edit Box so I am not able to get the file path.

From 'AutoIt Windows Info' I get the following identified for the Window:

Basic Window Info-

Title: Personal Folders

Class: #32770

Basic Control Info-

Class: Edit

Instance: 1

Control-

ClassnameNN: Edit1

ID: 2003

The data is shown as a file path but I keep getting blank (all the rems are the different things ive be trying)

dim $progressflag
dim $ipos
dim $iposa
dim  $loop
$progressflag = 0
;Start out look if not running
If not ProcessExists("OUTLOOK.EXE") Then
Run("C:\Program Files\Microsoft Office\OFFICE11\OUTLOOK.EXE")
sleep (5000)
EndIf
If WinExists("Outlook Today - Microsoft Outlook") Then 
WinActivate("Outlook Today - Microsoft Outlook", "")
$progressflag = 1
endif 
If WinExists("Calendar - Microsoft Outlook") Then 
WinActivate("Calendar - Microsoft Outlook", "")
$progressflag = 1
endif
If WinExists("Contacts - Microsoft Outlook") Then 
WinActivate("Contacts - Microsoft Outlook", "")
$progressflag = 1
endif
If WinExists("Tasks - Microsoft Outlook") Then 
WinActivate("Tasks - Microsoft Outlook", "")
$progressflag = 1
endif

if $progressflag = 1 then
while $progressflag <> 10
  If WinActive("Enter Network Password") Then
   Send("{ENTER}")
  ; sleep (1000) 
  EndIf
  If WinActive("Outlook Send/Receive Progress") Then
   Send("!s")
   Send("!c")
  ; sleep (1000)
  EndIf
  If WinActive("Outlook Today - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf
  If WinActive("Calendar - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf
  If WinActive("Contacts - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf
  If WinActive("Tasks - Microsoft Outlook") Then
   Send("!f")
   Send("d")
  ; sleep (1000)
  EndIf

  If WinActive("Outlook Data Files") Then
   ControlClick("", "", 701) ;go to list view
   Send("{UP}") ;work way up to top of list view
   Send("{UP}")
   Send("{UP}")
   Send("{UP}")
   Send("{UP}")   
   ;Check each entry in list view for our Personal File
   For $loop = 1 to 5
    $iPos = ""
   ; sleep (2000)
    Send("!s"); now go to settings lidt box item
    If WinActive("Personal Folders") Then
    ;ControlCommand("","","ListBox1", "FindString", 'string')
    $iPos = ControlGetText("Personal Folders", "", "RichEdit20WPT1")
    ToolTip($iPos, 0, 0)
   ;  sleep (2000) 
    if $iPos <> "Personal Folders" then 
      $iPosa = ""
    endif

    if $iPos = "Personal Folders" then 
    ;**************************************************************************************
    ;************************THE BELOW I THINK IS THE PROBLEM******************************
    ;**************************************************************************************
      If WinActive("Personal Folders") Then
   [b]    $iPosa = ControlGetText("Personal Folders", "", "Edit1")[/b]
    ToolTip($iPosa, 0, 0)   ;********* NOT GETTING $iPosa String.. It is blank *********                            
    MsgBox(4096, $loop, $iPosa)
    sleep (5000)
      endif
    endif  
    EndIf 
    Send("{ESCAPE}")
    Send("{DOWN}") ;work way up to top of list view
   next
  endif
;  If WinActive("Microsoft Office Outlook") Then
;   $iPosa = ControlGetText("Microsoft Office Outlook", "", "Edit1")
  ; sleep (1000)
;  EndIf 
  
; sleep (5000)
wend 
endif

Thanks for any help/advice anyone can give

gingerbloke

Hi Gingerbloke

I have created a Office backup application front end, which i will release on the forums within the week. Just cant find a Autoit Pro to go over my script and help me correct any potential issues. currently have tested and all is working just some times CPU usage spikes to 66-100% and wanted some one to check my code.

If you can hang on until i can find a friendly Dev to check it if not ill just post it @ the end of the week.

ftc

Share this post


Link to post
Share on other sites
gingerbloke

Hi Gingerbloke

I have created a Office backup application front end, which i will release on the forums within the week. Just cant find a Autoit Pro to go over my script and help me correct any potential issues. currently have tested and all is working just some times CPU usage spikes to 66-100% and wanted some one to check my code.

If you can hang on until i can find a friendly Dev to check it if not ill just post it @ the end of the week.

ftc

Thanks failedtocompile,

I will look out for your project.

If anyone can still see where I went wrong with my code it would be appreciated for future projects.

Regarding your issue with CPU usage, I am currently writing a 'general' backup program and have found Hard Drive Access is the main bottleneck (reading and writing the data). Because it was slowing my system a bit more than I wanted I have changed the process priority to Idle and that seems to have worked well.

Just a thought if all else fails with your project

Gingerbloke

Share this post


Link to post
Share on other sites
failedtocompile

Hello Gingerbloke

I have posted my example script over HERE

If you need a little help let me know, I am not an Autoit Pro still progressing myself.

ftc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.