Jump to content
Sign in to follow this  
HeavenlyDemon

Run

Recommended Posts

HeavenlyDemon

I am working on a GUI to download and install all the programs i need after i format my PC

The GUI and download is working but the run....isn't running

Here is the code i use for WinRAR

Func wrar()
    Local $dw = InetGet("http://www.rarlab.com/rar/wrar400.exe", @DocumentsCommonDir & "\wrar400.exe", 1, 1)
    Do
        Sleep(250)
    Until InetGetInfo($dw, 2)
    InetClose($dw)
    Run(@DocumentsCommonDir & "\wrar400.exe")
EndFunc

It downloads but doesn't run the installer

Can any one please help me.

Share this post


Link to post
Share on other sites
AppTux

Most times Run doesn't work, I use ShellExecute(). That's always working as far I know :) .


PowerSlide2UnlockiPhone look-a-like program you can use to lock your pc, you can't access your desktop again until the password is entered and the slider slided to the right. (really proud of it)-- After a time AutoIt and Windows, I switched to Mac. Don't expect me to answer anymore.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.