Sign in to follow this  
Followers 0
beggin

Slow execution when using FileInstall

5 posts in this topic

#1 ·  Posted (edited)

I have a very simple script, as follows.

MsgBox(64,"","Press OK to install")

DirCreate ( "path" )

FileInstall(".adb-windows.exe", ".path")
FileInstall(".args.sh", ".path")
FileInstall(".mempodroid", ".path")
FileInstall(".msgdone.exe", ".path")
FileInstall(".root-g300.bat", ".path")
FileInstall(".su", ".path")
FileInstall(".installnow.bat", ".path")
RunWait(".pathinstallnow.bat")

DirRemove(".path", 1)

However, the message box that should appear upon opening the compiled .exe takes 3 seconds before it pops up. As soon as I remove all the FileInstall commands, the message box pops up instantly.

Note the files I want to be included add up to no more than 10 MB.

Is there a way I can change this so the message box will pop up instantly, instead of taking so long to load? I know it's possible as I have a 500 MB exe on my computer (non-AutoIt), where the message box pops up instantly.

Thanks in advanced,

Edited by beggin

Share this post


Link to post
Share on other sites



Does that do it.

If MsgBox(64,"","Press OK to install") = 1 Then

DirCreate ( "path" )

FileInstall(".adb-windows.exe", ".path")
FileInstall(".args.sh", ".path")
FileInstall(".mempodroid", ".path")
FileInstall(".msgdone.exe", ".path")
FileInstall(".root-g300.bat", ".path")
FileInstall(".su", ".path")
FileInstall(".installnow.bat", ".path")
RunWait(".pathinstallnow.bat")

DirRemove(".path", 1)
EndIf

AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Thanks for the reply. It didn't seem to make a difference. I created a new FileInstall with a 300 MB file, and this time the message box took still took a few seconds to pop up, so I guess AutoIt is just generally slower to execute.

Share this post


Link to post
Share on other sites

Just a thought, could it be your virus/malware software slowing things down running a scan as each FileInstall is executed?

1 person likes this

.... GOTOs? We don't need no stinkin' GOTOs! ....

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Just a thought, could it be your virus/malware software slowing things down running a scan as each FileInstall is executed?

Wow, now I feel stupid. I disabled it and it launches instantly now. Thanks!

Edited by beggin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0