Jump to content
Sign in to follow this  
karanmoonlight

Unable to maximize IE page with specific address

Recommended Posts

karanmoonlight

Hi people

I have prepared two same programs but only one of them is working fine even the codes and commands are all same

this program of opening the google is working fine

#include <IE.au3>


Sleep(500)
Local $oIE = _IECreate("https://www.google.co.in/?gfe_rd=ctrl&ei=ab8ZU4PrKKrW8gf5lYDgDg&gws_rd=cr")
Sleep(100)
_IELoadWait($oIE)
Sleep(100)
$hIE = _IEPropertyGet($oIE, "hwnd") ; Get Handle of the IE window
WinSetState("Google - Windows Internet Explorer","",@SW_MAXIMIZE)
Sleep(100)

2nd program which is not working even though the codes are same for both the programs but the 2nd one is not maximizing the IE page. Can anyone please help me???????????

#include <IE.au3>


Sleep(500)
Local $oIE = _IECreate("https://ericoll.internal.ericsson.com/sites/MUNA_RF_Engineering_Services/RF%20Engineering%20Design%20Services/Documents/Forms/AllItems.aspx?RootFolder=%2Fsites%2FMUNA%5FRF%5FEngineering%5FServices%2FRF%20Engineering%20Design%20Services%2FDocuments%2FATT%20RF%20Design%2FCentral%20Region")
Sleep(100)
_IELoadWait($oIE)
Sleep(100)
$hIE = _IEPropertyGet($oIE, "hwnd") ; Get Handle of the IE window
WinSetState("Central Region - All Documents - Windows Internet Explorer","",@SW_MAXIMIZE)
Sleep(100)

Share this post


Link to post
Share on other sites
mlukac89

#include <IE.au3>
Sleep(500)

$url = "https://ericoll.internal.ericsson.com/sites/MUNA_RF_Engineering_Services/RF%20Engineering%20Design%20Services/Documents/Forms/AllItems.aspx?RootFolder=%2Fsites%2FMUNA%5FRF%5FEngineering%5FServices%2FRF%20Engineering%20Design%20Services%2FDocuments%2FATT%20RF%20Design%2FCentral%20Region"

$oIE = _IECreate($url)
Sleep(100)
_IELoadWait($oIE)
Sleep(100)
$hIE = _IEPropertyGet($oIE, "hwnd") ; Get Handle of the IE window
WinSetState($hIE, "" ,@SW_MAXIMIZE)
Sleep(100)

Share this post


Link to post
Share on other sites
karanmoonlight

#include <IE.au3>

Sleep(500)
$url = "https://ericoll.internal.ericsson.com/sites/MUNA_RF_Engineering_Services/RF%20Engineering%20Design%20Services/Documents/Forms/AllItems.aspx?RootFolder=%2Fsites%2FMUNA%5FRF%5FEngineering%5FServices%2FRF%20Engineering%20Design%20Services%2FDocuments%2FATT%20RF%20Design&FolderCTID=0x012000996EDBBE338E5648A6ACBA29634947DE&View={CD8ED170-2F0F-43A5-902F-C30662738710}"
$oIE = _IECreate($url)
Sleep(100)
_IELoadWait($oIE)
Sleep(100)
$hIE = _IEPropertyGet($oIE, "hwnd")
WinSetState($hIE, "" ,@SW_MAXIMIZE)
Sleep(100)

hi team,

I am using the above program but stills its not maximizing my internet explorer webpage.... can anyone suggest any other way of doing so?????????

Share this post


Link to post
Share on other sites
karanmoonlight

Hi admin...can u pls help me?

Share this post


Link to post
Share on other sites
karanmoonlight

Auto it 3.3.10.2 and beta 3.3.11.3

IE 10

Share this post


Link to post
Share on other sites
karanmoonlight

Its not working on IE10 and beta 3.3.11.3. Can anyone else suggest something?

Share this post


Link to post
Share on other sites
karanmoonlight

No...i dont get any error in the code posted above. How do i check the return value? I am not so used to auto it so please guide me

Share this post


Link to post
Share on other sites
karanmoonlight

hi..i am unable to maximize my IE 10 using above code..can anyone please help me?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×