Jump to content
VaishnaviBUtpat

Automation of multiple Web pages

Recommended Posts

VaishnaviBUtpat
#include <string.au3>
#include <File.au3>
#include <MsgBoxConstants.au3>
#include <FileConstants.au3>
#include <WinAPIFiles.au3>
#include <Misc.au3>
#include <AutoItConstants.au3>
#include <Date.au3>
#include <IE.au3>
#include<Inet.au3>

Local $oIE = _IECreate("www.google.com",1,1,1,1)
Sleep(2000)
_IELoadWait($oIE)
Sleep(2000)
$o_form = _IEFormGetObjByName($oIE, "f")
$element = _IEFormElementGetObjByName($o_form,"q")
_IEFormElementSetValue($element,"INDIA")
Sleep(2000)
_IEFormSubmit($o_form)
Sleep(2000)
 _IELinkClickByText($oIE, "India - Wikipedia")
 Sleep(3000)
;~  $Set = _IEFormGetObjByName($o_form,"search")
;~  _IEFormElementSetValue($Set,"MAHARASHTRA")
$OIE1 = _IEPropertyGet($oIE, 'locationurl')
_IELoadWait($OIE1)
Sleep(2000)
MsgBox($MB_SYSTEMMODAL,"","New Page",3)
;~ $form = _IEFormGetObjByName($OIE1,"searchform")
;~ $select = _IEFormElementGetObjByName($form,"searchInput")
;~ Sleep(2000)
;~ _IEFormElementSetValue($select,"MAHARASHTRA")


_IELinkClickByText($OIE1,"second-most populous")

Hi all,

I am working on web automation using AutoIT.

But only two or three pages can be automated using AutoIT.

For the further pages the code is not working.

Can anybody help me with the same.

How to Automate multiple web pages....???

Share this post


Link to post
Share on other sites
Danp2

This is the third thread that you have started on the same subject. I tried to assist you in the other two, but you failed to respond essentially abandoning the thread. What's going to be different about this one?

Suggest that you review the prior threads.

  • Like 2

Share this post


Link to post
Share on other sites
VaishnaviBUtpat

Yup....

 _IEAttach() should be used to navigate through multiple web pages....!!!

Thank you...!!!

But its not working for the CRM Web UI.

What should I do

Share this post


Link to post
Share on other sites
VaishnaviBUtpat
On ‎11‎.‎09‎.‎2017 at 5:12 PM, Danp2 said:

This is the third thread that you have started on the same subject. I tried to assist you in the other two, but you failed to respond essentially abandoning the thread. What's going to be different about this one?

Suggest that you review the prior threads.

Yup....

 _IEAttach() should be used to navigate through multiple web pages....!!!

Thank you...!!!

But its not working for the CRM Web UI.

What should I do

Share this post


Link to post
Share on other sites
junkew
Quote

What should I do

Panic, cooldown and provide more information. With telling  "But its not working for the CRM Web UI."  you jump into conclusions we cannot follow. What do you mean with your CRM WEB UI. What are spying tools telling you about the page? ...... You omitt zillions of detail to a community that knows a lot on webautomation with AutoIt but does not have a clue on your environment.

Share this post


Link to post
Share on other sites
VaishnaviBUtpat
On ‎15‎.‎09‎.‎2017 at 6:26 PM, junkew said:

Panic, cooldown and provide more information. With telling  "But its not working for the CRM Web UI."  you jump into conclusions we cannot follow. What do you mean with your CRM WEB UI. What are spying tools telling you about the page? ...... You omitt zillions of detail to a community that knows a lot on webautomation with AutoIt but does not have a clue on your environment.

 

I am working on the automation of SAP work. There is one website on which I am working.

I have automated first two pages, but when it navigates to third page I am unable to automate it.

 

Edited by VaishnaviBUtpat

Share this post


Link to post
Share on other sites
junkew

What are tools like AU3INF and Simplespy telling you. See FAQ31 for references

Your definition of "providing more information" is not in sync with mine.

Without information about the html, first browser, 2nd browser, popup, .... its hard to give direction(s)

 

Share this post


Link to post
Share on other sites
VaishnaviBUtpat
18 minutes ago, junkew said:

What are tools like AU3INF and Simplespy telling you. See FAQ31 for references

Your definition of "providing more information" is not in sync with mine.

Without information about the html, first browser, 2nd browser, popup, .... its hard to give direction(s)

 

ok thank you...!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • DynamicRookie
      By DynamicRookie
      Hey there!
       
      Is there a way to detect movement only for 1 specific window?

      HWnd is not really working, it still detects movement in all the windows within the region

      This is my script:
       
      ;Checksum actual HotKeySet("{f2}", 'exit_') MsgBox(0, '', '0') Beep(500, 2000) $Hwnd = WinActive('') while 1 $Checksum = PixelChecksum(211, 650, 1094, 914, 1, $Hwnd) If PixelChecksum(211, 650, 1094, 914, 1, $Hwnd) <> $Checksum Then For $i = 1 To 100 Beep(1000, 50) Next MsgBox(0, '', 'New message!', 1) EndIf WEnd Func exit_() Beep(500, 1000) Exit 0 EndFunc I just want to check whenever a message comes because the app i use doesn't give notifications properly.

      Any help is really appreciated!
    • PramodR
      By PramodR
      Can you please see whats wrong im doing in the below code? i can read few registry entry but not all for eg, i am able to get value of "Shell" Key from the registry path  but not AutoAdminLogon which has the value of "1", is there any change i have to do to read numeric values?
       Global  $shello = RegRead ("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","Shell" )
       ConsoleWrite("This is Hello"& $shello)
      above command returns proper value , but same command with AutoAdminLogon returns null as shown in below ? infact registry has the value of 1.
       Global  $shello = RegRead ("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminLogon" )
       ConsoleWrite("This is Hello"& $shello)
    • Eminence
      By Eminence
      Hello,
      I've been searching on how to select the first row in my database which includes a time column based on the latest start_time date for today's date.
      This is my current code:
      Local $iCurrentDate = _Now() Local $sqlHandle = _dbOpen($sDbPath) Local $aResult, $iRows, $iCols _SQLite_GetTable2d($sqlHandle, "SELECT start_time FROM " & $srawDb & " ORDER BY datetime(start_time) DESC LIMIT 1", $aResult, $iRows, $iCols) _ArrayDisplay($aResult) _dbClose($sDbpath) What it does is it gets the first row entry in the database however it does not select the latest start_time entry in the database, it always select the first row. I've tried changing DESC to ASC to see if that will do it but the issue still remains. Any thoughts on this? Thanks in advance.
       
      *EDIT
      The date format in the database is by MM/DD/YYYY HH:MM:SS.
    • Trisha
      By Trisha
      Hello,
      I Have clicked on save as option to save a file, while doing that I need to rename a file appending with sysdate. I have searched in google find the below one line of code:
      FileMove("C:\somefile.txt", "C:\somefile1.txt"), When I am trying to append with sysdate. It is not happening. Please help me out  with the small issue.
    • TrashBoat
      By TrashBoat
      hey i would like to know if its possible to take a string like this
      $string = "onethousandninehundredeightyfive" and convert it into:
      $string = "one thousand nine hundred eighty five" i have something going on here but its no use
      $string = "onethousandninehundredeightyfive" Global $array[9] = ['one', 'two', 'three', 'four', 'five', 'six', 'seven', 'eight', 'nine'] Global $array1[19] = ['onethousand', 'twothousand', 'threethousand', 'fourthousand', 'fivethousand', 'sixthousand', 'seventhousand', 'eightthousand', 'ninethousand','tenthousand','hundred', 'twohundred', 'threehundred', 'fourhundred', 'fivehundred', 'sixhundred', 'sevenhundred', 'eighthundred', 'ninehundred'] MsgBox(0, 0, AddSpaces($string)) Func AddSpaces($string) Local $finalStr $length = StringLen($string) For $x = 0 To $length Local $trim = StringTrimRight($string, $x) For $h = 0 To 18 If $trim = $array1[$h] Then $finalStr = $finalStr & " " & $trim $string = StringTrimLeft($string, $h) $length = StringLen($string) EndIf Next For $z = 0 To 8 If $trim = $array[$z] Then $finalStr = $finalStr & " " & $trim $string = StringTrimLeft($string, $z) $length = StringLen($string) EndIf Next Next Return $finalStr EndFunc ;==>AddSpaces  
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.