Jump to content
Sign in to follow this  
VaishnaviBUtpat

Automation of multiple Web pages

Recommended Posts

#include <string.au3>
#include <File.au3>
#include <MsgBoxConstants.au3>
#include <FileConstants.au3>
#include <WinAPIFiles.au3>
#include <Misc.au3>
#include <AutoItConstants.au3>
#include <Date.au3>
#include <IE.au3>
#include<Inet.au3>

Local $oIE = _IECreate("www.google.com",1,1,1,1)
Sleep(2000)
_IELoadWait($oIE)
Sleep(2000)
$o_form = _IEFormGetObjByName($oIE, "f")
$element = _IEFormElementGetObjByName($o_form,"q")
_IEFormElementSetValue($element,"INDIA")
Sleep(2000)
_IEFormSubmit($o_form)
Sleep(2000)
 _IELinkClickByText($oIE, "India - Wikipedia")
 Sleep(3000)
;~  $Set = _IEFormGetObjByName($o_form,"search")
;~  _IEFormElementSetValue($Set,"MAHARASHTRA")
$OIE1 = _IEPropertyGet($oIE, 'locationurl')
_IELoadWait($OIE1)
Sleep(2000)
MsgBox($MB_SYSTEMMODAL,"","New Page",3)
;~ $form = _IEFormGetObjByName($OIE1,"searchform")
;~ $select = _IEFormElementGetObjByName($form,"searchInput")
;~ Sleep(2000)
;~ _IEFormElementSetValue($select,"MAHARASHTRA")


_IELinkClickByText($OIE1,"second-most populous")

Hi all,

I am working on web automation using AutoIT.

But only two or three pages can be automated using AutoIT.

For the further pages the code is not working.

Can anybody help me with the same.

How to Automate multiple web pages....???

Share this post


Link to post
Share on other sites
On ‎11‎.‎09‎.‎2017 at 5:12 PM, Danp2 said:

This is the third thread that you have started on the same subject. I tried to assist you in the other two, but you failed to respond essentially abandoning the thread. What's going to be different about this one?

Suggest that you review the prior threads.

Yup....

 _IEAttach() should be used to navigate through multiple web pages....!!!

Thank you...!!!

But its not working for the CRM Web UI.

What should I do

Share this post


Link to post
Share on other sites
Quote

What should I do

Panic, cooldown and provide more information. With telling  "But its not working for the CRM Web UI."  you jump into conclusions we cannot follow. What do you mean with your CRM WEB UI. What are spying tools telling you about the page? ...... You omitt zillions of detail to a community that knows a lot on webautomation with AutoIt but does not have a clue on your environment.

Share this post


Link to post
Share on other sites
On ‎15‎.‎09‎.‎2017 at 6:26 PM, junkew said:

Panic, cooldown and provide more information. With telling  "But its not working for the CRM Web UI."  you jump into conclusions we cannot follow. What do you mean with your CRM WEB UI. What are spying tools telling you about the page? ...... You omitt zillions of detail to a community that knows a lot on webautomation with AutoIt but does not have a clue on your environment.

 

I am working on the automation of SAP work. There is one website on which I am working.

I have automated first two pages, but when it navigates to third page I am unable to automate it.

 

Edited by VaishnaviBUtpat

Share this post


Link to post
Share on other sites

What are tools like AU3INF and Simplespy telling you. See FAQ31 for references

Your definition of "providing more information" is not in sync with mine.

Without information about the html, first browser, 2nd browser, popup, .... its hard to give direction(s)

 

Share this post


Link to post
Share on other sites
18 minutes ago, junkew said:

What are tools like AU3INF and Simplespy telling you. See FAQ31 for references

Your definition of "providing more information" is not in sync with mine.

Without information about the html, first browser, 2nd browser, popup, .... its hard to give direction(s)

 

ok thank you...!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gowrisankar
      Dear members of the forum,
      I'm working on a project in which I have to use Image recognition technique. 
      Due to client restrictions, I couldn't use AutoIt for this project. 
      Is there a way to use this DLL "ImageSearchDLL.dll" (which is used to do image recognition steps in AutoIt) in VB.Net to achieve the same result? 
      I have used this DLL few years before and got good results. If there is a latest version of this DLL and if you can share it, that will be helpful too.
      Any guidance is deeply appreciated.
    • By learner123
      Hi All,
       
      I am new to this AUTO IT and I have created a script that will open an app,enter pin and copy the code generated to clipboard. My java code call this autoIT script and use the copied generated code from clipboard.
      This works fine when server  window is on focus. My server is an windows server. 
      But when I minimize or disconnect the server, the script opens the app.exe but doesn't copy any value to clipboard.  
      Can anyone help me on this 😐
       
      Run("C:\Program Files (x86)\RSA SecurID Software Token\SecurID.exe")
      Local $hWnd=WinWait("abc - RSA SecurID Token") ; waits until the window is the active window
      $hWin = WinGetHandle("abc - RSA SecurID Token");
      ControlSend($hWnd,"","","1111") ; simulates pressing the Home key
      ControlSend($hWnd,"","","{ENTER}");
      ControlSend($hWnd,"","","^c");
      Sleep(1000) ;
      ControlSend($hWnd,"","","^c");
       
    • By learner123
      Hi All,
      So I have created a small autoIT script to enter pin into a RSA token(app which generate new code every 30 second), and copy the generated code.
      I have a java application which requires this code so every time my java-code requires this RSA code, it runs the autoIT script and the copied generated code is then used in my java application. 
      I have deployed this code on a windows server and it works fine when I am logged in and the window is on focus, But as soon as I schedule task and disconnect the server (not logged out only disconnect), or even minimize the server window, the autoIT scripts fails and its not able to copy the value.
       
      Please find below the code for AUTOIT.
       
      WinActivate("rsa - RSA SecurID Token") ; activates the window that has old in the tilte bar
      WinWaitActive("rsa - RSA SecurID Token") ; waits until the window is the active window
      Send("1111") ; simulates pressing the Home key, enters password to get the code
      Send("{ENTER}") ; simulates pressing the Enter key
      Sleep(1000) ;
      Send("^c") ; simulates pressing the CTRL+c keys (copy)
       
      Also I saw some post regarding that WINACTIVE only works when window is active. But my below AUTO IT script to handle windows pop up  works perfectly fine when the server is disconnected. 
       
      Opt("WinTitleMatchMode", 1)
      WinWait("https://url","","10")
      WinWaitActive("https://url","","10")
      Sleep(2000)
      Send("userid")
      Sleep(1000)
      Send("{TAB}")
      Sleep(1000)
      Send("passwrd")
      Send("{TAB}")
      Sleep(500)
      Send("{ENTER}")
       
       
    • By JuanFelipe
      Hello gyus, I try to make a code to login in a web page in my job, buy i can’t understand why my form is blocked, this is my code: 
      #include <ButtonConstants.au3> #include <EditConstants.au3> #include <GUIConstantsEx.au3> #include <StaticConstants.au3> #include <StringConstants.au3> #include <WindowsConstants.au3> #include <WinAPIFiles.au3> #include <FileConstants.au3> #include <File.au3> #include <Array.au3> #include <IE.au3> #include <Excel.au3> #include <GuiEdit.au3> #include <GuiStatusBar.au3> #include <DateTimeConstants.au3> #include <Date.au3> #Region ### START Koda GUI section ### Form=C:\noentry\koda_1.7.3.0\Forms\spoa.kxf $Form1 = GUICreate("Eva y Vehículos", 1200, 1000, 10, 10) $prueba = GUICtrlCreateButton("Prueba",10,990,50,20) ;VARIABLES ========================================================================================== $psi = "https://psi.policia.gov.co/PSI/Login.aspx?ReturnUrl=%2fPSI#no-back-button" $chequeVehiculos = "https://psi.policia.gov.co/PSI/frm_lista_chk.aspx" $evaluacionEva = "https://psi.policia.gov.co/PSI/eva_frmver.aspx" $oIE = ObjCreate("Shell.Explorer.2") $GUIActiveX = GUICtrlCreateObj ($oIE, 10, 10, 1180, 980) ;GUICtrlSetState(-1, $GUI_DISABLE) GUISetState(@SW_SHOW) $oIE.navigate($psi) ;_IELoadWait($oIE) _InicioSesion() #EndRegion ### END Koda GUI section ### While 1 $nMsg = GUIGetMsg() Switch $nMsg Case $GUI_EVENT_CLOSE Exit Case $prueba _InicioSesion() EndSwitch WEnd Func _InicioSesion() Local $username = _IEGetObjByName($oIE, "txtUsuario") Local $pass = _IEGetObjByName($oIE, "txtClave") Local $logina = _IEGetObjByName($oIE, "btnIngresar") $username.value="example" $pass.value="examplepass" _IEAction($logina, 'click') _IELoadWait($oIE) MsgBox(16,"","") EndFunc  
×
×
  • Create New...