Jump to content
Sign in to follow this  
Micheal

Winwaitactive with jenkins

Recommended Posts

Micheal

i have integrated the auit sript with jenkins. 

In my script, i am using winwaitactive but it is not working with jenkins.

 

Can any one help me on this.

Share this post


Link to post
Share on other sites
JLogan3o13

@Micheal welcome to the forum. You will often find you get a faster/more complete response if you post the code you're working with, rather than asking us to guess at what you're doing. :)

 


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites
Micheal

Run("D:\ABS\Install.exe")
WinWaitActive("ABS installation setup", "&Next", 100) ;

Send("!n")

 

if i run this code directly from autoit , It is working fine. But when i am trying to execute from jenkins , it is getting failed due to the "ABS installation setup" is getting minimized by jenkins.  

Share this post


Link to post
Share on other sites
MKolhar

Hey, any solution for this. I am  facing the same issue for Autoit in Jenkins (WinWaitActive, WinWait, WinActive does not work)

Share this post


Link to post
Share on other sites
caramen
Posted (edited)

Hi guys, 

A good thing is to be sure it s not working with the received title name.

$WinTitle = WinGetTitle ("[active]")



MsgBox (0, "WinTitle" , "WinTitle = "&$WinTitle)

An other way whould be to try with a part of the windows name and the option TitleMatch set on 2

Opt("WinTitleMatchMode", 2)

;If your windows name is "blablablabla 456789"

WinWaitActive ("blabla")

WinActivate ("blabla")

WinWaitActive("ABS")

 

 

Edited by caramen

IUIAutomation From Junkew WebDriver From Danp2  >>HIt The Thanks Button.<<

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×