Jump to content

Recommended Posts

Hi 

I'm trying to start Teams but as the Teams.exe is located in the profile folder it'll be different for different users. 

Any ideas on a solution? 

I've tried the below to no joy 

WriteToConsoleAndLog("-----Log: Run Teams.exe")
   Run("%userprofile%\AppData\Local\Microsoft\Teams\current\Teams.exe")
      if @error then
         Msgbox(16, "", "ERROR launching Teams.exe-> Attempting to launch Teams")
         WriteToConsoleAndLog("----ERROR launching Teams.exe-> Attempting to launch Teams")

      endif

 

Link to post
Share on other sites

Hi @CaptainBeardsEyesBeard,

what is the exact output/error of your Run() approach? Have you already tried ShellExecute() / ShellExecuteWait() instead?

Btw: 💡 As far as I can see, the teams.exe is located under:

%LocalAppData%\Microsoft\Teams\current\

I don't get your pain point to be honest 🤔 .

Best regards
Sven

________________
Stay innovative!

Edited by SOLVE-SMART

Stay innovative!

Spoiler

🌍 Au3Forums

📊 AutoIt limits/defaults

💎 Code Katas: [...] (comming soon)

🎭 Collection of GitHub users with AutoIt projects

🐞 False-Positives

🔍 Forum search

🔮 Me on GitHub

💬 Opinion about new forum sub category

 📑 UDF wiki list

✂ VSCode-AutoItSnippets

📑 WebDriver FAQs

👨‍🏫 WebDriver Tutorial (coming soon)

Link to post
Share on other sites

The default method for starting Teams can be found here (when setup to start on first logon)

Key =: HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Val =: com.squirrel.Teams.Teams

Run(@LocalAppData & '\Microsoft\Teams\Update.exe --processStart "Teams.exe" --process-start-args "--system-initiated"')

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...