Sign in to follow this  
Followers 0
Nefarious

Portability?

9 posts in this topic

#1 ·  Posted (edited)

Okay, so I've got a script written to do certain functions on a webpage...this script works perfectly on my home machine, but when I take it to work it just closes my browser window out. Has anybody experienced the same problem when taking a script from machine to machine and does anybody know of a way to stop this?

As a side note, the brower closes so fast after starting the script that I can't see what's being clicked on the screen to try and troubleshoot it.

Edited by Nefarious

Share this post


Link to post
Share on other sites



Okay, so I've got a script written to do certain functions on a webpage...this script works perfectly on my home machine, but when I take it to work it just closes my browser window out. Has anybody experienced the same problem when taking a script from machine to machine and does anybody know of a way to stop this?

As a side note, the brower closes so fast after starting the script that I can't see what's being clicked on the screen to try and troubleshoot it.

My guess is that you have different versions of IE and do not do proper error checking on your com objects. But that is just a wild, but qualified :think: , guess.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

are you using mousemove etc. If so it will most likely be the screen resolution.

Edited by RazerM

My Programs:AInstall - Create a standalone installer for your programUnit Converter - Converts Length, Area, Volume, Weight, Temperature and Pressure to different unitsBinary Clock - Hours, minutes and seconds have 10 columns each to display timeAutoIt Editor - Code Editor with Syntax Highlighting.Laserix Editor & Player - Create, Edit and Play Laserix LevelsLyric Syncer - Create and use Synchronised Lyrics.Connect 4 - 2 Player Connect 4 Game (Local or Online!, Formatted Chat!!)MD5, SHA-1, SHA-256, Tiger and Whirlpool Hash Finder - Dictionary and Brute Force FindCool Text Client - Create Rendered ImageMy UDF's:GUI Enhance - Enhance your GUIs visually.IDEA File Encryption - Encrypt and decrypt files easily! File Rename - Rename files easilyRC4 Text Encryption - Encrypt text using the RC4 AlgorithmPrime Number - Check if a number is primeString Remove - remove lots of strings at onceProgress Bar - made easySound UDF - Play, Pause, Resume, Seek and Stop.

Share this post


Link to post
Share on other sites

are you using mousemove etc. If so it will most likely be the screen resolution.

I use mouseclicks for pretty much everything, I have a seperate .ini file which houses the pixel locations for the script to find. I use the window spy program to grab the pixels. When I moved to a new computer I set these all up again yet I get the error where IE closes. I don't think posting the code would be relevant since it works fine at home, besides, posting it would make for one huge post.

Share this post


Link to post
Share on other sites

You shouldn't use mouse clicks, they can be very unreliable. Look at DaleHohms IE.au3 UDF library in Scripts & Scraps


AutoIt Console written in C#. Write au3 code right at the console :D_FileWriteToLineWrite to a specific line in a file.My UDF Libraries: MySQL UDF Library version 1.6 MySQL Database UDF's for AutoItI have stopped updating the MySQL thread above, all future updates will be on my SVN. The svn location is:kan2.sytes.net/publicsvn/mysqlnote: This will still be available, but due to my new job, and school hours, am no longer developing this udf.My business: www.hirethebrain.com Hire The Brain HireTheBrain.com Computer Consulting, Design, Assembly and RepairOh no! I've commited Scriptocide!

Share this post


Link to post
Share on other sites

You shouldn't use mouse clicks, they can be very unreliable. Look at DaleHohms IE.au3 UDF library in Scripts & Scraps

Can you link me to a specific post in Scripts & Scraps? I guess I'm being retarded, because I can't find it.

Share this post


Link to post
Share on other sites

Well, it turns out that the ToolTip I was using at location 0,0 was forcing the browser closed when I took it to another computer. I just moved the tool tip away from the upper-left corner and the problem is solved. Makes me feel stupid for not checking that first after days of scratching my head. I'm also wondering why it was closing the browser at work, but not at home....*shrugs* Anyway, problem solved. :think:

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

Okay, back to the drawing board....again...I tried it on yet another machine and the original problem still exists. Something in my script is sending the mouse to pixel location 0,0 and I can't figure out why. I'll strip down the code a bit and post it here later when I get home.

Edited by Nefarious

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0