Sign in to follow this  
Followers 0
RussMuss

Lotus notes and password

24 posts in this topic

Hi I have tried with another post to get my script working, but with no luck.

All I would like to do is open up Lotus notes then fill the edit box with my password.

I return no errors nothing happens except Lotus opens asking for a password

The String "IRIS.password2" comes from Au3info when I have my cursor over the password edit box

Any ideas what I am doing wrong?

I guess you will need Lotus notes on your computer to test it properly.

Thanks Russ

#include <ie.au3>

$Password = "mypassword";Lotus notes password

Run ("C:\Lotus\Notes\notes.exe" )

ControlSend ("Lotus Notes", "" ,"IRIS.password2", $Password )

Share this post


Link to post
Share on other sites



Hi I have tried with another post to get my script working, but with no luck.

All I would like to do is open up Lotus notes then fill the edit box with my password.

I return no errors nothing happens except Lotus opens asking for a password

The String "IRIS.password2" comes from Au3info when I have my cursor over the password edit box

Any ideas what I am doing wrong?

I guess you will need Lotus notes on your computer to test it properly.

Thanks Russ

#include <ie.au3>

$Password = "mypassword";Lotus notes password

Run ("C:\Lotus\Notes\notes.exe" )

ControlSend ("Lotus Notes", "" ,"IRIS.password2", $Password )

lol wierd i just automated a full notes configuration for my dads work today mmk to run i would try using shellexecutewait or after run put winwaitactive("win title here")

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

lol wierd i just automated a full notes configuration for my dads work today mmk to run i would try using shellexecutewait or after run put winwaitactive("win title here")

wow sorry im not thinking just use

$Password = "mypassword";Lotus notes password
Run ("C:\Lotus\Notes\notes.exe" )
winwaitactive("title here")
send($Password)

or try

$Password = "mypassword";Lotus notes password
shellexecutewait ("C:\Lotus\Notes\notes.exe" )
send($Password)

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

wow sorry im not thinking just use

$Password = "mypassword";Lotus notes password
Run ("C:\Lotus\Notes\notes.exe" )
winwaitactive("title here")
send($Password)

or try

$Password = "mypassword";Lotus notes password
shellexecutewait ("C:\Lotus\Notes\notes.exe" )
send($Password)
Thanks Thats looks easy. I will have to wait until I go to work, until I can test it. You say that you have done something similar. How do you go straight to your Lotus email after the password entry? As I remember there are several buttons and one of them has something like email on it. Edited by RussMuss

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Thanks Thats looks easy. I will have to wait until I go to work, until I can test it. You say that you have done something similar. How do you go straight to your Lotus email after the password entry? As I remember there are several buttons and one of them has something like email on it.

make a seperate program go into notes type in password there should be only one button to get to mail i think i dont recall in your new program put this code

hotkeyset("!c","clip")
while 1
    $pos=mousegetpos()
    tooltip($pos[0]&","&$pos[1])
WEnd

func clip()
    clipput($pos[0]&","&$pos[1])
    exit
EndFunc

get your mouse over that button then hold alt and press c the program should close then go into your automation program and type in mouseclick("left",here press ctrl+v) that should do it.

-----------------------EDIT------------------

heres a good idea

use this

$Password = "mypassword";Lotus notes password
shellexecutewait ("C:\Lotus\Notes\notes.exe" )
send($Password)
sleep(500)
mouseclick("left",here press ctrl+v)

or of course if you want it to be perfect you could use pixelgetcolor but just play around with the number it sleeps for that should work good...

Edited by EagleClaw

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

make a seperate program go into notes type in password there should be only one button to get to mail i think i dont recall in your new program put this code

hotkeyset("!c","clip")
while 1
    $pos=mousegetpos()
    tooltip($pos[0]&","&$pos[1])
WEnd

func clip()
    clipput($pos[0]&","&$pos[1])
    exit
EndFunc

get your mouse over that button then hold alt and press c the program should close then go into your automation program and type in mouseclick("left",here press ctrl+v) that should do it.

-----------------------EDIT------------------

heres a good idea

use this

$Password = "mypassword";Lotus notes password
shellexecutewait ("C:\Lotus\Notes\notes.exe" )
send($Password)
sleep(500)
mouseclick("left",here press ctrl+v)

or of course if you want it to be perfect you could use pixelgetcolor but just play around with the number it sleeps for that should work good...

Thanks for the code. I tried your piece of code and it puts in the password in but it comes back with a message from lotus notes saying it is invalid. I know the password is correct and it works when I type it in manually.

why is this?

Russ

Share this post


Link to post
Share on other sites

send($Password, 1)

Try this.

Share this post


Link to post
Share on other sites

Why won't you activate SSO (Single Sign On) in Lotus Notes. Then if you do that you can merge it with the same pass as your domain account and when you log in to Lotus Notes while logged in to Windows with domain pass you won't need to type in Lotus Notes pass.


My little company: Evotec (PL version: Evotec)

Share this post


Link to post
Share on other sites

Hi,

I have this one:

Opt('SendKeyDelay', 1)
Opt('WinTitleMatchMode', 2)
#include <string.au3>

HotKeySet('^!x', '_end')

Global Const $pathPWD = @AppDataDir & '\AutoLoginTM\AutoLoginTM_PWD.ini'
Global Const $pathPaths = @AppDataDir & '\AutoLoginTM\AutoLoginTM_Path.ini'
Global Const $waitTitle = 'Lotus Notes'
Global Const $waitTitle2 = '- XXX'
Global Const $waitTitle3 = 'Arbeitsbereich'
Global Const $process = 'nlnotes.exe'
Global Const $defaultPath = RegRead('HKEY_LOCAL_MACHINE\SOFTWARE\Lotus\Notes', 'Path') & 'nlnotes.exe'

_checkForAlreadyRunningInstance()
_checkIfFileExists($pathPWD, 'AutoLoginTM_PWD.ini')
_run()
Exit (0)

Func _run()
    Local $password = _StringEncrypt(..... some encryption ...)
    ShellExecute($defaultPath, '', '', 'open', @SW_SHOW)
    If WinWait($waitTitle, '', 50) = 0 Then Exit (0)
    WinSetState($waitTitle2, '', @SW_MAXIMIZE)
    ControlFocus($waitTitle, '', '')
    ControlSend($waitTitle, '', '', $password & '{Enter}')
    If WinWait($waitTitle3, '', 50) = 0 Then Exit (0)
    ControlSend($waitTitle3, '', '', '!l1')
EndFunc   ;==>_run

Func _checkForAlreadyRunningInstance()
    If ProcessExists($process) Then
        MsgBox(64, 'Information', 'Das Skript wurde beendet, weil eine Instanz von ' & $process & ' bereits aktiv ist!', 3)
        Exit (0)
    EndIf
EndFunc   ;==>_checkForAlreadyRunningInstance

Func _checkIfFileExists($path, $name)
    If Not FileExists($path) Then
        MsgBox(16, 'Error', 'Die ' & $name & ' konnte im Pfad ' & @AppDataDir & '\AutoLoginTM\ nicht gefunden werden.', 5)
        Exit (0)
    EndIf
EndFunc   ;==>_checkIfFileExists

Func _end()
    MsgBox(64, 'Information', 'Sie haben STRG+ALT+X gedrückt und damit das Skript sofort beendet!', 2)
    Exit (0)
EndFunc   ;==>_end

So long,

Mega


Scripts & functions Organize Includes Let Scite organize the include files

Yahtzee The game "Yahtzee" (Kniffel, DiceLion)

LoginWrapper Secure scripts by adding a query (authentication)

_RunOnlyOnThis UDF Make sure that a script can only be executed on ... (Windows / HD / ...)

Internet-Café Server/Client Application Open CD, Start Browser, Lock remote client, etc.

MultipleFuncsWithOneHotkey Start different funcs by hitting one hotkey different times

Share this post


Link to post
Share on other sites

Why won't you activate SSO (Single Sign On) in Lotus Notes. Then if you do that you can merge it with the same pass as your domain account and when you log in to Lotus Notes while logged in to Windows with domain pass you won't need to type in Lotus Notes pass.

Out IT dept sets the password options - so I have no choice. I am trying to make life easier for myself and others in our so we don't have to tediously navigate through all the hurdles put in front of us. :-)

Share this post


Link to post
Share on other sites

Thanks for the replies. I think I know what my problem is : If you have ever seen Lotus notes password it is a bit like typing in each character 'individually'. Lotus verifies each character. You can see this by the little animation of a set of keys on the edit box. It is not possible to just paste the whole password in one go! How could I 'type' each character individually? Perhaps it can not be done?

Cheers Russ

Share this post


Link to post
Share on other sites

I have also tried breaking mY password so each letter is typed. If my password is "tomato"

Then I have tried the below code. It looked promising because the little animation started to move,

but it just did not accept it.

Those guys who make Lotus Are very CUNNING!

shellexecutewait ("C:\Program Files\Lotus\Notes\notes.exe" )

sleep(200)

send("t")

sleep(200)

send("o")

sleep(200)

send("m")

sleep(200)

send("a")

sleep(200)

send("t")

sleep(200)

send("o")

sleep(200)

Share this post


Link to post
Share on other sites

I have also tried breaking mY password so each letter is typed. If my password is "tomato"

Then I have tried the below code. It looked promising because the little animation started to move,

but it just did not accept it.

Those guys who make Lotus Are very CUNNING!

shellexecutewait ("C:\Program Files\Lotus\Notes\notes.exe" )

sleep(200)

send("t")

sleep(200)

send("o")

sleep(200)

send("m")

sleep(200)

send("a")

sleep(200)

send("t")

sleep(200)

send("o")

sleep(200)

it works for me im not sure why yours wouldnt btw im using lotus notes 7

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

it works for me im not sure why yours wouldnt btw im using lotus notes 7

At home I have Lotus 7 and work Lotus 6.5.

They both have the same problem.

My password has a combination of letters and numbers and a !

It appears the the last 3 characters which are numbers just are not being inputted,

although this is hard to tell as the characters come up with X in the edit box.

Does your password have numbers and letters and a ! ?

Russ

Share this post


Link to post
Share on other sites

At home I have Lotus 7 and work Lotus 6.5.

They both have the same problem.

My password has a combination of letters and numbers and a !

It appears the the last 3 characters which are numbers just are not being inputted,

although this is hard to tell as the characters come up with X in the edit box.

Does your password have numbers and letters and a ! ?

Russ

letters and numbers but not a ! show me the code for putting in the ! maybe thats whats wrong

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

letters and numbers but not a ! show me the code for putting in the ! maybe thats whats wrong

okay my password is similar to this "we!com700"

so I have he following code

I have slowed it down so it makes it a little easier to understand whats going on.

#include <ie.au3>

Run ("C:\Lotus\Notes\notes.exe" )

sleep(200)

send("w")

sleep(1000)

send("e")

sleep(1000)

send("!")

sleep(1000)

send("c")

sleep(1000)

send("o")

sleep(1000)

send("m")

sleep(1000)

send("7")

sleep(1000)

send("0")

sleep(1000)

send("0")

sleep(1000)

Share this post


Link to post
Share on other sites

okay my password is similar to this "we!com700"

so I have he following code

I have slowed it down so it makes it a little easier to understand whats going on.

#include <ie.au3>

Run ("C:\Lotus\Notes\notes.exe" )

sleep(200)

send("w")

sleep(1000)

send("e")

sleep(1000)

send("!")

sleep(1000)

send("c")

sleep(1000)

send("o")

sleep(1000)

send("m")

sleep(1000)

send("7")

sleep(1000)

send("0")

sleep(1000)

send("0")

sleep(1000)

all i had to do was run it in notepad and here you go send("{!}") :whistle:

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

all i had to do was run it in notepad and here you go send("{!}") :whistle:

Eagle Claw thanks for your effort - unfortunately that did not work either. I also tried putting brackets {} around all the characters - but with no success

Its just a complete mystery why it does work......

Russ

Share this post


Link to post
Share on other sites

Eagle Claw thanks for your effort - unfortunately that did not work either. I also tried putting brackets {} around all the characters - but with no success

Its just a complete mystery why it does work......

Russ

that is very wierd give me the current code your using and try using it in notepad and tell me if it doesnt type something

[quote name='PsaltyDS' post='635433' date='Jan 27 2009, 07:04 AM']Larry is a mass murderer?! It's always the quiet, clean cut, bald guys... [/quote]

Share this post


Link to post
Share on other sites

that is very wierd give me the current code your using and try using it in notepad and tell me if it doesnt type something

I have tried it in notepad and the password types out perfectly- using send("{!}") . Its just Lotus notes and its encryption - something weird is going on, as you say.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0